Renderização do WhatsApp web com o Firefox

Olá pessoal, como vão?

Recentemente, inclusive graças a um tópico gerado aqui mesmo no fórum sobre o Firefox, resolvi voltar usá-lo mais à fundo como uso diário para comparar como está de fato atualmente em relação aos concorrentes.

Indo direto ao ponto, um dos acessos que faço é no WhatsApp Web e acabei percebendo uma coisa peculiar no uso. Observem na imagem abaixo que as letras “g” (especificamente no exemplo) e “j” ficam “comidas” na parte de baixo do campo de digitação.

firefox

Mais precisamente há uma rolagem vertical nesse campo e que faz com que o comportamento seja esse. O mesmo não ocorre se eu usar um navegador de base Chromium como o Brave por exemplo.

chrome

Já fiz alguns ajustes no about:config nas flags gfx.font_rendering e não consegui normalizar isso. Pesquisas pelo Reddit também não me retornaram resultado esperado.

Algum de vocês passa pelo mesmo problema? Ou se passou como conseguiu resolver? Penso que não é uma falta de fontes, já que no outro navegador tudo funciona normalmente. Ou é o caso de chutar o balde de vez e tratar o Firefox como batalha perdida, apesar dos recursos?!

Obrigado desde já a quem responder.

1 curtida

Em “about:support” a opção “composição” está “webrender” ou “webrender (software)”? pois dependendo do hardware/versão do opengl suportado o Firefox pode não oferecer aceleração por hardware.
Está usando Firefox na última versão? Testou flatpak, snap, deb…? tentou abrir o Firefox com outro perfil?

1 curtida

Boa tarde! Acredito que o problema não esteja diretamente no Firefox, mas no sistema (distro) que vc está usando. Segue abaixo um print do whatsapp Web no Firefox em meu Ubuntu 20.04 renderizado de forma correta (como deve ser).

image

1 curtida

“Webrender” apenas.

Uso (iniciando) no Arch, então é a última versão dos repositórios. Não cheguei ainda a testar outros formatos nem outro perfil, mas irei verificar.

Edit: Testado com a versão Flatpak, mesmo comportamento da imagem.

Estou utilizando o Arch, fiz os procedimentos que a Wiki indica para a instalação das fontes e ainda assim não resultou em nada. :slightly_frowning_face:
Aliás as fontes foram uma das primeiras coisas que verifiquei. Fiz uma comparação com o Ubuntu nas configurações de fontes, fiz os mesmos ajustes de lá e também sem resultado.

Obrigado vocês dois pelas respostas. :+1:t4: :vulcan_salute:t4:

1 curtida

Q chato esse problema. Espero que encontre alguma solução, ou alguém que use arch aqui no fórum possa te ajudar.

1 curtida

Wayland ou Xorg?

Contigurou aceleração de hardware no sistema?

Intel, nvidia ou amd?

1 curtida

Xorg.

glxinfo | grep "direct rendering"
direct rendering: Yes

Pelas informações, sim, está ativa.

AMD.

Ok.

https://wiki.archlinux.org/title/Hardware_video_acceleration

Já viu informações da placa no archwiki

https://wiki.archlinux.org/title/AMDGPU#Troubleshooting

1 curtida

Vi mais cedo essa seção de troubleshoot, no caso creio eu, o tópico especificamente sobre o Firefox.

by going to about:config and setting gfx.webrender.all to true. Restart Firefox for changes to take effect.

Estava como false, mudei para true, idem, mesmo comportamento. Suponho que o blocklisted se deva a falta de suporte de hardware, mudei de volta a flag acima para false.

Webrender já é ativado por padrão. Verifica nas configurações do Firefox na parte de fontes e tenta mudar lá a fonte ou o tamanho.

2 curtidas

Você ativou no sistema?

https://wiki.archlinux.org/title/Habirdware_video_acceleration

Seu firefox está habilitado para wayland?

WebRender é para wayland.
Não tenho certeza

1 curtida

Veja aqui

https://wiki.archlinux.org/title/Firefox/Tweaks#Enable_Legacy_OpenGL_compositor

Já tentou desabilitar a aceleração do firefox na janela configuração ou opções do navegador?

1 curtida

Já tinha feito isso, mas só funciona se eu desmarcar a opção para os sites usem a fonte do navegador. Testei com a Noto (a que está) e a DejaVu.

Se a informação de que está ativa é a que postei no post #7, então deve estar. Algum outro comando para verificar se está ativa?

Eu segui e instalei os pacotes indicados neste link. Horizon Chase talvez não seja um parâmetro para avaliar mas tem funcionando muito bem. Creio que se tivesse algum erro ele não funcionaria ou funcionaria mal.

Essa flag estava desabilitada, habilitei e sem efeito.

PS: Estou amando a experiência com o Arch, só esse ponto aí do Firefox que me pegou.

Hardware video acceleration

https://wiki.archlinux.org/title/Hardware_video_acceleration

ATI/AMD

ATI and AMDGPU open-source drivers support both VA-API and VDPAU:

  • VA-API on Radeon HD 2000 and newer GPUs is supported by libva-mesa-driver.
  • VDPAU on Radeon R300 and newer GPUs is supported by mesa-vdpau.

AMDGPU PRO proprietary driver is built on top of AMDGPU driver and supports both VA-API and VDPAU.

Verifying VA-API

Verify the settings for VA-API by running vainfo, which is provided by libva-utils:

Verifying VDPAU

Install vdpauinfo to verify if the VDPAU driver is loaded correctly and retrieve a full report of the configuration:

Configuring VA-API

You can override the driver for VA-API by using the LIBVA_DRIVER_NAME environment variable:

  • AMD:
    • For AMDGPU driver use radeonsi.
      pensei que você estava utilizando Arch…

Configuring VDPAU

You can override the driver for VDPAU by using the VDPAU_DRIVER environment variable.

The correct driver name depends on your setup:

  • For the open source AMD driver set it to the proper driver version depending on your GPU, see #Verification.

desativar no firefox…
desmarque aceleração de hardware

Configuração de placa.

https://wiki.archlinux.org/title/ATI
ou
https://wiki.archlinux.org/title/AMDGPU

por exemplo, para radeon

Below is a sample configuration file of /etc/X11/xorg.conf.d/20-radeon.conf:

Section "Device" 
Identifier "Radeon"
Driver "radeon" 
Option "AccelMethod" "glamor" 
Option "DRI" "3" 
Option "TearFree" "on" 
Option "ColorTiling" "on" 
Option "ColorTiling2D" "on"
Option "TearFree" "true"
 EndSection

AMDGPU

/etc/X11/xorg.conf.d/20-amdgpu.conf

Section "Device"
     Identifier "AMD"
     Driver "amdgpu"
     Option "TearFree" "true"
     Option "DRI" "3"
EndSection
1 curtida

Eu acho que o problema não está na decodificação vaapi, q só serve pra reprodução de vídeos usando a GPU. Sugiro verificar configurações no sistema visto que o Firefox funciona normalmente em outras distros.

1 curtida

Funciona sem problema no wayland com placa de vídeo intel.

Não cheguei a testar pelo xorg.

1 curtida

Se estiver falando do vaapi funciona no X11 desde a versão 85. Mas como falei n acho q tenha a ver com o problema. Na verdade todo o suporte completo a GPU no Firefox já funciona a bastante tempo, pelo menos em distros da família Ubuntu.

1 curtida

Também acho que não é o vappi, acredito que seja configuração da placa de vídeo.

1 curtida

Não é um problema no Arch, aqui está normal:
Screenshot_20220324_230818
Screenshot_20220324_231101

1 curtida

Então pode ser o que o @swatquest falou. Alguma coisa no vídeo msm.

1 curtida