Remover KDE do ArchLinux

Olá, bom dia!

Podem me ajudar?

Instalei hoje o ArchLinux junto com o Gnome, porém percebi agora que por algum motivo o KDE foi instalado junto. Sou iniciante no linux e não sei se isso é normal.
Outra coisa estranha, é que eu instalei o Latte Dock no Gnome e não funciona de jeito nenhum, mas quando entrei no KDE lá estava o maroto funcionando normalmente.

Podem me ajudar a remover o KDE?

O KDE deve ter vindo como dependência da Latte Dock, salvo engano ela não funciona em ambientes GTK. Você pode usar a Plank Dock no lugar.

Para remover você pode usar algo como sudo pacman -Rcss latte-dock
Só toma cuidado para não remover algo necessário ao Gnome por engano, como o xorg ou o seu driver de vídeo.

1 Curtida

Removi só o latte-dock pois quando dei o comando abaixo vi que nos pacotes além do plasma também estava o Xorg:

Mas será que existe uma forma segura de remover apenas o KDE e as suas dependências sem impactar no restante do sistema?

Instalei o Plank mas quando inicializo não acontece nada. Porém quando entro no Gnome Classic lá está ele. Ta difícil essa vida kk

Rsrsrs
Eu não uso nenhuma das duas docks, então não posso ajudar muito em fazê-las funcionar. Tente procurar na Arch Wiki, sempre tem informações úteis lá.

Tira um “s” do comando, deixando apenas -Rcs. Se ainda estiver removendo algum pacote necessário, tire o outro e deixe apenas -Rc. O “s” é para remover dependências desnecessárias, mas algumas vezes elas são bem necessárias :joy:
Você pode pesquisar os pacotes instalados do KDE com pacman -Qs plasma, por exemplo, e depois removê-los.

1 Curtida

Não é nada recomendado utilização do pacman -Rc, pois pode remover pacotes necessários.

A melhor maneira é utilizar o pacman -Rs, que remove o pacote desejado e as dependências não mais exigidas por nunhum outro pacote instalado.
Algumas vezes o comando pacman -Rs pode recusar-se a remover um grupo que contém pacotes necessários, nesse caso pode utilizar pacman -Rsu e depois instalar novamente os outros pacotes.

1 Curtida

Se instalou os pacotes via meta, basta um # pacman -Rsn plasma-meta

Para o plank abrir quando iniciar a sessão tem que adicionar o plank na inicialização do sistema.

Para fazer isso basta acesar o diretório:

$ cd ~/.config/autostart

Crie o arquivo plank.desktop

$ touch plank.desktop

Dentro do arquivo plank.desktop com seu editor preferido, copie, cole o conteúdo abaixo e salve o arquivo.

[Desktop Entry]
Name=Plank
GenericName=Dock
Comment[pt_BR]=Estupidamente simples.
Comment=Stupidly simple.
Categories=Utility;
Type=Application
Exec=plank
Icon=plank
Terminal=false
NoDisplay=false
X-GNOME-Autostart-enabled=true
Hidden=false
Name[en_US]=Plank
Comment[en_US]=Stupidly simple.
X-GNOME-Autostart-Delay=0