Quando tento instalar o programa "Stremio" no meu desktop Linux Pop OS, dá um erro de "problema de dependência"

Primeiramente, obrigado pela resposta!
Coloquei o seu comando no terminal, veja o que diz:


Oque vc acha que eu faço? Não é o primeiro erro que me ocorre. Será que deixo o Pop OS e vou pro Ubunto “Ubunto” mesmo? Formato o computador? Ou será que o erro não é do SO.
De qualquer forma obrigado pela força!

Cole esse comando e rode no terminal:

sudo apt install nodejs qml-module-qt-labs-platform qml-module-qtquick-controls qml-module-qtquick-dialogs qml-module-qtwebchannel qml-module-qtwebengine

E o último pacote, tu instala por meio do pacote .deb:
http://mirrors.kernel.org/ubuntu/pool/multiverse/f/fdk-aac/libfdk-aac1_0.1.6-1_amd64.deb

É só isso. Qualquer coisa poste aqui.

amigo tente instalar via flatpak já que estar dando problema de dependência,coisa que flatpak não sofre. para ajudar siga esse tutorial:Como instalar o poderoso Stremio no Linux via Flatpak

1 curtida

use o comando

sudo apt install -f

Qual distro e qual versão da distro você tá usando?

Pessoal, parece que é problema do stremio mesmo, o pacote deve estar com dependencia quebrada. Acabei de ver outro post falando a mesma coisa. No caso a solução seria faltpak mesmo como o talls falou

Não consigo instalar absolutamente nada! Já troquei de linux 3 vezes (Pop OS, Linux Ubuntu normal e agora to com um sabor diferente que esqueci o nome, todos .deb). O computador veio com windows, novinho, comprei a 5 dias na loja. AMD Ryzen 5 12gb.

Não consigo instalar nada, jogos, programas, nada. Nem mesmo apps da loja do proprio Linux.

Já tentei pelo terminal, colocando códigos pra baixar os pacotes… Nada funciona. O que pode ser? Já troquei de Linux várias vezes.
Me estendam uma mão!

Você deve estar errando algo muito básico. Não precisava ficar trocando de distribuição.

Primeiro você tem que entender que os programas pra Linux tradicionalmente são distribuídos em pacotes .deb (no caso do Debian, *ubuntu e derivados) ou .rpm (no caso do Mageia, Fedora, etc); na verdade têm mais, mas vamos manter as coisas simples. Por exemplo, o pacote vlc (do reprodutor VLC) exige outros pacotes como vlc-bin, vlc-plugin-base, etc; é necessário que todos esses pacotes sejam instalados para que o programa VLC funcione. Mas atenção, o instalador de pacotes da sua distribuição Linux deveria fazer isso pra você!

O pacote que você baixou exige algumas dependências. Baixei o pacote .deb do Stremio, o abri com o QApt (o instalador de pacotes .deb que já vem no Kubuntu) e ele listou as seguintes dependências exibidas na janela em destaque.


Mas isso é muito esquisito. Você deve estar errando e alguma coisa. Rapaz, primeiro veja se seu sistema está atualizado. Rode o comando abaixo para fazer isso:

sudo apt update && sudo apt upgrade

Vai pedir para você digitar a sua senha. É normal que nada seja exibido enquanto você digita a senha.

A loja de aplicativos deverá estar funcionando normalmente depois disso.


Agora vamos ver esse Stremio. O que posso sugerir pra você é que você instale o QApt e abra o arquivo .deb através dele.

Para baixar o QApt, use o comando abaixo:

sudo apt install qapt-deb-installer
2 curtidas

Qual distro você está usando e qual a versão?
Dependendo da versão que você baixou, talvez ela não seja mais suportada.
Utilize o comando

lsb_release -a

Para instalar o Stremio via terminal, primeiro acesse a pasta onde baixou e use os comandos

sudo dpkg -i nome_arquivo.deb
sudo apt install -f

Em seguido tentei abrir o Stremio pelo terminal. Suspeito que ainda falta uma coisa pra funcionar.

1 curtida

Obrigado, o seu comentário foi muito útil pra me ajudar a entender um pouco mais o Linux.
Eu estava esperando que assim que eu desse o boot no windows eu apenas abriria o computador, abriria o terminal, daria os comandos para baixar meus programas, jogos etc e ele iria fazer isso sem problemas.

Agora, nem pra executar uma instalação simples de um arquivo ele consegue.
Por exemplo, o Java eu consegui instalar sem nenhum problema através do terminal, e logo em seguida instalei o Minecraft (jogo programado em Java), apenas seguindo os comandos listados no “Blog do Edivaldo”. Foi simples e rápido como tudo deveria ser.

Um outro problema que tenho tido e com um tal de dkpg que fica dando erro, novamente na instalação. Já deu em vários programas diferentes e em várias tentativas de instalação.

Sei que tenho que estudar mais já que nada se aprende de mão beijada, mas a sensação que tenho é que a cada passo que eu sigo, a cada simples instalação que eu coloco no meu terminal de código, a cada arquivo .deb que eu baixo… é uma luta. Cada hora um erro diferente.
Deveria ser só baixar, instalar e pronto!

bom, vamos por partes.

Eu já reparei que muita coisa no blog do edivaldo está desatualizada. era válido para o Ubuntu 12 (o que eu começei pra ser sincero kkkk) mas hoje algumas muitas coisas mudaram pra melhor e os tutoriais não foram atualizados. Não sei se o blog continua ativo ou se é o google personalizando minhas buscas, mas quando mostra algo deles está parado no tempo.

Segundo: como o pessoal já falou, as distribuições linux gerenciam as instalações então é estranho não baixar as dependências junto. Conseguiu atualizar o sistema? Houve algum erro na instalação? Da próxima vez que for instalar e der erro , poste para sabermos o que está acontecendo (a saída do terminal). ou procure no google também. É muito provavel haver a resposta em alguma postagem já.

ah, uma coisa importante: a maioria dos gerenciadores bloqueiam instalações ao mesmo tempo, assim voce tem que esperar uma terminar para intalar outra. Só que também é possivel fazer uma “ordem em sequência”. Não me lembro muito do apt, mas resolve fazer “sudo apt install pacote1 && sudo apt install pacote 2”. existem outros meios, mas esse é o básico

e por fim, espero que isso não te desanime, o mundo linux e open sourse é muito interessante, rico e empolgante.

1 curtida

Mas geralmente é só baixar, instalar e pronto. :slightly_smiling_face:

OK, você está tentando instalar programas proprietários (Minecraft, Stremio) que geralmente não se encontram nos repositórios. Mas para 99% dos programas (que em sua maioria são livres), você os baixa através da “loja de aplicativos” ou gerenciador de pacotes dos repositórios da sua distribuição.

Olha, estou fazendo um tópico ensinando o básico de instalação de programas no Linux. Assim que eu terminar, eu mando o link pra cá.


Parece que você bagunçou demais o seu gerenciador de pacotes. :sweat_smile:
Faça o que o seu sistema falou e rode o comando abaixo que geralmente resolve esse tipo de problema:

dpkg --configure -a

Ah, mas não se esqueça de antes fechar qualquer programa envolvido na instalação de programas no Linux como a “loja de aplicativos” ou gerenciador de pacotes, coisas desse tipo geralmente bloqueiam que outra instalação funcione.

1 curtida

Bem gostaria de agradecer a todos que me ajudaram nesse tópico.

Quando digito esse comando de configure fica:
dpkg: erro: a operação solicitada requer privilégios de superusuário.

A paciência e a disponibilidade de usuários como vocês me empolgam a continuar aprendendo Linux.

Não me esqueça de enviar aqui o link do seu tópico de básico para Linux quando acabar de escrevê-lo. Tenho certeza que será de grande ajuda!

É que, no Linux, sempre estamos utilizando a conta de usuário normal, sem privilégios para instalar programas na base do sistema. Nesse caso use o comando abaixo:

sudo dpkg --configure -a

E coloque sua senha como já lhe ensinei.


Sim, e este tópico está sendo ótimo para eu ver o que preciso adicionar no meu tópico. Não me esquecerei.

1 curtida

Parece que o stremio está com dependência quebrada (já falado em outro tópico esse dias, senão hoje, no ubuntu 20.10). Deram a dica de instalá-lo via flatpak.

O problema é com o stremio, que precisa instalar via download do .deb. É o pior jeito de instalar um programa… No último ano já deve ter mais de 10 tópicos do mesmo jeito, a pessoa instala via .deb, quebra as dependências, o apt (e o dpkg) fica perdido e daí não consegue fazer mais nada (nem desinstalar o pacote quebrado).

Segue as dicas do colega que vamos recuperar esse seu sistema!

1 curtida

Agora esse comando deu certo!

Boa, vou instalar o flatpack. Obrigado!

quando usar o dpkg em distros baseada em Ubuntu , recomendo que use o ( apt-get )

ficando assim: sudo apt-get install -f

1 curtida

@Gabriel_TrHb, aqui o tópico que prometi:

https://plus.diolinux.com.br/t/tutorial-nao-consigo-instalar-nada-no-linux-o-que-eu-faco/

1 curtida

prefiro aptitude

1 curtida

Funcionou, valeu

1 curtida