Python3-rdflib (LADSPA-RDF support)

Como resolver esse erro?
Versão do python instalado: 2.7.17 (Ubuntu 19.10)
Captura de tela de 2020-01-09 10-10-08

Olá!

Você instalou as dependências do Carla?

sudo pip install -r PythonClient/requirements.txt

Caso o erro persista, tente instalar o RDFLIB

sudo apt install python-rdflib

Se mesmo assim o erro persistir, você deverá instalar o Python3 ou superior.

1 Curtida

Olá! Apenas instalei o carla. Não sei sobre as dependências.

1 Curtida

Tente instalar com os comandos que eu passei na mensagem anterior.

1 Curtida

Tentei instalar. Apena o segundo comando me parece ter instalado. Mesmo assim reiniciei a máquina, mas o problema continua. Agora que vc comentou sobre as dependências… eu fui pesquisar no site do carla. Realmente possuem mesmo. Mas não sei como instalar isso.
Site: Carla/INSTALL.md at develop · falkTX/Carla · GitHub

BUILD DEPENDENCIES

There are no required build dependencies. The default build is probably not what you want though.

If you want the frontend (which is likely), you will need PyQt5 (python3 version).

You likely will also want:

  • libmagic/file (for auto-detection of binary types, needed for plugin-bridges)
  • liblo (for OSC support, also a requirement for DSSI UIs)

Optional for extra Linux-only engine features:

  • ALSA
  • PulseAudio
  • X11 (LV2/VST X11 UI support)

Optional for extended LV2 UIs support: (Linux only)

  • Gtk2
  • Gtk3
  • Qt4
  • Qt5

Optional for extra samplers support:

  • FluidSynth (SF2/3)

Optional for extra LADSPA plugin information:

  • python3-rdflib

You can use:

$ make features

To find out which dependencies are missing.

Under Debian based systems, you can use this command to install everything:

sudo apt install python3-pyqt5.qtsvg python3-rdflib pyqt5-dev-tools \
  libmagic-dev liblo-dev libasound2-dev libpulse-dev libx11-dev \
  libgtk2.0-dev libgtk-3-dev libqt4-dev qtbase5-dev libfluidsynth-dev

Under Fedora, you can use the following command instead:

sudo dnf install python3-qt5-devel python3-rdflib \
  file-devel liblo-devel alsa-lib-devel pulseaudio-libs-devel libX11-devel
  gtk2-devel gtk3-devel qt4-devel qt5-devel fluidsynth-devel libsndfile-devel
1 Curtida

Eu estava lendo no site deles, não no Git. Se eu tivesse lido no Git, já teria dito de cara que você precisará do Python 3.
Então vamos lá, abra o terminal e digite:

sudo apt install python3.7

Após isso:

sudo pip install -r PythonClient/requirements.txt

E:

sudo apt install python3-pyqt5.qtsvg python3-rdflib pyqt5-dev-tools \
  libmagic-dev liblo-dev libasound2-dev libpulse-dev libx11-dev \
  libgtk2.0-dev libgtk-3-dev libqt4-dev qtbase5-dev libfluidsynth-dev

Veja se resolve.

1 Curtida

instalei, mas o problema ainda continua. Será um erro do 19.10?

1 Curtida

Igual?

Se for isso, quando você usa o comado:

sudo apt install python3-rdflib

Aparece alguma mensagem de erro?

1 Curtida

Aparece isso:
Lendo listas de pacotes… Pronto
Construindo árvore de dependências
Lendo informação de estado… Pronto
python3-rdflib is already the newest version (4.2.2-2).
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.

1 Curtida

Executando o comando de dentro da pasta onde se encontram os arquivos do Git:

sudo make features

Trás alguma mensagem de erro?

1 Curtida

No rule to make target ‘features’. Pare.

1 Curtida

Não consigo imaginar outra solução a não ser, agora que instalamos o Python 3.7, remover e reinstalar o Carla.

Digite no terminal:

sudo apt purge carla

E reinstale novamente.
Não esqueça de reinstalar as dependências, apesar de eu achar que não precisará.

1 Curtida

Fiz o processo! O erro só aparece abrindo o Carla dentro do Reaper. Fora, não mais!

Dentro do próprio Reaper, existe alguma opção para remover o plugin do Carla e adicionar novamente?
Isso tomado por base que o Reaper “chama” o Carla como um plugin…
Caso contrário, acho que só reinstalando o Reaper também.

1 Curtida

Vou fazer mais alguns testes. Se não der resultado eu reinstalo o sistema novamente. Obrigadão pelo suporte, Miura! Abração

1 Curtida

Não acredito que seja caso de reinstalar o sistema. Mas se você for reinstalar, dê uma olhada no Ubuntu Studio. ACHO que tudo isso já vem instalado nele.

Desculpe a falta de conhecimento mais profundo para te ajudar!

1 Curtida

Miura! Você ajudou muito, meu amigo! Cada etapa é um aprendizado pra mim! Só assim para eu aprender mesmo kkk… Faz um pouco mais de um mês que migrei totalmente para o linux. Estou aprendendo a resolver as coisas aos poucos com a ajuda de vocês! Sou muito grato! Abração.

3 Curtidas

Precisando estamos aê!

:metal:t3:

2 Curtidas

Muitíssimo obrigado!

1 Curtida