Problemas no Dpkg no archlinux

l    [email protected] Downloads]$ sudo dpkg -i emby-server-deb_4.5.4.0_amd64.deb
[sudo] senha para lciarallo: 
(Lendo banco de dados ... 1657 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar emby-server-deb_4.5.4.0_amd64.deb ...
A descompactar emby-server (4.5.4.0) sobre (4.5.4.0) ...
dpkg: problemas com dependências impedem a configuração de emby-server:
 emby-server depende de libc6 (>= 2.17); porém:
  Pacote libc6 não está instalado.

dpkg: erro ao processar o pacote emby-server (--install):
 problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
 emby-server

Tentei instalar o libc6 pelo pacman e pelo yay mas não obtive sucesso. Alguém pode me ajudar?

Você já tem o libc6 instalado, na verdade (assim como toda distribuição Linux de desktop), apenas muda que o nome no Arch é glibc.

A questão é que o dpkg não sabe o que o pacman instalou, e vice-versa (desse modo, mesmo se o pacote também se chamasse libc6 no Arch, não ia adiantar nada).

A maneira “certa” de instalar pacotes de outras distribuições no Arch é ver se alguém já fez a conversão no AUR, usar um conversor como o debtap, ou no mínimo forçar o dpkg a ignorar a dependência (acho que a opção é --force-depends).

4 curtidas