Problemas na instalação de flatpak - pacotes com dependências desencontradas

Olá, pessoal!

Uso um Ubuntu 22.04.3 LTS Jammy Jellyfish e tentei instalar o flatpak através do terminal.
Usei o seguinte comando:

sudo apt install flatpak
Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:
Os pacotes a seguir têm dependências desencontradas:
`flatpak : Depende: libmalcontent-0-0 (>= 0.6.0) mas não é instalável
           Depende: libostree-1-1 (>= 2020.8) mas não será instalado
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

Conseguem me ajudar com esse problema?

Olá.
Isso…

… me faz pensar que talvez o seu sistema não esteja atualizado. A arual versão é 22.04.4.
E que…

… você tem pacotes quebrados e/ou obsoletos ainda instalados.


Eu tentaria

sudo apt autoremove && sudo apt autoclean && sudo apt clean
Limpa pacotes obsoletos e limpa lista de pacotes do repositório.

sudo apt -f install
sudo dpkg --configure -a
Corrige pacotes eventualmente quebrados.

sudo apt update && sudo apt upgrade -y
Atualiza lista de pacotes dos repositórios e pacotes instalados.

Eu reiniciaria o sistema entre cada parágrafo desse (só pra garantir).

[edit]
Aí depois tentaria novamente:

Seguindo as instruções…
https://flatpak.org/setup/Ubuntu

sudo apt install flatpak

sudo apt install gnome-software-plugin-flatpak


flatpak remote-add --if-not-exists flathub https://dl.flathub.org/repo/flathub.flatpakrepo

Reiniciar o sistema.
[/edit]

Você pode tentar compilar o flatpak deste código fonte: GitHub - flatpak/flatpak: Linux application sandboxing and distribution framework
O compilador vai gerar os binários do flatpak compatível com o seu sistema.

Fiz conforme vc orientou

sudo apt autoremove && sudo apt autoclean && sudo apt clean
Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto        
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto

(reiniciei o sistema)

sudo apt -f install
Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto        
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
sudo dpkg --configure -a

(sem resposta do terminal)

(reiniciei o sistema)

sudo apt update && sudo apt upgrade -y
Atingido:1 https://dl.google.com/linux/chrome/deb stable InRelease
Atingido:2 https://repo.nordvpn.com//deb/nordvpn/debian stable InRelease       
Atingido:3 http://oem.archive.canonical.com focal InRelease                    
Atingido:4 https://ppa.launchpadcontent.net/flatpak/stable/ubuntu jammy InRelease
Atingido:5 https://ppa.launchpadcontent.net/somerville-dla-team/ppa/ubuntu jammy InRelease
Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto        
Todos os pacotes estão atualizados
Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto        
Calculando atualização... Pronto
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.

(reiniciei o sistema)

sudo apt install flatpak
Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto        
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
 flatpak : Depende: libmalcontent-0-0 (>= 0.6.0) mas não é instalável
           Depende: libostree-1-1 (>= 2020.8) mas não é instalável
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

sudo apt install gnome-software-plugin-flatpak
Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto        
E: Impossível encontrar o pacote gnome-software-plugin-flatpak

flatpak remote-add --if-not-exists flathub https://dl.flathub.org/repo/flathub.flatpakrepo
Comando 'flatpak' não encontrado, mas poder ser instalado com:
sudo apt install flatpak

não deu certo.

não consegui compilar o código-fonte, sou iniciante

Eu compilei aqui agora e funciono, segue:
Primeiro eu instalei as dependências
$ sudo apt install git
$ sudo apt build-dep flatpak
Agora eu instalei algumas dependências que fico faltando
$ sudo apt install meson
$ sudo apt install libcurl4-gnutls-dev
$ sudo apt install libappstream-dev
Agora obtendo o código fonte do flatpak
Criei uma pasta
$ mkdir /home/$USER/flatpak_comp
Entrei na pasta
cd /home/$USER/flatpak_comp
Baixei o codigo fonte
$ git clone https://github.com/flatpak/flatpak.git
Agora entra na pasta
cd /media/$USER/flatpak_comp/subprojects/variant-schema-compiler/
Baixei o código
$ git clone https://gitlab.gnome.org/alexl/variant-schema-compiler.git
copiei o arquivo “variant-schema-compiler” para a pasta /media/$USER/flatpak-comp/flatpak/subprojects/variant-schema-compiler/
Ainda na pasta /home/$USER/flatpak_comp criei a pasta ./bin2/
$ mkdir ./bin2/
Executei o meson setup
$ meson setup ./bin2/ ./
Entrei na pasta bin2
$ cd ./bin2/
Rodei o ninja para começar a tarefa de compilar
$ ninja
Entrei onde esta os binários da compilação
$ cd app
Testando se o binário funciona
$ ./flatpak --version
Flatpak 1.15.6

É isso, abraço.

Resolvido!

Baixei os pacotes: libmalcontent-0-0 e libostree-1-1 no https://packages.ubuntu.com/

Eu queria usar o flatpak para instalar o calibre, consegui fazer pela linha de comando:

sudo apt update && sudo apt upgrade
sudo apt install flatpak
flatpak install flathub com.calibre_ebook.calibre

E deu tudo certo. Agradeço quem se dispôs a me ajudar. Valeu.

1 curtida

seu problema está aqui:

https://ppa.launchpadcontent.net/flatpak/stable/ubuntu jammy

usar PPA para o flatpak, em vez de usar o do sistema. use PPA somente em caso de extrema necessidade.

1 curtida

Este tópico foi fechado automaticamente 3 dias depois da última resposta. Novas respostas não são mais permitidas.