Problemas de Inicialização - POP_OS e Windows 10

Objetivo: Dualboot.

Todo o processo de instalação do POP_os funciona bem, o problema é o seguinte:
Ao instalar o POP, ele exige que a gente defina uma partição /efi/boot de no mín 500MB.

  1. Já existe uma partição de /efi/boot do windows de 100MB que não aparece para ser selecionada
  2. Mesmo que aparecesse, ela não tem o tamanho mínimo

Isso gera que ao terminar a instalação o POP_os nem aparece e o Windows dá o erro:
"Não foi possível carregar o aplicativo ou sistema operacional, porque um arquivo necessário está ausente ou com erros"
Arquivo: Windows/system32/winload.efi
Código do erro: 0xc00000e

Ao reiniciar o PC, o windows volta a carregar.
Ao entrar na BIOS e colocar o POP_OS como padrão para iniciar, ele entra no command line do GRUB

No windows, utilizando o DISKPART é possível visualizar as duas partições EFI


X: → Windows
L: → Linux / POP_OS

E agora eu não sei o que fazer porque já tentei reinstalar várias vezes e sempre gera duas partições de inicialização diferentes.
OBS.: Ambas as partições estão no mesmo SSD.

E qual o problema de gerar duas partições efi ? vc pode ter quantas partições efi vc quiser.

Mas o pop os não usa grub… Isso é estranho…

Mas afinal o sistema instala ou não instala? Pq se tiver instalado é só tentar arrumar o boot

Acabei de testar de novo e o sistema instala sim.
Testando agora eu mudei a BIOS para iniciar o POP_os e ele entrou, fiz a instalação do os-proper e grub-customizer mas ele não indentifica o windows de jeito nenhum.

Ao reiniciar o pc pelo POP ocorre o erro do windows que apontei acima.

Alterando a BIOS novamente para entrar pelo windows, não dá nenhum sinal do POP mas o windows funciona de boas.

O bootloader do pop é bem problemático, então eu recomendo não mexer em nada.
Tente adicionar o windows ao systemd-boot:

Deixa eu só esclarecer uma coisa que agora comecei a entender.

Quando eu instalo o POP_os e reinicio, não aparece tela de GRUB (porq o pop não tem né) e ai eu só consigo selecionar o OS via BIOS.

Quando eu entro no POP, instalo o grub e grub customizer ai começa o problema de reiniciar o PC e ao tentar entrar no POP ele para no command line do GRUB.

Eu vou reinstalar o POP para fazer esse passo a passo que me mandou.

Não aparece grub pq o pop não usa o grub ele usa outro bootloader (no caso o systemd-boot)

Aí já é outro problema, o grub que não reconhece o windows boot manager