Problemas com o optimus-manager

Boa tarde a todos
Estou tendo problemas com o Optimus-manager, isso ocorreu apos eu atualizar o kernel e quando eu abro o terminal e digito “optimus-manager --status” a seguinte mensagem ocorre:

ERROR: the latest GPU setup attempt failed at Xorg pre-start hook.
Log at /var/log/optimus-manager/switch/switch-20230819T141627.log
Cannot execute command because of previous errors.

e este é o log citado anteriormente:

[12] INFO: # Xorg pre-start hook
[12] INFO: Previous state was: {'type': 'pending_pre_xorg_start', 'requested_mode': 'nvidia', 'current_mode': None}
[12] INFO: Requested mode is: nvidia
[36] INFO: Available modules: ['nouveau', 'bbswitch']
[36] INFO: Unloading modules ['nouveau'] (if loaded)
[39] INFO: switching=none, nothing to do
[63] INFO: Setting Nvidia PCI power state to on
[87] INFO: Writing "on" to /sys/bus/pci/devices/0000:01:00.0/power/control
[87] INFO: Writing "on" to /sys/bus/pci/devices/0000:01:00.1/power/control
[92] INFO: Loading module nvidia
[92] ERROR: Xorg pre-start setup error
Traceback (most recent call last):
  File "/usr/lib/python3.11/site-packages/optimus_manager/hooks/pre_xorg_start.py", line 51, in main
    setup_kernel_state(config, prev_state, requested_mode)
  File "/usr/lib/python3.11/site-packages/optimus_manager/kernel.py", line 22, in setup_kernel_state
    _nvidia_up(config, hybrid=(requested_mode == "hybrid"))
  File "/usr/lib/python3.11/site-packages/optimus_manager/kernel.py", line 95, in _nvidia_up
    _load_nvidia_modules(config, available_modules)
  File "/usr/lib/python3.11/site-packages/optimus_manager/kernel.py", line 164, in _load_nvidia_modules
    _load_module(available_modules, "nvidia", options=nvidia_options)
  File "/usr/lib/python3.11/site-packages/optimus_manager/kernel.py", line 241, in _load_module
    raise KernelSetupError(
optimus_manager.kernel.KernelSetupError: module nvidia is not available for current kernel. Is the corresponding package installed ?
[95] INFO: Removing /etc/X11/xorg.conf.d/10-optimus-manager.conf (if present)
[95] INFO: Writing state {'type': 'pre_xorg_start_failed', 'switch_id': '20230819T141627', 'requested_mode': 'nvidia'}

Tente reinstalar o optimus-manager. As vezes no processo de recompilação ele faz as devidas atualizações no sistema que não foram feitas ao longo da atualização de outros componentes, como por exemplo o kernel.

Mês passado tive um problema em alguma dependência da minha WM, que bastou eu reinstalar, que na compilação foi atualizado com os novos componentes e voltou a funcionar. (não atualizou a versão do pacote, apenas atualizou com os módulos/dependências novas que foi instalados posteriormente ao pacote instalado)

OBS: A dependência em questão era em python também, como o optimus-manager.