Problemas com Davinci Resolve no fedora 32

Olá pessoal!

Venho tentado utilizar o davinci resolve no fedora recentemente mas tive uma série de imprevistos…

No windows, não consigo utilizar CUDA (mesmo com placa nvidia) mas isso nunca foi um problema já que os vídeos ainda sim era renderizados normalmente com OpenCL. Mas no fedora, nem o OpenCL eu consigo usar.

Ele de cara diz que não tenho suporte pra openCL e pede para checar as configurações, entretanto, não consigo confirmar as mudanças porque ele sempre fecha sozinho ao setar o media storage.

Resumindo: o resolve nao reconhece nem meu opencl e quando vou tentar mudar nas configurações (na parte de escolher media storage) ele só fecha na minha cara.

Meu Hardware:
nvidia 710m (suporta até o driver 390)
i7 4510U (hd graphics 4400)
fedora workstation 32 num 480gb ssd

1 Curtida

Veja se este link aqui lhe ajuda:

https://forum.blackmagicdesign.com/viewtopic.php?f=21&t=98528

desculpe a demora! Testei a versão 15.3 no Resolve para ver se o problema era outro mas agora o programa nem abre. Quando rodo no terminal ele dá uma saída semelhante a isto;

aborted (core dumped)

Alguma dica do que fazer? Testei os posts aqui do fórum sobre isso e nada.

nota: creio que não seja uma limitação de hardware pois uso tranquilamente o resolve no popOS. Queria usar no fedora pq é a distro que mais gostei até agr

Consegui resolver!

O que eu fiz foi instalar todos os pacotes do meu driver (legacy 390xx). Pelo jeito nos sistemas base ubuntu o meta-pacote nvidia-384 instala tudo de uma vez, mas no fedora preciso de um comandinho a mais.

Os comandos que usei foram os seguintes:

sudo dnf install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm

sudo dnf install xorg-x11-drv-nvidia-390xx akmod-nvidia-390xx mesa-libGLU

reinicie o computador

sudo dnf install xorg-x11-drv-nvidia-390xx-cuda

reinicie o computador

nvidia-smi (se tudo der certo a saída deve se parecer com isso :point_down:)

Screenshot from 2020-07-21 10-45-22
(não sei se todos esses reboots são realmente necessários, coloquei ali porque foi o que eu fiz haha)

Depois disso, basta instalar o Davinci Resolve (testei com o 16.2.4) e tudo deve abrir normalmente.

1 Curtida

Estou com o mesmo problema no fedora. No ubuntu roda normalmente. Vou seuir suas instruções e tentar hoje a noite após o serviço. Obrigado!