Problemas com compilação de programas

Olá pessoal, eu vi esse video aqui e gostaria de testar o app

porem quando vou compilar da erro, não só nesse programa geralmente toda vez que vou compilar algo, dá erro e eu não sei resolver,

[davidmacalister@fedora src]$ cargo build
        Updating crates.io index
        Updating git repository `https://gitlab.gnome.org/World/Rust/libhandy-rs`
        Updating git repository `https://gitlab.com/Miridyan/vte-rs`
        Updating git repository `https://github.com/gtk-rs/gtk-rs.git`
        Updating git submodule `https://github.com/gtk-rs/gir`
        Updating git submodule `https://github.com/gtk-rs/gir-files`
    error: failed to select a version for `cairo-sys-rs`.
        ... required by package `gdk-sys v0.13.0 (https://github.com/gtk-rs/gtk-rs.git#7e9115a6)`
        ... which is depended on by `gdk v0.13.0 (https://github.com/gtk-rs/gtk-rs.git#7e9115a6)`
        ... which is depended on by `libhandy v0.8.0 (https://gitlab.gnome.org/World/Rust/libhandy-rs?branch=master#5d852e91)`
        ... which is depended on by `mt v0.1.0+alpha2021.05.05 (/home/davidmacalister/mt)`
    versions that meet the requirements `*` are: 0.13.0
    the package `cairo-sys-rs` links to the native library `cairo`, but it conflicts with a previous package which links to `cairo` as well:
    package `cairo-sys-rs v0.10.0`
        ... which is depended on by `gdk v0.13.2`
        ... which is depended on by `mt v0.1.0+alpha2021.05.05 (/home/davidmacalister/mt)
    failed to select a version for `cairo-sys-rs` which could resolve this conflict

alguém sabe como resolver isso?
desde já agradeço :grin: (uso fedora 34)

Basicamente tá dizendo que você tem versões antigas de pacotes, já viu se tem no nixpkgs?

1 curtida

Oque é isso?

1 curtida