Problemas ao instalar um programa no linux

#1

To tentando instalar esse programa https://justgetflux.com no Linux mint, não consigo. Fiz o que ele esta mandando, mais não abre, alguém me ajuda?

1 Like

#2

O Linux Mint já vem com o Redshift instalado, ele tem a mesma funcionalidade.

2 Likes

#3

corre o programa pelo terminal e ve os erros

0 Likes

#4

Oi, baixe através do PPA.

sudo add-apt-repository ppa:nathan-renniewaldock/flux
sudo apt-get update
sudo apt-get install fluxgui

Observação você tem que ter o Python3 instalado na máquina

Mas a dica que o @drakofrost falou, é boa também. O linux mint já de “fabrica” já vem com o Redshift.

Mas caso queira instalar este ainda, esta ai o passo - a - passo.

Depois de instalado, é so chamar a aplicação direto do menu ou do terminal.

Como pode ver na foto o programa sobre normalmente, instalando através da PPA, que te passei

2 Likes

#5

Como eu instalo o Python3?

0 Likes

#6

Instalar Python no Linux

1 Like

#7

caso queira tentar, pode instalar via snap Install fluxgui for Linux using the Snap Store | Snapcraft

2 Likes

#8

Ao pedir para instalar o f.lux através do PPA, as demais dependências – o que incluiu o Python 3 – serão instaladas automaticamente, você não precisa se preocupar com isso. Simplesmente insira os 3 comandos para baixar pelo PPA, se você tiver qualquer dificuldade, pergunte aqui que esclareceremos sua dúvida.

0 Likes

#9

Rapaz eu acho que já vem python instalado abra e digite python e diga o que vê

0 Likes

#10

Este flux não funcionou comigo, Uso o redshift como o @drakofrost disse, única coisa ruim é que ele não tem um menu de configurações.

0 Likes

#11

Esta dando esse erro aki:

Traceback (most recent call last):
File “/usr/local/bin/fluxgui”, line 17, in
from fluxgui.fluxapp import main
File “/usr/local/lib/python3.8/site-packages/fluxgui/fluxapp.py”, line 4, in
from fluxgui import fluxcontroller, settings
File “/usr/local/lib/python3.8/site-packages/fluxgui/fluxcontroller.py”, line 1, in
from fluxgui import xfluxcontroller
File “/usr/local/lib/python3.8/site-packages/fluxgui/xfluxcontroller.py”, line 1, in
import pexpect
ModuleNotFoundError: No module named ‘pexpect’

0 Likes

#12

Alguém sabe como resolver?

0 Likes

#13

sudo pip3 install pexpect

0 Likes