Problema para atualizar pacotes flatpak no Arch Linux

Olá pessoal, estou tentando rodar o comando: flatpak upgrade para atualizar os pacotes flatpaks, mas sempre aparece esse tipo de mensagem:


Alguém já teve esse problema? Estou tentando buscar respostas, mas nada ainda…

O comando é flatpak update. Roda esse e veja se aparecem os mesmos erros.

Sobre o erro na runtime (Gnome40), o jeito é esperar.

1 curtida

Da na mesma.

1 curtida

Também to com o mesmo erro :frowning:
até agora não achei solução.

1 curtida

Estava vendo estas issues talvez relacionadas com a sua, parece pedir update do ostree…

quais versões dos pacotes flatpak e ostree aí?

aqui está assim:
ostree-2022.4-2.fc36.x86_64
flatpak-1.12.7-3.fc36.x86_64

imagino que já tenha tentado os seguintes comandos:
sudo flatpak repair --system ou flatpak repair --user

2 curtidas

Minha ostree ta na mesma versão em que a sua está, mas o meu flatpak tá nessa Version: 1:1.12.7-1

Já, mas não resolveu : (

1 curtida

veja, a mensagem de aviso de runtime sem suporte/inexistente… é normal aparecer as vezes, com algum app que não se atualiza ou runtime sem suporte…já as mensagens “critical” aí não, elas estão impedindo de tu atualizar os flatpaks?

Por hora não, mas fico preocupado com a segurança.

Tentei isso também.

Apareceu o exato mesmo problema aqui.
Fedora Workstation 36.

Aqui automagicamente resolveu depois de alguns updates no flatpak :slight_smile:

Aqui tá o oposto - apareceu tanto no Reborn quanto no Manjaro. Mas não tá atrapalhando em nada, só visualmente

Aqui continua aparecendo o maldito

GLib-GIO-CRITICAL: g_task_get_cancellable: assertion ‘G_IS_TASK (task)’ failed

Alguma atualização nisso? Aqui continua assim.

Aqui meio que resolveu sozinho, tanto no Manjaro quanto no Reborn

2 curtidas

atualizou libostree e flatpak depois disso?

1 curtida

Sim. caractere