Problema no Debian 10: Dependências Quebradas

Olá, preciso de ajuda!

Estou usando o Debian 10, há algum tempo, todas as vezes que tento instalar qualquer coisa aparece a mensagem:

"Dependências Quebradas
Seu sistema tem dependências quebradas. Esta aplicação não pode continuar até que isto seja corrigido. Para consertar este problema, execute ‘gksudo synaptic’ ou ‘sudo apt-get install -f’ em uma janela de terminal

Já realizei os dois comandos sugeridos e os resultados foram os seguintes:

usuario@polilinux:~$ gksudo synaptic
bash: gksudo: comando não encontrado

usuario@polilinux:~$ sudo apt-get install -f
[sudo] senha para usuario:
Lendo listas de pacotes… Pronto
Construindo árvore de dependências
Lendo informação de estado… Pronto
Corrigindo dependências… Pronto
O seguinte pacote foi instalado automaticamente e já não é necessário:
libmicrodns0
Utilize ‘sudo apt autoremove’ para o remover.
The following additional packages will be installed:
gnome-shell-common
Os pacotes a seguir serão atualizados:
gnome-shell-common
1 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 6 não atualizados.
1 pacotes não totalmente instalados ou removidos.
É preciso baixar 0 B/635 kB de arquivos.
Depois desta operação, 0 B adicionais de espaço em disco serão usados.
Você quer continuar? [S/n] s
Lendo logs de mudanças… Feito
(Lendo banco de dados … 223114 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar …/gnome-shell-common_3.30.2-11~deb10u2_all.deb …
A descompactar gnome-shell-common (3.30.2-11~deb10u2) sobre (3.30.2-11~deb10u1) …
dpkg: erro ao processar o arquivo /var/cache/apt/archives/gnome-shell-common_3.30.2-11~deb10u2_all.deb (–unpack):
a tentar sobre-escrever ‘/usr/share/locale/pt_BR/LC_MESSAGES/gnome-shell.mo’, que também está no pacote oem-translation 1.0.0
dpkg-deb: erro: o subprocesso colar foi morto pelo sinal (Pipe quebrado)
Erros foram encontrados durante o processamento de:
/var/cache/apt/archives/gnome-shell-common_3.30.2-11~deb10u2_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

usuario@polilinux:~$ sudo apt autoremove
Lendo listas de pacotes… Pronto
Construindo árvore de dependências
Lendo informação de estado… Pronto
Você pode querer executar ‘apt --fix-broken install’ para corrigí-los.
Os pacotes a seguir têm dependências desencontradas:
gnome-shell : Depende: gnome-shell-common (= 3.30.2-11~deb10u2) mas 3.30.2-11~deb10u1 está instalado
E: Dependências desencontradas. Tente ‘apt --fix-broken install’ sem nenhum pacote (ou especifique uma solução).

usuario@polilinux:~$ apt --fix-broken install
E: Não foi possível abrir arquivo de trava /var/lib/dpkg/lock-frontend - open (13: Permissão negada)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), are you root?

root@polilinux:/home/usuario# apt --fix-broken install
Lendo listas de pacotes… Pronto
Construindo árvore de dependências
Lendo informação de estado… Pronto
Corrigindo dependências… Pronto
O seguinte pacote foi instalado automaticamente e já não é necessário:
libmicrodns0
Utilize ‘apt autoremove’ para o remover.
The following additional packages will be installed:
gnome-shell-common
Os pacotes a seguir serão atualizados:
gnome-shell-common
1 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 6 não atualizados.
1 pacotes não totalmente instalados ou removidos.
É preciso baixar 0 B/635 kB de arquivos.
Depois desta operação, 0 B adicionais de espaço em disco serão usados.
Você quer continuar? [S/n] s
Lendo logs de mudanças… Feito
(Lendo banco de dados … 223114 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar …/gnome-shell-common_3.30.2-11~deb10u2_all.deb …
A descompactar gnome-shell-common (3.30.2-11~deb10u2) sobre (3.30.2-11~deb10u1) …
dpkg: erro ao processar o arquivo /var/cache/apt/archives/gnome-shell-common_3.30.2-11~deb10u2_all.deb (–unpack):
a tentar sobre-escrever ‘/usr/share/locale/pt_BR/LC_MESSAGES/gnome-shell.mo’, que também está no pacote oem-translation 1.0.0
dpkg-deb: erro: o subprocesso colar foi morto pelo sinal (Pipe quebrado)
Erros foram encontrados durante o processamento de:
/var/cache/apt/archives/gnome-shell-common_3.30.2-11~deb10u2_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Alguém poderia me ajudar?

Olá @carlosmelo tudo bem contigo?
Você ativou algum repositório extra ou instalou algum pacote manualmente?

Isso aqui só vai funcionar se você tiver o gksudo instalado, ele não é um pacote padrão do sistema.


Em uma instalação padrão do Debian os pacotes do Gnome são instalados automaticamente, novamente, minha maior suspeita é que você tenha instalado/removido algo que não deveria. Você pode fazer uma cópia desse arquivo ‘/usr/share/locale/pt_BR/LC_MESSAGES/gnome-shell.mo’ e depois apagar ele do sistema, para ver se assim a instalação segue normalmente.


Comandos de sistema só podem ser executados pelo root.


Vou dar uma olhada numa VM de Debian aqui, mas acredito que esse pacote “gnome-shell” é apenas um meta-pacote e que não deveria ser instalado diretamente em situações normais.

Na vasta maioria dos casos, os comandos que você citou são os recomendáveis para resolver esse tipo de problema. Você selecionou manualmente os pacotes que deveriam ser instalados no Debian?

:vulcan_salute:

Manda a saída do apt policy