Problema com temas no KDE

Quase todos os temas que instalo apresentam uma certa “borda” por baixo da decoração das janelas.

opengl

No exemplo estou usando o OpenGL 3.1 como compositor, porém quando troco para XRender tudo parece ficar normal:

xrender

Teria alguma solução alem da troca do compositor? aparentemente alguns efeitos ficam faltando com XRender (como o blur), poderia ser problema com os drivers proprietários da Nvidia?

UPDATE

Depois de pesquisar mais um pouco descobri que isso já é um bug conhecido a bastante tempo, como pode ser visto aqui.
A única maneira de resolver até então é desativando o blur nos efeitos de área de trabalho.

2 Curtidas

Eu edito o arquivo de tema no local (/home/usuario/.local/share/aurorae/themes/WhiteSur-Sharp-dark/WhiteSur-Sharp-darkrc), meio na tentativa e erro. O teu tema pode ser diferente do meu, então vc navega até (/home/usuario(teu usuário)/.local/share/aurorae/themes/) encontra o teu tema e procura por um arquivo de texto, esse arquivo de texto tem as configurações do teu tema. Então vc edita apenas a parte do layout.

Por exemplo o tema WhiteSur - Sharp Dark (versão antiga):
[Layout]
BorderLeft=1
BorderRight=1
BorderBottom=12
TitleEdgeTop=4
TitleEdgeBottom=4
TitleEdgeLeft=16
TitleEdgeRight=16
TitleBorderLeft=50
TitleBorderRight=50
TitleHeight=16
ButtonWidth=16
ButtonHeight=16
ButtonSpacing=10
ButtonMarginTop=2
ButtonMarginLeft=0
ButtonMarginRight=0
ExplicitButtonSpacer=0
PaddingTop=35
PaddingBottom=94
PaddingRight=75
PaddingLeft=75
TitleEdgeTopMaximized=4
TitleEdgeBottomMaximized=4
TitleEdgeLeftMaximized=4
TitleEdgeRightMaximized=4

nova versão( a que funcionou para mim):

[Layout]
BorderLeft=1
BorderRight=1
BorderBottom=1
TitleEdgeTop=4
TitleEdgeBottom=4
TitleEdgeLeft=16
TitleEdgeRight=16
TitleBorderLeft=50
TitleBorderRight=50
TitleHeight=16
ButtonWidth=16
ButtonHeight=16
ButtonSpacing=10
ButtonMarginTop=2
ButtonMarginLeft=0
ButtonMarginRight=0
ExplicitButtonSpacer=0
PaddingTop=35
PaddingBottom=85
PaddingRight=75
PaddingLeft=75
TitleEdgeTopMaximized=4
TitleEdgeBottomMaximized=4
TitleEdgeLeftMaximized=4
TitleEdgeRightMaximized=4

mas, como eu disse, foi na tentativa e erro.

Ao alterar e salvar o arquivo a janela não muda imediatamente, então para verificar, basta atualizar a visualização da janela, ou seja, maximize e retorne a janela ao normal e vuoala.

1 Curtida

Passei tanto tempo tentando achar uma solução pra esse bug que acabei abandonando o KDE e indo pro lado dos TWM mesmo asokasoasoas.
Qualquer hora dessas vou baixar novamente e testar, mas me pareceu ser um bug com as placas nvidia.

1 Curtida

Na verdade me parece ser um bug de renderização da janela com o tema, em meu note, mesmo sem placa de vídeo estava apresentando essa anomalia. No PC era muito mais aparente, acredito q a nvidia intensifica o problema. Acho q no futuro eles resolvam isso, tlvz com atualização do driver, ou até mesmo com alguma implementação no próprio gerenciador de temas do kde.
Vamos esperar pra ver…

1 Curtida