Problema com Scanner Kodak no Ubuntu18.04.5 e Ubuntu20.04

Boa tarde,

Há dois anos comecei a usar os scanners Kodak no Ubuntu18.04 e Xubuntu18.04, sem problemas instalando os driver baixados do site da Kodak.

Agora estou migrando algumas maquinas para o Ubuntu20.04 e Xubuntu20.04, nenhum aplicativo de digitalização reconhece os scanners, modelos (I2600 e I1190), programas usados (xsane, Simple Scan, gscan2pdf_2.12, etc).

Pelo comando “lsusb” o scanner I2600 reconhece normalmente, já o outro modelo reconhece o ID do equipamento, já pelo comando “lsusb -v” esse outro scanner aparece todas as informações.

Percebi que a versão mais atualização do Ubuntu18.04.5 também não esta reconhecendo mais esses scanners, no Ubuntu18.04.5 os drivers são instalados sem nenhum erro, no Ubuntu20 da um erro que na dependência “libopenusb”, resolvi esse erro instalando a lib “libopenusb-dev_1.1.11-2_amd64.deb”.

Já tentei mudar os parâmetros do arquivo “55-kodakdi.rules” no diretório /etc/udev/rules, coloquei o id do produto de acordo com comando “lsusb -v” .

Baixei o drives do site da kodak

Foi feito o link simbólico de acordo com a dica do site

Outros scanners como fujitsu SP-1120 e Epson Perfection V19 estão funcionado normalmente, apenas os modelos Kodak não estão funcionando, modelos ( kodak i1190, I1150, I1120, I2600 ).

Segue os resultado do meus últimos teste em relação o problema no scanner.texto em negritotexto em negrito

Segue abaixo a saída do comando "usb-devices" o scanner esta sendo corretamente identificado.

pelo comando scanimage -L aparece apenas as impressora na rede.

**Tenho um computador com Xubuntu 18 funcionando o scanner que não atualizou, comparei as configurações dos arquivos "kodak.conf e kodakaio.conf " que ficam no diretório /etc/sane.d, estão idênticas.
Já no arquivo “kodakaio.conf” inserir manualmente as informações do equipamento "usb 0X040a 0X601d" no programa XSANE chega a listar o scannner, porém da erro ao iniciar o digitalizador, imagens anexas.

Já desanimei na procurar da solução desse problema, não sei qual o problema da versão do Ubuntu.20, lembrando que já baixei uma imagem limpa do Xubuntu e Ubuntu 20, porém os scanner Kodak não funcionam.

Bem vindo ao fórum @washigtonpa!
Só me vem uma coisa a cabeça, levando em consideração tudo que disse no seu relato e com os seus testes. Pode ter passado despercebido por você quando testou as versões, mas acredito que esteja diretamente atrelado ao kernel usado.

Na versão que funciona (18.04) era utilizada a versão 4.15.0-20 do kernel sendo que hoje é considerada defasada, recomendo fazer um teste usando a versão 10 do Debian que vem com kernel 4.19.0-5, não é exatamente o mesmo kernel, entretanto, é mais próximo que conseguiremos, isso até incluírem as correções necessárias para rodar no kernel atual.

Eu uso o VueScan a muitos anos. Já usei ele no Windows, Mac OS e no Linux. Funcionou perfeitamente com todos os scanners que eu já usei. Com ele você não precisa se preocupar com compatibilidade, ele usa os próprios drivers. Faça um teste. Creio que deva resolver seu problema.

" VueScan is compatible with 6639 scanners from 42 manufacturers on Windows, Mac OS X and Linux"

1 curtida