Problema com Ethernet no archlinux

Saudações, galera. Sou novato no arch linux e estou tendo problemas com a minha conexão cabeada. Minha placa de rede JMicron JMC250 Ethernet é reconhecida, no entanto o sistema diz que o cabo não está conectado, quando uso o comando $ ip addr, o comando retornar que o estado da placa está “DOWN”, utilizando o comando $ ip link set dev enp2s0f5 up, a placa continua DOWN. Procurando na internet encontrei alguns topicos dizendo para instalar um driver, consegui efetuar o download desse driver, mas não consigo fazer a instalação correta.
links dos tópicos - JMicron JMC250 Ethernet driver installation - Linux Mint Forums
https://sempreupdate.com.br/jmicron-jmc250-gigabit-nic-como/

Bem-vindo ao fórum.

É um notebook?
Já tentou ver pelo teclado se a rede está desativada?

solução manjaro de 2018

I did figure out what you say about the folder /etc/systemd/system, sorry for wasting your time.

It still doesn’t work with 1 gig but at least I get 100 lan on boot and can finally disable wifi.

The new version of the file is:

    [Unit]
    Description=Configure NIC
    After=network.target

    [Service]
    Type=simple
    ExecStart=/usr/bin/ethtool -s ens5f5 speed 100 duplex full autoneg off
    Restart=on-failure

    [Install]
    WantedBy=multi-user.target

Thank you very much for your help.
If I find a way to get 1 Giga connection I will post it here later.

Sim, é um notebook. Então, no Windows 7 funciona normalmente a interet cabeada, só no linux mesmo, o wifi eu preciso ligar pelo teclado em ambos os sistemas, mas a ethernet não. Já olhei esse tópico, mas não consegui executar nenhum desses comandos, esse $ ethools sudo ethtool -s ens5f5 autoneg on, seria equivalente ao $ ip link set dev enp2s0f5 up, não? E aquele tutorial para o instalar o drive eu não consegui fazer no arch.

O comando ethtool também existe no Arch Linux (sudo pacman -S ethtool). Apesar de não vir pré-instalado como no Manjaro, deve ser possível instalá-lo pelo Wi-Fi. E pelo visto não há uma equivalência - o post do Manjaro não diz que ip funciona.

Considerando a situação relatada pelo post no fórum do Manjaro, o ethtool é a melhor via. O driver para baixar está desatualizado há muitos anos (o que significa que ele não vai funcionar de um jeito adequado em um kernel super novo como o do Arch) e nem no Windows ele costuma alcançar a velocidade divulgada.

1 Curtida

não …

é outro comando

pertence ao pacote ethtool

sudo pacman -S ethtool

no caso caso não tenha conexão nenhuma com a internet, teria que baixar na instalação

pode baixar no windows e instalar no linux

https://www.archlinux.org/packages/extra/x86_64/ethtool/

sudo pacman -U ethtool…xz

1 Curtida

Saudações, meus caros!

Vos comunico através de uma rede cabeada, depois de um dia inteiro pesquisando tentando e errando. Finalmente consegui ligar a placa através do comando $ sudo ethtool -s enp2s0f5 speed 100 duplex full autoneg on. No entanto, preciso fazer esse procedimento toda vez que ligo o computador, se alguém souber um método pra eu colocar junto com a inicialização eu ficaria muito grato. OBS: Consegui instalar o ehtools através do “YAY”, pelo pacman não tava encontrando o target.

Agradeço à atenção e ajuda de todos.

2 Curtidas

No fórum do Manjaro, consta a seguinte solução para isso:

1 . Crie o arquivo /etc/systemd/system/autoethernet.service como root
2 . Edite esse arquivo com, por exemplo, nano, e coloque:

[Unit]
Description=Configure NIC
After=network.target

[Service]
Type=simple
ExecStart=/usr/bin/ethtool -s enp2s0f5 speed 100 duplex full autoneg on
Restart=on-failure

[Install]
WantedBy=multi-user.target

Esse comando será iniciado logo após o sistema detectar as placas de rede.
Se quiser mudar alguma coisa, só mudar o que vem no ExecStart
3 . sudo systemctl enable autoethernet.service para ativar o comando e ele ser rodado no boot seguinte.

Para maiores informações, leia o artigo sobre Systemd na wiki do Arch.

3 Curtidas

oi amigo segue o link que passei.

crie um arquivo em /etc/systemd/system

por exemplo:
nome:rede_cabeada.service

sudo nano /etc/systemd/system/rede_cabeada.service

adicione

    [Unit]
    Description=Configure NIC
    After=network.target

    [Service]
    Type=simple
    ExecStart=/usr/bin/ethtool -s ens5f5 speed 100 duplex full autoneg off
    Restart=on-failure

    [Install]
    WantedBy=multi-user.target

para salvar
Ctrl+X
e depois
S

LOgo após isso execute o comando abaixo para iniciar no boot

sudo systemctl enable rede_cabeada.service

se já quiser rodar para ver se funciona

sudo systemctl start rede_cabeada.service

Funcionou

Faça o teste agora de boot
Reinicie o pc e veja se funciona

2 Curtidas

Galera, está tudo funcionando perfeitamente. Novamente, muito obrigado à todos que colaboraram com o meu problema. Abraços!

antes disso tudo, vc ao menos instalou um gerenciador de redes e habilitou ele no systemd?
tipo

sudo pacman -S dhcpcd && sudo systemctl enable --now dhcpcd

?

(só por curiosidade)

Mesmo no Manjaro que tem esse tipo de coisa junto na ISO apresenta esse problema.
Acho que é problema no driver mesmo.

Caros,

Estou passando pelo mesmo problema com o JMC250.
Sou novo no manjaro, podem me apontar uma resolução?

O sistema reconhece a placa apenas. Mas não funciona.

Grato