Preso na tela "Docker Desktop starting" no Kubuntu 22.04

Desde ontem que eu estou tentando fazer o Docker funcionar. Já procurei por toda essa internet, mas nada parece resolver meu problema. Já instalei e desinstalei várias vezes, mas também não consegui resolver. Eu instalei a partir do guia do próprio site do Docker. Eu não entendo praticamente nada do Docker, eu só queria ele para usar o @wordpress/env.

Abaixo a bendita tela:

Experimente a solução apontada no issue abaixo…

Executando os comandos abaixo, lembrando de trocar <USER> por seu usuário…

sudo echo <USER>:10000:65536 >> /etc/subuid
sudo echo <USER>:10000:65536 >> /etc/subgid

Infelizmente eu já fiz isso.

Eu já dei olhada no GitHub, vi outras pessoas com os mesmos problemas que eu, mas não encontrei a solução. Eu ia reportar meu problema lá, mas como meu inglês é meio ruinzinho, seria muito difícil descrever meu problema, daí desistir.

Tens o Docker daemon iniciado, pode verificar com o comando abaixo…

systemctl status docker

A saída deste comando tem que conter uma linha próxima a abaixo, informando que o docker está ativo…

...
    Active: active (running)...
...

Caso contrário ative executando o seguinte…

sudo systemctl enable --now docker

Sobre o Wordpress Env, não necessariamente necessitas do Docker Desktop, segue link


Para instalar o Docker no Ubuntu siga Instale o Docker no Ubuntu usando o script de conveniência

A boa é rodar com start e não enable, ainda mais que por padrão, o docker no Ubuntu* sobe com o systemd automaticamente. A minha sugestão ao OP é que use via CLI em não pela interface gráfica que, na real, só vejo mais como necessidade para quem é usuário do Windows por não ter escolha mesmo.

Instalação do docker no Ubuntu* 22.04 → How To Install and Use Docker on Ubuntu 22.04 | DigitalOcean

  • Pull da imagem do WordPress: sudo docker pull wordpress
  • Iniciar o serviço: sudo docker run --name wordpressTeste -p 8080:80 -d wordpress (por padrão, após o pull da imagem, um deamon do wordpress vai startar de forma automática, mas não aparece ao rodar sudo docker ps, que é o comando responsável por listar container em execução. Então suba na mão com o comando da linha dois);
  • Parar o container: sudo docker stop some-wordpress (ou o nome que você deu para o cotainer)

Obs: se quiser parar o serviço do docker de iniciar junto ao sistema: sudo systemctl disable docker.service && sudo systemctl disable docker.socket

Não faz real diferença, pois como mencionado por tu, o Ubuntu já adiciona ou seja se já estiver habilitado, só irá iniciar, o comando à qual informei era mais para garantir que realmente o Daemon está em execução…


Sobre seu uso o OP, poderia achar mais fácil, gerenciar utilizando-se de interface, e cabe ao usuário decidir…


Não necessariamente precisa informar o .service e o .socket o Systemd sabe encontrar os serviços, portanto somente sudo systemctl disable --now docker é suficiente… Mas caso queira poderá simplesmente executar

sudo systemctl disable docker.{service,socket}
1 curtida