Preciso de uma ajuda no quesito linha malformada?

nt@ant-340X:~$ sudo apt-get install kdenlive

[sudo] senha para ant:

E: Malformed entry 62 in list file /etc/apt/sources.list (Component)

E: A lista de fontes não pode ser lida.

E: Malformed entry 62 in list file /etc/apt/sources.list (Component)

E: A lista de fontes não pode ser lida.

Você teria que ver o que tem na linha 62 do arquivo /etc/apt/sources.list, possivelmente algum erro de digitação, caso você tenha adicionado um PPA.

Sim eu adicionei o PPA …mas nao sei como corrigir essa linha …teria que ter instruçoes sobre como fazer isso de corrigir a linha .

Para isso é necessário saber o conteúdo da linha e qual o PPA, sem essas informações não é possível ajudar.

O PPA é do Calibre …biblioteca do calibre

Sem o conteúdo da linha 62 não é possível fazer nada.

acabei deletando a sources.list …espero nao ter dado uma mancada maior …rs

obrigado por me ajudar …

Não dá para ajudar sem informações. E não, você não pode deletar esse arquivo, você não será capaz de atualizar o sistema ou instalar quaisquer aplicativos sem ele.

Sobre o problema, para ver sem abrir o arquivo, poderia ter utilizado:

cat -n /etc/apt/sources.list | grep 62

Envie qual sua distro e versão para ajudarmos a recompor o arquivo. É realmente vital. Mas considerando que seu sources já tinha tantas linhas, já incluía algo a muito tempo, fez backup inicial?

Fiz backup sim …e uso ubuntu Dingo …19.2

@antpn Por favor você conseguiu resolver esse problema? Estou com um semelhante.

qual o erro que aparece ??

E: Malformed entry 6 in list file /etc/apt/sources.list.d/additional-repositories.list (Component)

E: A lista de origens não pôde ser lida.

Configure as opções de repositórios para corrigir o problema.

E: _cache->open() failed, please report.

Mas apaguei esses repositórios da lista e parece que está normal de novo.
Segundo um cara que estava me ajudando nessa questão era ideal eu colocar os repositórios originais da distro(a minha é LINUX MINT(TARA) 19 CINNAMON) que resolveria o problema. Será que ter apagado esses da lista que estavam com erros vão me fazer falta futuramente?

depende você instalou alguma coisa desses repositórios? pelo que sei a unica coisa que possa acontecer e algum software nao atualizar por faltar o repositório

Eu instalei o Wine, só que deve ter dado erro porque eu não completei a instalação.

Roda o comando: sudo dpkg --configure -a

Depois update e upgrade pra ver se resolveu.

@Roldon Não apresentou nem erro.
Obrigado pela dica!

1 Curtida

Mas resolveu o problema?