Pop!_shop - Tem Atualização do SO pendente, mas não atualiza

Espere então só não está atualizando os pacotes do PostgreSQL?

$ sudo apt-get --fix-broken install

$ sudo apt-get install --reinstall postgresql-*

2 curtidas

O meu ainda permanece mesmo com a solução que o Herege disponibilizou.

@rafaelFelip
Bom, se não deu certo do Herege, pode ser que do meu jeito não dê certo também.

O que eu fiz foi entrar em modo tty: Ctrl+Alt+F3
Lá você digita seu nome de usuário e depois digite sua senha.
E rodar o comando:
sudo apt update && sudo apt full-upgrade -y

Depois de atualizar, rode o comando:
sudo reboot

Assim vai reiniciar o sistema e pronto.

Obs.: Caso você não saiba o nome do usuário, só você abrir o terminal que vai estar lá antes do @.
ab8a68d8881002f6135f1ec9fbf5f7ab57dbad04

2 curtidas
sudo apt-get --fix-broken install
...
...
                               Nenhum relatório apport escrito pois a mensagem de erro indica que é um erro de seguimento de um erro anterior.
                                                              Erros foram encontrados durante o processamento de:
 postgresql-common
 postgresql-12
 postgresql-server-dev-12
E: Sub-process /usr/bin/dpkg returned an error code (1)

e depois

sudo apt-get install --reinstall postgresql-*
...
...
dpkg: erro ao processar o pacote postgresql (--configure):
 problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de postgresql-12:
 postgresql-12 depende de postgresql-common (>= 182~); porém:
  Pacote postgresql-common não está configurado ainda.

dpkg: erro ao processar o pacote postgresql-12 (--configure):
 problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de postgresql-server-dev-12:
 postNenhum relatório apport escrito pois a mensagem de erro indica que é um erro de seguimento de um erro anterior.
                                    Nenhum relatório apport escrito pois a mensagem de erro indica que é um erro de seguimento de um erro anterior.
                                                                   Nenhum relatório apport escrito pois MaxReports já foi atingido
                                                  Nenhum relatório apport escrito pois MaxReports já foi atingido
                                 gresql-server-dev-12 depende de postgresql-common (>= 142~); porém:
  Pacote postgresql-common não está configurado ainda.

dpkg: erro ao processar o pacote postgresql-server-dev-12 (--configure):
 problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
 postgresql-common
 postgresql-13
 postgresql
 postgresql-12
 postgresql-server-dev-12
E: Sub-process /usr/bin/dpkg returned an error code (1)

Não sei se tem a ver, mas não estou conseguindo instalar o Spotify pela Pop!_shop.

Quando tento instalar a versão flatpak, ela fica carregando infinito.
Quando tendo instalar a versão deb, ele da o erro The package id's '' are not valid

$ sudo dpkg --configure

1 curtida
dpkg: erro: --configure precisa de pelo menos um nome de pacote como argumento

Escreva dpkg --help para ajuda sobre instalar e desinstalar pacotes [*];
Utilize 'apt' ou 'aptitude' para gestão de pacotes amigável;
Escreva dpkg -Dhelp para uma lista de valores de flags de debug do dpkg;
Escreva dpkg --force-help para uma lista de opções para forçar operações;
Escreva dpkg-deb --help para ajuda sobre manipular ficheiros *.deb;

Opções marcadas com [*] produzem muita saída de texto - utilize pipes com 'less' ou 'more' !

$ sudo dpkg --reconfigure -a

Esqueci do -a :grin:

1 curtida

haha acontece!

Configurando postgresql-common (220.pgdg20.04+1) ...
dpkg: erro ao processar o pacote postgresql-common (--configure):
 o subprocesso instalado, do pacote postgresql-common, o script post-installation retornou erro do status de saída 10
dpkg: problemas com dependências impedem a configuração de postgresql-12:
 postgresql-12 depende de postgresql-common (>= 182~); porém:
  Pacote postgresql-common não está configurado ainda.

dpkg: erro ao processar o pacote postgresql-12 (--configure):
 problemas de dependência - deixando desconfigurado
Configurando sysstat (12.4.0-1) ...
dpkg: erro ao processar o pacote sysstat (--configure):
 o subprocesso instalado, do pacote sysstat, o script post-installation retornou erro do status de saída 10
Erros foram encontrados durante o processamento de:
 postgresql-common
 postgresql-12
 sysstat

$ sudo dpkg --configure postgresql-* sysstat

Admito que esotu ficando sem ideias

1 curtida

Caso não funcione com os dois juntos. execute separados:

$ sudo dpkg --configure postgresql-*

$ sudo dpkg --configure sysstat

1 curtida

Nada ainda :frowning:


Escreva dpkg --help para ajuda sobre instalar e desinstalar pacotes [*];
Utilize 'apt' ou 'aptitude' para gestão de pacotes amigável;
Escreva dpkg -Dhelp para uma lista de valores de flags de debug do dpkg;
Escreva dpkg --force-help para uma lista de opções para forçar operações;
Escreva dpkg-deb --help para ajuda sobre manipular ficheiros *.deb;
Configurando sysstat (12.4.0-1) ...
dpkg: erro ao processar o pacote sysstat (--configure):
 o subprocesso instalado, do pacote sysstat, o script post-installation retornou erro do status de saída 10
Erros foram encontrados durante o processamento de:
 sysstat

Tente abrir outro tty e atualizar por lá (aperte CTRL + ALT + alguma tela F como F3 e faça login pela linha de comado)

Para atualizar, faça um $ sudo apt-get update && sudo apt-get full-upgrade

1 curtida

Deu o mesmo erro de antes :frowning:

dpkg: erro ao processar o pacote postgresql-server-dev-12 (--configure):
 problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
 postgresql-common
 postgresql-13
 postgresql
 postgresql-12
 postgresql-server-dev-12
E: Sub-process /usr/bin/dpkg returned an error code (1)

algo assim

Fazendo uma rápida pesquisa, remover tudo de /var/lib/dpkg/info deve resolver.

$ sudo rm -rf /var/lib/dpkg/info*

$ sudo apt-get clean
$ sudo apt-get install -f
$ sudo apt-get update
$ sudo apt-get full-upgrade

5 curtidas

Perfeito !

Agora não deu mais erro e aviso!

0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.

Valeu! <3

2 curtidas

Instalei Spotify pelo instrução do site:

Valeu!

Eu estava tentando por ele também, mas não rolou.

Agora deu certo!

1 curtida

Bom dia!

Consegui resolver, o problema era que tinha instalado o Spotify (.deb) e ele estava sendo o motivo do erro, reinstalei ele em flatpak e resolveu.

2 curtidas