Pop!_OS - Há como desativar o botão "fechar" do GNOME?

A princípio parece uma ideia idiota remover o botão para fechar as janelas, mas você vai entender.

Junto ao Pop!_OS vem embarcada uma extensão chamada “Pop!_Shell”, que adiciona funções ao Shell do GNOME, entre elas uma função que procuro há muito tempo: transformar o GNOME em um TWM como o i3WM/Gaps

Ao ativar a função, as janelas são separadas como o i3-Gaps (quem usou já sabe como é).

Porém, algo que me incomoda é o fato de ainda haver um botão para fechar a janela ali no canto da janela, mesmo já havendo o atalho pelo teclado (SUPER + Q).

Há como desativar o botão?

1 Curtida

Talvez com o dconf, mas eu não faço ideia de como fazer.

Foi o primeiro que pensei, mas parece que vou ter que dar uma estudada no dconf :sweat_smile:

1 Curtida

Tem sim, abra o gestor de arquivos e pressione CTRL+H (para exibir os arquivos e bastas ocultos), entre na pasta .confige depois na pasta gtk-3.0 (se não existir crie)

Dentro dessa pasta abra o arquivo settings.ini (se não existir crie)

e coloque:

gtk-decoration-layout=menu

Abaixo de [Settings], (caso alguma linha começando com gtk-decoration-layout, subustitua por essa)

Feche os apps, abra novamente e pronto, vai notar que o botão “Fechar” se foi


Se o arquivo não existir ao final você vai ter o arquivo settings.ini assim:

[Settings]
gtk-decoration-layout=menu

1 Curtida

Não funcionou. Note que o meu ~/.config/gtk-3.0/settings.ini está como indicado por você, e mesmo reiniciando a sessão os botões continuam.

Tente este comando:

gsettings set org.gnome.desktop.wm.preferences button-layout :

Se esse não funcionar, é provável que seja algo da extensão

Funcionou :slight_smile:
Poderia deixar um comando para reverter, só para ter aqui?

gsettings set org.gnome.desktop.wm.preferences button-layout :close

Eu sou um caso raro que uso o Pop!OS com cinnamon. Até que funciona bem.