Placa wlan0 não ativa

Boa noite galera, estou tentando instalar arch linux no modo UEFI pela primeira vez no note, eu já havia feito instalações no virtual box mas lá não tinha como testar placa wifi.

Não consigo conectar a rede wifi, pesquisei aqui no fórum mas nenhum post é similar ao meu problema, uso um note positivo motion, o driver reconhecido é o iwlwifi, eu rodo wifi-menu pra conectar, seleciono a rede, crio meu perfil e digito a senha, porem dá um erro e não conecta, a placa de rede wlan0 aparece como down só que mesmo usando o comando do ip link pra ativar ela não ativa.

o que aparece pra mim é parecida com a mensagem dessa imagem.

Já adianto que desconheço o Arch, só li sobre algumas vezes.

Pelo terminal também não consegue conectar no wifi?

Não sei se mudou muita o nome de pacotes, mas segue um tutorial

é instalação então eu preciso ativar o wifi pra prosseguir.

meu problema é realmente em conectar a rede wifi, o processo de instalação eu consigo prosseguir, vou tentar desativar o dhcp e ver se funciona, obrigado.

Primeiro de um ip link pra ver se o sistema reconhece o dispositivo e depois dê um iwctl para configurar a rede wifi.

se pretende conectar com networkmanager…

é só desativar o dhcp como falou…

Tentei mas não funcionou, não entendo muito de redes então não sei bem como proseguir.

vc está tentando via terminal na instalação

13- Configurando o Wi-Fi no ambiente Arch Linux

pacman -S wireless_tools wpa_supplicant netctl dialog

Habilitando a rede Wireless
Habilitando a rede wireless automaticamente no boot do sistema:

Talvez seja necessário executar o wifi-menu novamente

$ cd /etc/netctl
Obs.: dê um ls, para ver o conteúdo da pasta.

Dentro do diretório, vai ter um arquivo de perfil, algo como:

ou
Para listar os perfis:

netctl list

ATENÇÃO: veja se no arquivo criado tem a senha e outras configurações preenchidas.

wlp1s0-MeuWifi

Esse arquivo é gerado quando você conecta-se em uma rede com o wifi-menu, onde ficam as informações do roteador que o wifi-menu vai se conectar.

Para habilitar o wifi-menu, para que conecte-se automaticamente toda vez que o sistema iniciar, dê o comando:

$ netctl enable wlp1s0-MeuWifi

Para desabilitar:

$ netctl disable wlp1s0-MeuWifi

Mais informação: netctl - ArchWiki
Atenção: Você pode instalar também programas como NetworkManager e Wicd.
Mais informação: Network configuration - ArchWiki

recomendo sempre instalar na instalaçào o desktop

se for gnome

pacman -S gnome

systemctl enable gdm

principalmente para quem não conhece muito o sistema

Mas como posso instalar os pacotes sem conexão ?

vc tem que inserir o cd de imagem de novo do arch

WI-FI

Na instalação do Arch, rode o programa:

wifi-menu

Escolha a rede e digite sua senha.

E pronto, você está conectado.

monte as partiçoes entre no chroot

e instale o que falta

sim mas quando rodo wifi-menu a conexão falha e mostra a mesma mensagem do inicio do post.

ok…

qual a saía do comando

systemctl -l status [email protected]

e

jourbalctl -xe

As duas, systemctl -l status [email protected] e jourbalctl -xe.

qual a saída?

é um notebook?

se for viu se o hardware rede está ativado?

pelo teclado

Sim é um note, ele reconhece a placa wireless, mas não ativa ela.

Normalmente notebook, vem pm u.a opção fn para habilitar ou desabilitar rede…

Tem o comando rfkill, acho que é isso para verificar isso, no momento Estou no telefone, mas vou verificar isso é te passo o caminho.

Verifiquei aqui, dentro do cd /etc/netctl o arquivo tá criado mas tá vazio a pasta interfaces também está vazia assim como a hooks.