[PARCIALMENTE RESOLVIDO] Queda de frames (FPS) em alguns games ao movimentar o mouse

Oi, pessoal.

Apenas ao movimentar o mouse alguns games apresentam drásticas quedas de quadros por segundo (ou FPS). Uma lista dos games que testei e ocasiões especiais:

  • The Saboteur (GOG) no WINE (tanto no 3.2 quanto no 4.6);
  • Tomb Raider Anniversary (Steam) apenas quando jogado com o Proton 4.2, se jogado com o Proton 3.16 não tem problema algum;
  • Lost Planet: Extreme Condition DEMO (Steam)tanto com o Proton 4.2 quanto com o Proton 3.16.

Meu computador:

Processor Information:
CPU Vendor: GenuineIntel
CPU Brand: Intel® Core™ i3-7100 CPU @ 3.90GHz
Speed: 3900 Mhz
4 logical processors
2 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported
AES: Supported
AVX: Supported
CMPXCHG16B: Supported
LAHF/SAHF: Supported
PrefetchW: Unsupported

Operating System Version:
Kubuntu KDE 18.04.2 LTS (64 bit)
Kernel Version: 4.15.0-47-generic

Video Card:
Driver: Intel Open Source Technology Center Mesa DRI Intel® HD Graphics 630 (Kaby Lake GT2) x86/MMX/SSE2
Driver Version: 3.0 Mesa 18.2.8
OpenGL Version: 3.0
Number of Logical Video Cards: 1
Desktop Resolution: 1920 x 1080

Sound card:
Audio device: Realtek ALC887-VD

Memory:
RAM: 7860 Mb

Andei pesquisando e não acho que realmente exista uma solução pra isso, mas gostaria de saber se sou o único por aqui com esse problema tão específico. :roll_eyes:

[EDIT]
Tentei rodar o The Saboteur e o Lost Planet pelo WINE que está instalado no sistema (nenhum via PlayOnLinux ou Proton) e funcionou direitinho. A conclusão que chego é que há algo de errado com o WINE 3.2 do PlayOnLinux e o Proton 4.2). Já que consegui rodar os jogos mas não sei a causa do problema botei “parcialmente resolvido” no título.

Ola tudo bem, não tenho exatamente este tipo de problema o que eu posso te dar a dica é desligue seus efeitos 3d da area de trabalho e você irá ganhar alguns fps usando o comando dica
1º = ctrl+alt+f12
2º = feche o firefox enquanto joga ou até mesmo o google-chrome porque eles fazem uso da placa de video

Minha opinião é eu uso somente a versão do kde-Neon useredition praticamente não tenho problema algum minha placa a diferença de nossas configs é tão somente a placa de video a minha é gforce gtx750 ti da pra quebrar um galho.
não esqueça de postar como fez pra resolver estarei no aguardo.

1 Curtida

Tu pode rodar apenas esse jogo com o Proton 3.16, é só selecionar a opção nas configurações/propriedades do jogo.

Quanto aos outros dois problemas, sinceramente não sei, mas como o @leonny02 falou, feche todos os outros programas quando for jogar.

Além disso tu pode tentar fazer esses tweaks:

To vendo que teus drivers não estão na última versão, tenta instalar o Mesa atualizado do Padoka:

sudo apt-add-repository ppa:paulo-miguel-dias/mesa
sudo apt update
sudo apt upgrade
“Reiniciar o sistema”

Ah, e além disso tu também pode tentar instalar os jogos via Lutris, muitas vezes funciona melhor que diretamente na Steam nativa.

Se nada disso funcionar provavelmente é algum bug/erro com a execução no game via SteamPlay, o que pode ser corrigido em versões futuras do Proton, aí é só esperar.

1 Curtida

Terei que esperar mesmo porque nada disso funcionou. Infelizmente. :confused:

Obrigado a todos. Qualquer coisa, atualizo a postagem.