Pacotes Quebrados - Corrigir

Olá Pessoal.

Estou precisando de ajuda quanto a um pacote que quebrou e agora não consigo instalar absolutamente nada, muito menos corrigir o erro.

Estou utilizando o Kubuntu 22.04 e ao tentar instalar um programa retornei o erro que existem pacotes quebrados.

No discovery tentei atualizar para ver se corrigia mas me foi retornado o seguinte erro:

E: linux-image-5.15.0-27-generic: o subprocesso instalado, do pacote linux-image-5.15.0-27-generic, o script post-removal retornou erro do status de saída 1

Fui no terminal e rodei um dkpg --configure -a e me foi retornado o seguinte erro:

update-initramfs: deferring update (trigger activated)
Sourcing file /etc/default/grub' /usr/sbin/grub-mkconfig: 10: /etc/default/grub: splash: not found E: Failed to update-grub2 dpkg: erro ao processar o pacote plymouth-theme-kubuntu-logo (--configure): o subprocesso instalado, do pacote plymouth-theme-kubuntu-logo, o script post-installation retornou erro do status de saída 127 Configurando linux-image-5.15.0-33-generic (5.15.0-33.34) ... A processar 'triggers' para initramfs-tools (0.140ubuntu13) ... update-initramfs: Generating /boot/initrd.img-5.15.0-33-generic I: The initramfs will attempt to resume from /dev/sda11 I: (UUID=9feea65b-9a60-4a2e-898f-a6b2c51acc7b) I: Set the RESUME variable to override this. A processar 'triggers' para linux-image-5.15.0-33-generic (5.15.0-33.34) ... /etc/kernel/postinst.d/initramfs-tools: update-initramfs: Generating /boot/initrd.img-5.15.0-33-generic I: The initramfs will attempt to resume from /dev/sda11 I: (UUID=9feea65b-9a60-4a2e-898f-a6b2c51acc7b) I: Set the RESUME variable to override this. /etc/kernel/postinst.d/zz-update-grub: Sourcing file /etc/default/grub’
/usr/sbin/grub-mkconfig: 10: /etc/default/grub: splash: not found
run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 127
dpkg: erro ao processar o pacote linux-image-5.15.0-33-generic (–configure):
o subprocesso instalado, do pacote linux-image-5.15.0-33-generic, o script post-installation retornou erro do status de saída 1
Erros foram encontrados durante o processamento de:
plymouth-theme-kubuntu-logo
linux-image-5.15.0-33-generic

Com um apt-get install -f o retorno é o seguinte:

Lendo listas de pacotes… Pronto
Construindo árvore de dependências… Pronto
Lendo informação de estado… Pronto
Os pacotes a seguir serão REMOVIDOS:
linux-image-5.15.0-27-generic
0 pacotes atualizados, 0 pacotes novos instalados, 1 a serem removidos e 63 não atualizados.
3 pacotes não totalmente instalados ou removidos.
Depois desta operação, 11,1 MB de espaço em disco serão liberados.
Você quer continuar? [S/n]
(Lendo banco de dados … 274329 ficheiros e directórios actualmente instalados.)
A remover linux-image-5.15.0-27-generic (5.15.0-27.28) …
/etc/kernel/postrm.d/initramfs-tools:
update-initramfs: Deleting /boot/initrd.img-5.15.0-27-generic
/etc/kernel/postrm.d/zz-update-grub:
Sourcing file `/etc/default/grub’
/usr/sbin/grub-mkconfig: 10: /etc/default/grub: splash: not found
run-parts: /etc/kernel/postrm.d/zz-update-grub exited with return code 127
dpkg: erro ao processar o pacote linux-image-5.15.0-27-generic (–remove):
o subprocesso instalado, do pacote linux-image-5.15.0-27-generic, o script post-removal retornou erro do status de saída 1
dpkg: demasiados erros, a parar
Erros foram encontrados durante o processamento de:
linux-image-5.15.0-27-generic
Processamento parou porque havia muitos erros.
E: Sub-process /usr/bin/dpkg returned an error code (1)

Alguem poderia me ajudar? Estou impossibilitado de instalar qualquer coisa e preciso realmente de algumas coisas para o trabalho.

1 curtida

Parece que o problema está no pacote plymouth-theme-kubuntu-logo. Tente reinstalar o Plymouth.

Primeiro, edite o arquivo /etc/default/grub, removendo a palavra splash da linha que começa com

GRUB_CMDLINE_LINUX_DEFAULT="quiet...

A seguir, atualize o grub com o comando sudo update-grub.

Depois, veja se consegue rodar esses comandos, em sequência:
sudo apt purge plymouth*
sudo apt install -f
sudo dpkg --configure -a

Para instalar novamente o Plymouth:
sudo apt install plymouth plymouth-theme-kubuntu-logo plymouth-theme-kubuntu-text

Em seguida, edite novamente o arquivo /etc/default/grub inserindo novamente a palavra splash, no mesmo lugar de onde você apagou, salve o arquivo e rode um sudo update-grub novamente.

tambem estou com um erro parecido estou utilizando o ubuntu 22.04 lts e ao rodar apt upgrade ele pede para rodar o comando ‘apt --fix-broken install’ rodo o comando e ele me retorna o seguinte erro

Preparing to unpack .../linux-image-5.15.0-33-generic_5.15.0-33.34_amd64.deb ...
Unpacking linux-image-5.15.0-33-generic (5.15.0-33.34) ...
dpkg: error processing archive /var/cache/apt/archives/linux-image-5.15.0-33-generic_5.15.0-33.34_amd64.deb (--unpack):
 unable to open '/boot/vmlinuz-5.15.0-33-generic.dpkg-new': Operation not permitted
Errors were encountered while processing:
 /var/cache/apt/archives/linux-image-5.15.0-33-generic_5.15.0-33.34_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1) '

Talvez seja erro de cahce com o apt. Tente: sudo apt autoclean && sudo apt update && sudo apt autoremove -y && sudo apt full-upgrade -y

Se não funcionar, tenta esse, mais radical

sudo dkpg --configure -a

1 curtida