Pacotes mantidos nas versões atuais, como atualizar?

Então, estou tentando atualizar 5 pacotes, mas das maneiras que conheço, não deu certo e quando eu tento pelo atualizador do próprio ubuntu, quando chegar nesses packs, ele fala que deu erro na internet… Ou seja, não to conseguindo atualizar de jeito nenhum, vi uns problemas parecidos aqui no forum, mas não consegui entender o que fazer ao certo :frowning:

[email protected]:~$ sudo apt-get update
[sudo] senha para guilherme: 
Atingido:1 http://br.archive.ubuntu.com/ubuntu focal InRelease
Atingido:2 http://dl.google.com/linux/chrome/deb stable InRelease              
Atingido:3 http://br.archive.ubuntu.com/ubuntu focal-updates InRelease         
Atingido:4 http://br.archive.ubuntu.com/ubuntu focal-backports InRelease       
Atingido:5 https://repo.steampowered.com/steam stable InRelease                
Atingido:6 https://dl.winehq.org/wine-builds/ubuntu focal InRelease            
Atingido:7 http://ppa.launchpad.net/ernstp/mesarc/ubuntu focal InRelease       
Atingido:8 http://security.ubuntu.com/ubuntu focal-security InRelease
Atingido:9 http://ppa.launchpad.net/flexiondotorg/mangohud/ubuntu focal InRelease
Atingido:10 http://ppa.launchpad.net/lutris-team/lutris/ubuntu focal InRelease
Lendo listas de pacotes... Pronto
[email protected]:~$ sudo apt-get upgrade
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Calculando atualização... Pronto
Os pacotes a seguir serão mantidos em suas versões atuais:
  libvkd3d1 wine-staging wine-staging-amd64 wine-staging-i386:i386
  winehq-staging
**0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 5 não atualizados.**
[email protected]:~$ sudo apt dist-upgrade
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Calculando atualização... Pronto
Os NOVOS pacotes a seguir serão instalados:
  libvkd3d-shader1 libvkd3d-shader1:i386 libvkd3d1:i386 vkd3d-compiler:i386
Os pacotes a seguir serão atualizados:
  libvkd3d1 wine-staging wine-staging-amd64 wine-staging-i386:i386
  winehq-staging
5 pacotes atualizados, 4 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
É preciso baixar 171 MB/171 MB de arquivos.
Depois desta operação, 3.192 kB adicionais de espaço em disco serão usados.
Você quer continuar? [S/n] s
Obter:1 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 winehq-staging amd64 6.17~focal-1 [1.928 B]
Err:1 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 winehq-staging amd64 6.17~focal-1
  File has unexpected size (1932 != 1928). Mirror sync in progress? [IP: 151.101.194.217 443]
  Hashes of expected file:
   - SHA512:dbd4301fc46570f00731408ddeac02561977ae5ab8b08d8f5f3c2c6852818dddeec717d8f67f4da21f2507ed51da661a73d70dac7a1a2e0a5dc02f3b74278dda
   - SHA256:b0aed899399d66fc5a2c37ddc670f305e0ca148041055f03c5f56df3f23c55b7
   - SHA1:9197ca14a5691dbf764eb40f86a63258aa998dc7 [weak]
   - MD5Sum:7847b322ca146f4da687d7e1fbe85d10 [weak]
   - Filesize:1928 [weak]
Obter:2 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 wine-staging amd64 6.17~focal-1 [3.621 kB]
Err:2 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 wine-staging amd64 6.17~focal-1
  File has unexpected size (3623076 != 3620848). Mirror sync in progress? [IP: 151.101.194.217 443]
  Hashes of expected file:
   - SHA512:6abbdc0fbccc1720f2d286c0c9f60fbb056fe2bba649fded660f6cceff13058bf33b421e1c417ac9500bd78bb5b2bb48842ea9a7829e11bd1cae2c6365299b88
   - SHA256:3394091590d2e143c1e4769b91966214d80360a126b4096bee53e6c0e9e09a1c
   - SHA1:7d6d24f31a331445e201e0edf4f5df1d740fd026 [weak]
   - MD5Sum:6b5039ef73e5cb968108199ff69fbbe5 [weak]
   - Filesize:3620848 [weak]
Obter:3 https://dl.winehq.org/wine-builds/ubuntu focal/main i386 wine-staging-i386 i386 6.17~focal-1 [81,7 MB]
Err:3 https://dl.winehq.org/wine-builds/ubuntu focal/main i386 wine-staging-i386 i386 6.17~focal-1
  File has unexpected size (81675616 != 81686648). Mirror sync in progress? [IP: 151.101.194.217 443]
  Hashes of expected file:
   - SHA512:15ecee1d18684bfe81eeff78c260a94d4246b00f49d671df75a45ca5ef1372d17357587c751638f7a4e66a0757681046ea800d647d75477c528d1ce09714f632
   - SHA256:f9ba3563fbe79c652bdeabab9db7bca085741c80ef92ba770c7bc8b91b7c2964
   - SHA1:8d3071e2f05b1c05a53594179d2a985eecb9ae69 [weak]
   - MD5Sum:0b24400a2cda869352297f32ba395745 [weak]
   - Filesize:81686648 [weak]
Obter:4 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 wine-staging-amd64 amd64 6.17~focal-1 [85,3 MB]
Err:4 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 wine-staging-amd64 amd64 6.17~focal-1
  File has unexpected size (85280536 != 85266380). Mirror sync in progress? [IP: 151.101.194.217 443]
  Hashes of expected file:
   - SHA512:2004e42ecc066120ace39ddb2f0c89556eca37170e9d29cbabb98c8607ff38d9110ca144a32143220f7b3f7930919218c5f95b722dfd2c1b659654cf4345ebf7
   - SHA256:9d4c8a8fa45107023dcf395c7c0b32da3015671ab59b6a22d2a26a266235d3de
   - SHA1:c6062245aa568957b5ec8c601bb434ce1411df3c [weak]
   - MD5Sum:6bfc8126094d932d00ef56e8a6b02068 [weak]
   - Filesize:85266380 [weak]
E: Falhou ao buscar https://dl.winehq.org/wine-builds/ubuntu/dists/focal/main/binary-amd64/winehq-staging_6.17~focal-1_amd64.deb  File has unexpected size (1932 != 1928). Mirror sync in progress? [IP: 151.101.194.217 443]
   Hashes of expected file:
    - SHA512:dbd4301fc46570f00731408ddeac02561977ae5ab8b08d8f5f3c2c6852818dddeec717d8f67f4da21f2507ed51da661a73d70dac7a1a2e0a5dc02f3b74278dda
    - SHA256:b0aed899399d66fc5a2c37ddc670f305e0ca148041055f03c5f56df3f23c55b7
    - SHA1:9197ca14a5691dbf764eb40f86a63258aa998dc7 [weak]
    - MD5Sum:7847b322ca146f4da687d7e1fbe85d10 [weak]
    - Filesize:1928 [weak]
E: Falhou ao buscar https://dl.winehq.org/wine-builds/ubuntu/dists/focal/main/binary-amd64/wine-staging_6.17~focal-1_amd64.deb  File has unexpected size (3623076 != 3620848). Mirror sync in progress? [IP: 151.101.194.217 443]
   Hashes of expected file:
    - SHA512:6abbdc0fbccc1720f2d286c0c9f60fbb056fe2bba649fded660f6cceff13058bf33b421e1c417ac9500bd78bb5b2bb48842ea9a7829e11bd1cae2c6365299b88
    - SHA256:3394091590d2e143c1e4769b91966214d80360a126b4096bee53e6c0e9e09a1c
    - SHA1:7d6d24f31a331445e201e0edf4f5df1d740fd026 [weak]
    - MD5Sum:6b5039ef73e5cb968108199ff69fbbe5 [weak]
    - Filesize:3620848 [weak]
E: Falhou ao buscar https://dl.winehq.org/wine-builds/ubuntu/dists/focal/main/binary-i386/wine-staging-i386_6.17~focal-1_i386.deb  File has unexpected size (81675616 != 81686648). Mirror sync in progress? [IP: 151.101.194.217 443]
   Hashes of expected file:
    - SHA512:15ecee1d18684bfe81eeff78c260a94d4246b00f49d671df75a45ca5ef1372d17357587c751638f7a4e66a0757681046ea800d647d75477c528d1ce09714f632
    - SHA256:f9ba3563fbe79c652bdeabab9db7bca085741c80ef92ba770c7bc8b91b7c2964
    - SHA1:8d3071e2f05b1c05a53594179d2a985eecb9ae69 [weak]
    - MD5Sum:0b24400a2cda869352297f32ba395745 [weak]
    - Filesize:81686648 [weak]
E: Falhou ao buscar https://dl.winehq.org/wine-builds/ubuntu/dists/focal/main/binary-amd64/wine-staging-amd64_6.17~focal-1_amd64.deb  File has unexpected size (85280536 != 85266380). Mirror sync in progress? [IP: 151.101.194.217 443]
   Hashes of expected file:
    - SHA512:2004e42ecc066120ace39ddb2f0c89556eca37170e9d29cbabb98c8607ff38d9110ca144a32143220f7b3f7930919218c5f95b722dfd2c1b659654cf4345ebf7
    - SHA256:9d4c8a8fa45107023dcf395c7c0b32da3015671ab59b6a22d2a26a266235d3de
    - SHA1:c6062245aa568957b5ec8c601bb434ce1411df3c [weak]
    - MD5Sum:6bfc8126094d932d00ef56e8a6b02068 [weak]
    - Filesize:85266380 [weak]
E: Impossível buscar alguns arquivos, talvez executar apt-get update ou tentar com --fix-missing?
[email protected]:~$

Tentou essa dica da própria mensagem? Se não, rode o comado

sudo apt upgrade --fix-missing

Isso aqui também me chamou atenção, no meu repositório também consta o referente ao wine, porém não consta a palavra dists (linha 12):

inxi -r
Repos:     Active apt repos in: /etc/apt/sources.list 
           1: deb http://archive.ubuntu.com/ubuntu focal main restricted
           2: deb http://archive.ubuntu.com/ubuntu focal-updates main restricted
           3: deb http://archive.ubuntu.com/ubuntu focal universe
           4: deb http://archive.ubuntu.com/ubuntu focal-updates universe
           5: deb http://archive.ubuntu.com/ubuntu focal multiverse
           6: deb http://archive.ubuntu.com/ubuntu focal-updates multiverse
           7: deb http://archive.ubuntu.com/ubuntu focal-backports main restricted universe multiverse
           8: deb http://archive.canonical.com/ubuntu focal partner
           9: deb http://archive.ubuntu.com/ubuntu focal-security main restricted
           10: deb http://archive.ubuntu.com/ubuntu focal-security universe
           11: deb http://archive.ubuntu.com/ubuntu focal-security multiverse
           12: deb https://dl.winehq.org/wine-builds/ubuntu/ focal main
           Active apt repos in: /etc/apt/sources.list.d/google-chrome.list 
           1: deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
           Active apt repos in: /etc/apt/sources.list.d/micahflee-ubuntu-ppa-focal.list 
           1: deb http://ppa.launchpad.net/micahflee/ppa/ubuntu focal main
           Active apt repos in: /etc/apt/sources.list.d/microsoft-edge-dev.list 
           1: deb [arch=amd64] http://packages.microsoft.com/repos/edge/ stable main
           No active apt repos in: /etc/apt/sources.list.d/webupd8team-ubuntu-tor-browser-focal.list 
           Active apt repos in: /etc/apt/sources.list.d/xubuntu-dev-ubuntu-extras-focal.list 
           1: deb http://ppa.launchpad.net/xubuntu-dev/extras/ubuntu focal main

Pode ser que esteja com repositório errado e ao tentar atualizar realmente não encontra.

Já tentei essa --fix… Mas não funcionou, nada funciona kkkkk, eu li em uns fóruns gringos que diziam que era só esperar que depois de um tempo chegariam atualizações pra resolver esse tipo de problema… Vamos ver

Removendo esse repositório e acrescentando o certo deve funcionar, se fosse um problema geral aqui estaria ruim também.

Como no seu perfil está que usa Ubuntu, pode abrir o aplicativo de atualização, acessar a aba outros aplicativos e remover o repositório que está causando problema:


Caso prefira, pode digitar no seu terminal:

sudo nano /etc/apt/sources.list  

Bastaria comentar colocando um ¨#¨ na frente a linha com o repositório com problema:

1 curtida

Provavelmente, por algum acaso do destino, os repositórios estejam atualizando no mesmo momento que você está tentando atualizar.
Tente + tarde fazer um sudo apt update.

1 curtida

Se eu voltar a ter o problema, eu faço esse processo ai, muito obrigado!

Era so isso xD, acordei hoje e so agora tive tempo de colocar pra att, foi tranquilo, ta tudo atualizado :smiley: