Pacote quebrado no ubuntu 19.10

Estou com um pacote quebrado no ubuntu 19.10 ao tentar atualizar aparece a seguinte mensagem
Verifique se você está utilizando repositórios de terceiros. Se estiver, desabilite-os, já que normalmente são fonte de problemas.
Além disso, execute o seguinte comando em um Terminal: apt-get install -f
Transaction failed: O sistema de pacotes está quebrado
Os seguintes pacotes têm dependências não satisfeitas:

libgcc1:i386: libgcrypt20:i386: Depends: libc6 (>= 2.28) mas a 2.30-0ubuntu2 está instalada
Depends: libgpg-error0 (>= 1.25) mas a 1.36-7 está instalada
libgpg-error0:i386: Depends: libc6 (>= 2.28) mas a 2.30-0ubuntu2 está instalada
libidn2-0:i386: Depends: libc6 (>= 2.4) mas a 2.30-0ubuntu2 está instalada
liblz4-1:i386: Depends: libc6 (>= 2.4) mas a 2.30-0ubuntu2 está instalada
liblzma5:i386: libunistring2:i386: Depends: libc6 (>= 2.7) mas a 2.30-0ubuntu2 está instalada

1 Curtida

Muito provavelmente esta acontecendo, por causa do “fim da vida” do 19.04, recomendo vc ir para o 19.10

Perdão pelo erro, eu ja estou no 19.10

De boas, ja alterei pra vc. E vc tem algum repositório de terceiros no sistema, tipo Lutris, WINE e tals??

então, tudo isso começou quando fui instalar o wine.

1 Curtida

No blog tem um tutorial de como instalar o WINEHq de uma forma bem simples e tals. Da uma olhada la

Certo, mas agora tudo que tento instalar da erro por causa deste pacote quebrado.

Tenta tirar o WINE fora, e rodar de novo o comando -f la e ve se vai. Depois tenta instalar o WINE de novo.

1 Curtida

Está ocorrendo conflitos com pacotes de 32 bits, tenho algumas sugestões, primeiro veja se vc instalou o suporte a arquitetura de 32 bits “sudo dpkg --add-architecture i386” , depois tente usar o aptitude, ele costuma te dar mais opções que o APT-GET.

Consegui resolver com esta dica, muito obrigado!

isso aconteceu comigo tbm. me ajuda ai CanalOCaradoTI

quando faço o comando :

  • sudo apt update

E: Type ‘sudo’ is not known on line 4 in source list /etc/apt/sources.list.d/additional-repositories.list
E: The list of sources could not be read.