Nova versão Mgba

Oi @henriquead7

tudo bom???

teria como você empacotar para mim porfavor a nova versão do Mgba???

estou instalando porém a versão contém erros.

Utilizo o Linux Mint 20.

A versão DEB do site oficial, tu fala? Daquela vez que empacotado eles tinham feito “errado” (nem lembro o que era, acho que na postagem do Diolinux eu descrevi o “erro”).

Atualmente estou dando preferência para versão Flatpak, não passo problemas e atualiza relativamente rápido.

Posso até dar uma olhada aqui na DEB, mas reintero que a Flatpak tá bem melhor.

Vc sabe me dizer qual erro em específico?

1 Curtida

@henriquead7 prefiro .deb mesmo.

até desinstalei o flatpak no meu mint.

não era um executável na barra de inicializar.
instalei todos os pacotes, não consigo iniciar o jogo.

já entrei nas pastas que geralmente ficam os arquivos executáveis, para gerar um atalho no gedit, não acho nenhum.

aí quando fui remover todos os pacotes instalados pelo synaptic, não podia ser removido.

quem gera esses instaladores no site, ou não sabe oque está fazendo ou faz de qualquer jeito, porque já é a 3ª vez que tento instalar e dá problema. já tentei diversas versões.

se puder gerar um .deb para mim com a última versão corrigida porfavor.

Não tem mgba-qt e/ou mgba-sdl na pasta /usr/bin ou /bin aí para criar o atalho?

não achei.

Mash instala a versão snap do mgba. Sem dor de cabeça. Só instalar e jogar.

O Mint desativou o Snap, e pelo visto ele nem ia gostar assim já que ele também desativou o Flatpak.

Me pergunto se ele instalou os 3 .DEBs que tem no download do site.

Nunca instalei o mGBA pelo Linux, mas você instalou os 3 DEBs como o @Capezotte mencionou?

Eu analisei dentro deles. Se você instalou os 3, era pro executável estar na pasta /usr/bin/.

sim, instalei os 3 .deb

Tendi. É uma pena uma distro tão popular atrapalhar o usuário.

@Capezotte @kalebesouza @Azure @henriquead7

Consegui instalar uma versão da central de aplicativos do linux mint.
mais tá desatualizada demais.
na central tá a versão 0.7.0
no site tá a 0.8.3

Por isso indiquei o Flatpak, menos dores de cabeça. Quando puder vou ver o pacote .DEB atual deles, mas não garanto nada. Ultimamente está corrido pra mim com o retorno do canal. Não estou dando conta, por conta da quantidade de trabalho para produzir os vídeos do OSistemático e tbm ter que dosar o tempo em frente ao Pc por conta de minha saúde.

(Hj mesmo “tô de molho”, mexendo no PC só via KDE Connect. O vídeo que sai domingo agora foi muito puxado pra mim).

Aí baixo o pacote que tinha feito na época do Diolinux, tbm nem lembro qual era o problema do antigo. Até usava aquele pacote, mas depois acabei migrando para o Flatpak por comodidade (e o pessoal do Flathub passou a manter sempre atualizado, algo que não ocorria na época do post).

Acabei de acessar a postagem, como suspeitei descrevi os erros que encontrei. Depois quando baixar o novo numa VM irei averiguar se a natureza dos erros é a mesma ou não.

Pronto @SuperSayajin, resolvi seu problema (ao menos funcionou aqui no Pop!_OS 20.04).

Novamente o pacote estava sem o “lançador” e desta vez faltava uma biblioteca relacionada ao OpenGL (libopengl0). Sem isso o app não funciona. Pelo que percebi eles usam algum meio automatizado para gerar os pacotes DEB. Depois vou abrir uma issue no Github deles relatando o erro.

Download versão 0.8.3 para Ubuntu 20.04

@henriquead7 Muito Obrigado Henrique.

@henriquead7 deu erro aqui!

Selecting previously unselected package mgba-qt.
(Reading database …
(Reading database … 5%%
(Reading database … 10%%
(Reading database … 15%%
(Reading database … 20%%
(Reading database … 25%%
(Reading database … 30%%
(Reading database … 35%%
(Reading database … 40%%
(Reading database … 45%%
(Reading database … 50%%
(Reading database … 55%%
(Reading database … 60%%
(Reading database … 65%%
(Reading database … 70%%
(Reading database … 75%%
(Reading database … 80%%
(Reading database … 85%%
(Reading database … 90%%
(Reading database … 95%%
(Reading database … 100%%
(Reading database … 373412 files and directories currently installed.)
Preparing to unpack …/mgba-qt.deb …
Unpacking mgba-qt (0.8.3) …
dpkg: error processing archive /home/gustavozlago/Documentos/mGBA 0.8.3 para Ubuntu 20.04/mgba-qt.deb (–install):
trying to overwrite ‘/usr/share/mgba/nointro.dat’, which is also in package mgba-common 0.7.0-1build1
dpkg-deb (subprocess): decompressing archive member: lzma write error: Broken pipe
dpkg-deb: error: subprocess returned error exit status 2
dpkg-deb (subprocess): cannot copy archive member from ‘/home/gustavozlago/Documentos/mGBA 0.8.3 para Ubuntu 20.04/mgba-qt.deb’ to decompressor pipe: failed to write (Broken pipe)
Processing triggers for gnome-menus (3.36.0-1ubuntu1) …
Processing triggers for desktop-file-utils (0.24+linuxmint1) …
Processing triggers for mime-support (3.64ubuntu1) …
Processing triggers for man-db (2.9.1-1) …
Errors were encountered while processing:
/home/gustavozlago/Documentos/mGBA 0.8.3 para Ubuntu 20.04/mgba-qt.deb

(Reading database …
(Reading database … 5%%
(Reading database … 10%%
(Reading database … 15%%
(Reading database … 20%%
(Reading database … 25%%
(Reading database … 30%%
(Reading database … 35%%
(Reading database … 40%%
(Reading database … 45%%
(Reading database … 50%%
(Reading database … 55%%
(Reading database … 60%%
(Reading database … 65%%
(Reading database … 70%%
(Reading database … 75%%
(Reading database … 80%%
(Reading database … 85%%
(Reading database … 90%%
(Reading database … 95%%
(Reading database … 100%%
(Reading database … 373414 files and directories currently installed.)
Preparing to unpack …/mgba-qt.deb …
Unpacking mgba-qt (0.8.3) …
dpkg: error processing archive /home/gustavozlago/Documentos/mGBA 0.8.3 para Ubuntu 20.04/mgba-qt.deb (–install):
trying to overwrite ‘/usr/share/mgba/nointro.dat’, which is also in package mgba-common 0.7.0-1build1
dpkg-deb (subprocess): decompressing archive member: lzma write error: Broken pipe
dpkg-deb: error: subprocess returned error exit status 2
dpkg-deb (subprocess): cannot copy archive member from ‘/home/gustavozlago/Documentos/mGBA 0.8.3 para Ubuntu 20.04/mgba-qt.deb’ to decompressor pipe: failed to write (Broken pipe)
Processing triggers for gnome-menus (3.36.0-1ubuntu1) …
Processing triggers for desktop-file-utils (0.24+linuxmint1) …
Processing triggers for mime-support (3.64ubuntu1) …
Processing triggers for man-db (2.9.1-1) …
Errors were encountered while processing:
/home/gustavozlago/Documentos/mGBA 0.8.3 para Ubuntu 20.04/mgba-qt.deb

Tá dando erro pq tem resquícios da versão 0.7.0 que vc instalou (conforme a mensagem de erro). Tu tem que remover isso.

É só clicar no pacote antigo e ao invés da opção de instalação vai aparecer pra desinstalar.

@henriquead7
eu instalei pela central de aplicativos e já removi.

até antes de instalar utilizei os comandos apt-get autoremove e apt-get autoclean.

@henriquead7 consegui resolver.

entrei no nemo em modo root, e saí apagando os arquivos do emulador no modo manual.