Networkmanager não funciona no meu Arch linux 2019

#1

Depois que entro no cinnamon,clico no ícone Rede e dá uma mensagem de erro em inglês do networkmanager tem que estar executando,sei pois diz

networkmanager alguma coisa to be running.

Porque no meu notebook não executa o networkmanager,mesmo eu tendo instado na instalação do sistema? O que estou fazendo de errado?

0 Likes

#2

Roda o comando $ sudo systemctl enable NetworkManager

Depois reinicia o sistema e ver se vai iniciar com internet.

1 Like

#3

Digito dentro do cinnamon no terminal(Konsole),e se dar erro depois de digitar o comando,o que será que tem o meu computador?

0 Likes

#4

Sim, abre o terminal e digite o comando que te passei.

Se der erro, tira um print do erro e publica aqui para eu poder ajudar melhor.

1 Like

#5

É melhor copiar a frase do erro em um papel que eu tenho aqui,anoto todos os comandos do arch linux nesse papel também.

0 Likes

#6

Agora estou com o Linux mint 19.1 cinnamon,mas na ultima vez que fiz esse comando no arch linux deu a seguinte mensagem de erro

nomedoserviço.service not found (Uma coisa assim se me lembro)

tradução nomedoserviço.service não encontrado (acho que é isso no inglês),também gostaria de saber porque os usuários de Arch Linux ou Linux em geral dizem que quem usa Ruindows da lixosoft é garoto de 12 anos?

Não entendo tudo,pois sou portador da síndrome de noonan e por isso as vezes tenho dificuldade para entender e dificuldade de aprendizado.

0 Likes

#7

Acho que encontrei o conserto do erro,deve ser esse

ip link set enp2s0 up
dhcpcd

Não sei o que faz esses comandos,mas parece ser o conserto do erro networkmanager not found.

0 Likes

#8

O usuário de Arch (ou de qualquer outra distro) que diz que “Ruindows” é coisa de garotos de 12 anos, é um babaca. A pessoa que diz esse tipo de coisa é quem está agindo como um garoto de 12 anos.

O Arch é uma distro voltada a usuários avançadas e isso, infelizmente, acaba fazendo com que muitos Arch users sintam-se superiores, mas isso está longe de ser verdade, não é pq você usa uma distro voltada a usuários avançados que você é superior a alguém. O próprio Dio manja muito e usa o Linux Mint, o Ricardo (Canal O cara do TI) manja muito e usa xubuntu, tive bons professores que usavam Windows e possuem muito mais conhecimento do que muitos que usam um Arch da vida.

Enfim, esse tipo de pessoa que fica falando mal de windows, que fica falando mal de distros voltadas a usuários comuns etc, você só ignora, finge que nem leu ou que nem ouviu (são os famosos xiitas), pq cada pessoa usa o sistema ou a distro que melhor atende as necessidades dela e é isso que você deve fazer, independentemente do que disserem.

5 Likes

#9

Não entendo tudo,pois sou portador da síndrome de noonan e por isso as vezes tenho dificuldade para entender e dificuldade de aprendizado.

Então o Arch Linux provavelmente não é a distro mais indicada para você. Arch Linux é uma distro para usuários avançados, a leitura e compreensão da wiki é essencial para a utilização do sistema.

1 Like

#10

Provavelmente você não está com o serviço ativo. Eu vi que alguns comentaram corretamente sobre você ativar o serviço, porém, colocaram o comando “sudo” não sei se você instalou ele em seu Arch, por isto, minha dica é como a dos demais, porém:

$ su root
# systemctl enable NetworkManager 

Agora execute o comando acima. Quando ver tutoriais com $ (dólar) à frente, significa que o comando é executado com qualquer usuário. Quando observar o # (cifrão) significa que o comando só é executado como root. Administrador do sistema.

4 Likes

#11

Perfeito, professor. Eu não levei em consideração a possibilidade dele não ter instalado o sudo.

2 Likes

#12

Pessoal,obrigado pela ajuda foi de grande valia,agora so fiz o comando wifi-menu depois de entrar no cinnamon e a internet sem fio funcionou,agora estou com o arch linux 2019 com internet sem fio ou seja wifi,porem minha duvida e se tenho que fazer o comado wifi-menu toda vez que entro no cinnamon?

0 Likes

#13

Professor fui digitar wifi-menu depois que reiniciei o arch linux 2019 e apareceu a seguinte mensagem

job for nomedarede.service failed because the control process exited with error code.
see systemctl status nomedarede.service and journalctl -xe for details.

O que devo fazer?

0 Likes

#14

hum… Já tive esse problema bem parecido como essa antes. Bem no meu caso era os serviços. Você tem que desabilitar os outros serviços de rede. E só deixar habilitado o networkmanager.service.
Desabilite dhcpcd e ou qualquer outro serviço de rede utilizado.

tente esses comandos

$ sudo systemctl disable dhcpcd.service
$ sudo systemctl disable dhcpcd@.service
$ sudo systemctl stop dhcpcd.service
$ sudo systemctl stop dhcpcd@.service
#habilite o NetworkManager
$ sudo systemctl enable NetworkManager
$ sudo systemctl start NetworkManager

1 Like

#15

caso não tenha resolvido. Use o seguinte comando:

$ systemctl list-unit-files --state=enabled

O comando mostra todos os serviços habilitados.
OBS:
no meu caso o problema foi com o netctl
então tive que desabilita-lo

$ sudo systemctl disable netctl 
& sudo systemctl stop netctl 
0 Likes

#16

Funcionou Samuel,você foi genial na minha humilde opinião,eu que fui burro,pois deu connection failed depois mas era porque tinha que digitar a senha da rede sem fio,por isso deu esse erro,e demorei para perceber,kkkkkkkkk.

1 Like

#17

O arch linux não tem um programa como recordmydesktop para fazer vídeo aulas,pois vi na wiki que tenho que digitar comandos para gravar a vídeo aula no arch,tem programa com interface gráfica para gravar vídeo aula no arch?

0 Likes

#18

Há o simplescreenrecorder para gravar a tela e fazer vídeo aula.

$ sudo pacman -S simplescreenrecorder

1 Like

#19

eu uso o simplescreenrecorder como já mencionado pelo nosso amigo Lavrudinho.
Mas eu lembro quando quando usava o Gnome com Wayaland ele não funcionava.
Como você possui outra interface gráfica que penso eu usar o Xorg. Então não vai ter problema

1 Like

#20

Só por desencargo de consciência, você instalou e configurou o sudo certinho aí ?

Ta funcionando corretamente ?

0 Likes