Não consigo publicar páginas no WP depois que migrei para o Linux

boa noite galera!

Atualmente desenvolvo os sites com wordpress, mas depois que mudei pro linux, tive muitos prooblemas.
Preciso da ajuda de vocês, pois NÃO CONSIGO PUBLICAR PÁGINAS NO WP.
abaixo segue alguns prints:

data_base

Como podem ver, não consigo publicar nada, pois ao clicar em publicar me aparece um pequeno erro no canto superior esrquerdo.

Me ajudem!!!

Olá @samuelxcastro tudo bem?

Provavelmente seu problema está relacionado com permissões de arquivos. O usuário que você está usando faz parte do grupo www-data?

As permissões dos arquivos que você tirou print estão corretas em todos os lugares? Você precisa ter permissão de escrita nos arquivos e diretórios se quer poder salvar as alterações.

Dá uma olhada nisso.

:vulcan_salute:

1 Curtida

E você poderia me ajudar nessa parte mano pois sou iniciante no Linux. Teria como você me auxiliar em acesso remoto? qual programa você usa para acesso remoto vou instalar? Pois vi alguns comandos de permissões na internet e parece que não adiantaram. Qual o melhor horário que eu posso te chamar? Irei deixar o meu WhatsApp para você aqui me dê um toque assim que possível: (telefone apagado pela moderação para preservar a privacidade do autor)

Um abraço e obrigado pela força!

@samuelxcastro tudo beleza?

Primeiramente, sugiro que apague imediatamente seu número de celular da postagem - estou partindo do pressuposto que seu nome de usuário é basicamente seu nome real e agora também sei seu celular. É preciso ter muito cuidado com a forma como divulgamos nossos dados na internet. :crazy_face:

Segundo, tudo indica que você deu o “salto” de Windows para Linux sem se preparar adequadamente e validar seu fluxo de trabalho antes, isso é muito comum, mas normalmente gera frustração e problemas com prazos. :slight_smile:

Agora sobre a ajuda: Você precisa garantir que todas as permissões estão no lugar certo, como root execute os comandos abaixo e creio que as coisas vão começar a caminhar para você:

Adicionando o seu usuário no grupo www-data: sudo addgroup seu_usuario www-data

Ajustando as permissões dos diretórios: chmod 755 diretorio_dos_arquivos_wordpress -R

Acertando o dono do diretório: chown www-data:www-data diretorio_dos_arquivos_wordpress -R

Faça estes ajustes e depois comente como as coisas estão andando.

:vulcan_salute:

2 Curtidas

Mano primeiramente quero te agradecer por estar me ajudando.
Como sou um pouco leigo, deixarei uma dúvida que tenho quanto o passo-a-passo que me deu:
No caso o meu usuário seria essa parte que destaquei no print?

Seu usuário é o que vem antes da @ no caso desse print usuario617

:vulcan_salute:

2 Curtidas

Olá parceiro, executei tudo conforme o passo-a-passo mas o erro persiste:

Um amigo meu disse que o erro pode ser o php, veja:

Samuel, o Wordpress utiliza escrita em banco de dados - muito pouco do funcionamento é diretamente em disco ou coisa do tipo.

Seu banco de dados está corretamente configurado? Você já validou usuário, nome do banco e permissões? O Wordpress é muito “simples” depois que você aprende a conviver com ele, mas existe uma curva de aprendizado que não pode ser “pulada” se você quer continuar evoluindo na ferramenta.

:vulcan_salute:

Não sei se ajuda, mas fiz esses procedimentos e o erro perciste.

Confira se no arquivo “wp-config.php” as configurações de usuário e senha estão corretas.

Me parece que você está usando algo que interage com o Wordpress e isso pode não estar instalado corretamente. Isso que você está utilizando possui alguma documentação para que você possa rever os passos de instalação e garantir que está tudo ok?

Se esse for o caso, procure ajuda especifica sobre esse programa ou o que quer que seja, assim fica muito mais fácil buscar uma solução.

A quanto tempo você vem trabalhando dessa forma?

:vulcan_salute:

Mano essa instalação no windows é muito simples, já fiz vários sites mas infelizmente no Linux estou tendo esse problema.
Vou fazer o seguinte…
vou fazer uma nova instalação e mais tarde te dou um posicionamento.

Eu realmente entendo isso Samuel, mas você mesmo citou que é novo usando essa ferramenta no Linux e existe uma curva de aprendizado. Da mesma forma que se você saísse do Windows para o “Mac” teria que aprender a fazer isso naquele sistema operacional.

:vulcan_salute:

1 Curtida

Mano, descobri o problema uuuuuuuuuurrull…
Glorifica de pé igreja !!!

O problema era a versão do editor Gutemberg.
Bastou instalar o editor clássico e thanaAaAaAan…
Vuala, página publicada!

De qualquer forma, muito obrigado pela ajuda mano, vc me deu atenção desde manhã.
Obrigado ai :upside_down_face:

2 Curtidas