Não consigo instalar o surf

A instalação ocorre normalmente mas o browser dá erro ao abrir.
O erro é sempre BadWindow (invalid Window parameter).
Será que está faltando alguma dependência para ele funcionar?

Cara existe mais de 65k de pacotes para Linux, qual pacote é esse tal de Surf?

Até onde eu sei só existe um browser chamado Surf da suckless.org.

Você leu o README? :roll_eyes:

Resumo README

Requirements

In order to build surf you need GTK+ and Webkit/GTK+ header files.

In order to use the functionality of the url-bar, also install dmenu[0].

Installation

Edit config.mk to match your local setup (surf is installed into
the /usr/local namespace by default).

Afterwards enter the following command to build and install surf (if
necessary as root):

make clean install

Você precisa do GTK+, Webkit/GTK+ e dmenu[0] como dependencia

Thanks for your help but even after installing the dependencies you mentioned, I receive the following error code:

** (surf:64540): WARNING **: 19:20:41.789: Could not open /sys/firmware/acpi/pm_profile: Falha ao abrir arquivo “/sys/firmware/acpi/pm_profile”: Permissão negada

(surf:64540): Gdk-WARNING **: 19:20:41.814: …/…/…/…/…/gdk/x11/gdkwindow-x11.c:5653 drawable is not a native X11 window
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 18 (X_ChangeProperty)
Resource id in failed request: 0x0
Serial number of failed request: 11
Current serial number in output stream: 12

Você está usando X11 ou Wayland? Se for seção wayland, mude para X11 e tente de novo

Mudei para X11 e o erro agora é:

Falha de segmentação (imagem do núcleo gravada)

** (WebKitWebProcess:37744): CRITICAL : 10:51:24.244: const char webkit_user_message_get_name(WebKitUserMessage): assertion ‘WEBKIT_IS_USER_MESSAGE(message)’ failed

Agradeço muito pela ajuda, mas não perca mais tempo com isso.
Isso está muito complicado.