Multilaser Legacy PC209 - WiFi não funciona no Linux

Olá, pessoal!

Primeiramente, é uma satisfação poder me juntar a essa enorme comunidade do software livre. Já sou usuário parcial de Linux há alguns anos, porém, não avançado. No início do ano, comprei um notebook baratinho, desses que servem somente para executar tarefas simples do dia-a-dia. Usei Windows 10 desde a primeira inicialização, por ser o sistema operacional de fábrica, no entanto, devido à minha necessidade pessoal, decidi instalar o Ubuntu 19.04 nele, mas o WiFi não funciona. Tentei realizar diversos reparos por meio do terminal (tutoriais que encontrei online) infelizmente sem sucesso. Minha placa é uma realtek RTL8723B, e gostaria de saber se quem teve o mesmo problema, conseguiu resolver, se podem me ajudar, enfim…

Agradeço desde já a quem puder me dar uma mãozinha, explicando como proceder para dar fim a este problema. (Já testei outras distro, como Linux mint e Elementary, e deu na mesma).

Acredito que essa matéria possa te ajudar: Como habilitar o Wireless Realtek RTL8723BE no Ubuntu e no Linux Mint

Tentei essa, amigo. Infelizmente sem sucesso! :sleepy:

Apresentou algum erro? Se sim, qual?

Na hora do Make, ele mostra um erro nº2, no final. Isso se repete de outras formas nos outros comandos. É como se não fosse possível instalar o driver. Uma hora, foi como se algum arquivo estivesse faltando, outra, já era a placa que teoricamente não existia…

Tentei com várias pastas do mesmo driver diferentes, de outros tutoriais, mas nada resolveu. Também já fiz algo relacionado a trocar a numeração nas antenas, com 4, 3, 2 e 1, de outro tutorial, mas também não aparece o sinal. É como se nem tivesse WiFi por perto!

Li em algum lugar que corrigiram esse bug numa versão de kernel recente, mas também instalei e não resolveu. Já com Windows funciona tranquilo!

Quero muito parar de usar o Windows. Estou em processo de migração desde o mês passado, minha máquina de casa também já está rodando Ubuntu de boas. Falta só ele pra completar o conjunto e abandonar de vez! :grin::blush:

Talvez isso te ajude.
https://ubuntuforums.org/showthread.php?t=2403539

1 curtida

Ajudou de verdade. Muito obrigado! :grin:
Um dos tópicos continha a solução. :clap::clap::blush:

Poderia informar qual foi a solução aplicada ao seu caso? Acredito que ajudará o pessoal daqui.

Tentei esses códigos primeiro, que foram disponibilizados pelo user jeremy31, do Ubuntu Fóruns. Inicialmente não funcionou, porém não sei se contribuiu para que funcionasse, então vou postar as duas soluções possíveis, em caso de uma complementar a outra.

  • Tentativa nº 1:
sudo apt-get install dkms git build-essential
git clone -b extended https://github.com/lwfinger/rtlwifi_new.git
sudo dkms add ./rtlwifi_new
sudo dkms install rtlwifi-new/0.6
sudo cp -r rtlwifi_new/firmware/rtlwifi/ /lib/firmware/rtlwifi
echo "options rtl8723de ant_sel=2" | sudo tee /etc/modprobe.d/rtl8723de.conf
  • Tentativa nº 2:
history | grep rtl    5  sudo apt search rtl8723
sudo apt search rtl8723
sudo apt-get ppa:hanipouspilot/rtlwifi
sudo add-apt-repository ppa:hanipouspilot/rtlwifi
sudo add-apt-repository ppa:hanipouspilot/rtlwifi
sudo apt-get install rtlwifi-new-dkms linux-firmware
sudo dkms add ./rtl8723bu
git clone https://github.com/lwfinger/rtl8723bu
sudo dkms add ./rtl8723bu
source rtl8723bu/dkms.conf
sudo dkms add ./rtl8723bu source rtl8723bu/dkms.conf
sudo dkms install rtl8723bu/$PACKAGE_VERSION
sudo tee /etc/modprobe.d/blacklist-rtl8xxxu.conf <<< "blacklist rtl8xxxu"
dmesg | grep rtl

A segunda tentativa resolveu o problema.

4 curtidas