Mouse VINIK w500

Resolvi reutilizar um antigo mouse Wireless que tinha guardado a algum tempo. O mouse é um VINIK w500 e o Sistema Operacional é o Ubuntu 20.04. O mouse está funcionando porém os eixos X e Y estão invertidos. Quando empurro o mouse para cima o cursos vem para baixo, quando empurro o mouse para baixo o cursor vai para cima, quando empurro o mouse para esquerda o cursor vai para direita e quando empurro o mouse para direita o cursor vai para esquerda.

Pesquisei em diversas paginas que falam sobre o xinput porém não consegui desatar este nó.


informações sobre o hardware.

xinput list

⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ HID Wireless Mouse HID Wireless Mouse id=10 [slave pointer (2)]
⎜ ↳ Synaptics s3203 id=12 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Power Button id=6 [slave keyboard (3)]
↳ Video Bus id=7 [slave keyboard (3)]
↳ Power Button id=8 [slave keyboard (3)]
↳ Sleep Button id=9 [slave keyboard (3)]
↳ Integrated_Webcam_HD: Integrate id=11 [slave keyboard (3)]
↳ Dell WMI hotkeys id=13 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=14 [slave keyboard (3)]

xinput --list-props 'HID Wireless Mouse HID Wireless Mouse ’

Device 'HID Wireless Mouse HID Wireless Mouse ':
Device Enabled (164): 1
Coordinate Transformation Matrix (166): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
libinput Natural Scrolling Enabled (301): 0
libinput Natural Scrolling Enabled Default (302): 0
libinput Scroll Methods Available (303): 0, 0, 1
libinput Scroll Method Enabled (304): 0, 0, 0
libinput Scroll Method Enabled Default (305): 0, 0, 0
libinput Button Scrolling Button (306): 2
libinput Button Scrolling Button Default (307): 2
libinput Middle Emulation Enabled (308): 0
libinput Middle Emulation Enabled Default (309): 0
libinput Accel Speed (310): 0.000000
libinput Accel Speed Default (311): 0.000000
libinput Accel Profiles Available (312): 1, 1
libinput Accel Profile Enabled (313): 1, 0
libinput Accel Profile Enabled Default (314): 1, 0
libinput Left Handed Enabled (315): 0
libinput Left Handed Enabled Default (316): 0
libinput Send Events Modes Available (286): 1, 0
libinput Send Events Mode Enabled (287): 0, 0
libinput Send Events Mode Enabled Default (288): 0, 0
Device Node (289): “/dev/input/event6”
Device Product ID (290): 7511, 22
libinput Drag Lock Buttons (317):
libinput Horizontal Scroll Enabled (318):

Oi cara…

Caso tenha o arquivo /etc/xorg.conf
Remova ele.

Eu não sei se no ubuntu tem a pasta (/etc/X11/xorg.conf.d). Se não tiver crie.

sudo mkdir -p /etc/X11/xorg.conf.d

Depois crie o arquivo

/etc/X11/xorg.conf.d/50-inverter_mouse.conf

sudo nano /etc/X11/xorg.conf.d/50-inverter_mouse.conf

E adicione o conteúdo

Section "InputClass"
       Identifier "Eixo Invertido"
       MatchProduct "VINIK w500"
       # Inverta o respectivo eixo.
       Option "InvertX" "on"
       Option "InvertY" "on"
EndSection

salve e reinicie o pc

Não funcionou.
Tem mais algum comando necessário para aplicar estar configurações?

ok
tenta

Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "ZAxisMapping" "4 5 6 7"
    Option         "FlipXY" "True"
EndSection

Testei todas as configurações que me repassaram no fórum.
Mesmo que estas não tenham funcionado acabaram orientando para o caminho correto.

Decidi realizar alguns testes como o comando /usr/bin/xinput;

Acabei chegando ao seguinte comando que finalmente me permitiu, mesmo que
de forma manual, configurar o mouse corretamente.

/usr/bin/xinput set-prop "HID Wireless Mouse HID Wireless Mouse " “Coordinate Transformation Matrix” 1.000000 0.000000 0.000000 0.000000 1.000000 0.000000 0.000000 0.000000 -1.000000

Esta limha pode ser simplificada para o seguinte comando. Neste caso é necessário encontrar o ID do mouse atavés do commando xinput list ( neste caso 10 ).
/usr/bin/xinput set-prop 10 166 1.000000 0.000000 0.000000 0.000000 1.000000 0.000000 0.000000 0.000000 -1.000000

Posteriormente resolvi gastar mais um pouco de fosfato lendo usado um exemplo da pagina Talk:Calibrating Touchscreen - ArchWiki cheguei ao seguinte arquivo de configuração que faz o mouse funcionar de forma automática.

/etc/X11/xorg.conf.d/50-vinik_w500_mouse.conf

Section “InputClass”
Identifier “Vinik w500 mouse calibration”
MatchProduct "HID Wireless Mouse HID Wireless Mouse "
Option “TransformationMatrix” “1.000000 0.000000 0.000000 0.000000 1.000000 0.000000 0.000000 0.000000 -1.000000”
EndSection

Como nem tudo é perfeito. Constatei que o mouse só funciona corretamente quando já estou logado
no Ubuntu sobre X11. Não funciona corretamente sobre Wayland nem sobre o GDM.

Obrigado pela ajuda.
Qualquer novidade volto a postar.
Se alguém tiver alguma dica de como fazer funcionar no Wayland e no GDM agradeço.