Mensagens de erro do Kernel Linux (ACPI Error)

Olá pessoal, tudo bom? Já faz um tempo que tenho tido umas mensagens de erro vindas do kernel que aparecem no boot do sistema (Debian 10). Elas sempre aparecem em grupo e na mesma ordem, indicando que devem estar relacionadas de alguma forma que eu não sei, uma vez que ainda desconheço os detalhes do kernel linux e de seu funcionamento.

Fazendo uma busca rápida nos logs do kernel encontrei os respectivos erros:

  • kernel: [ 0.275222] ACPI Error: Needed type [Reference], found [Integer] (ptrval) (20180810/exresop-69)
  • kernel: [ 0.275285] ACPI Error: AE_AML_OPERAND_TYPE, While resolving operands for [OpcodeName unavailable] (20180810/dswexec-427)
  • kernel: [ 0.275348] ACPI Error: Method parse/execution failed _PR.CPU0._PDC, AE_AML_OPERAND_TYPE (20180810/psparse-516)

Dei uma olhada neste fórum (link-fórum) e a pessoa tem erros bem semelhantes e nem consegue dar boot, mas no meu caso consigo… rodo o sys numa boa. Por isso não me arrisco a seguir a solução de lá.

Alguém ai pode me dar uma luz, um caminho, qqr coisa (kkk) que me aproxime da solução desses erros? Estou usando a versão 4.19.0-6-amd64 do Kernel.
Engraçado que não me lembro de ter tido esses erros nos primeiros dias que instalei o sistema.

Após umas pesquisas descobri que aparentemente dois deles se tratam de bugs. O primeiro erro foi tido por bug pela comunidade do manjaro (ManjaroLink) mas que não acontece nas séries 4.9.x do kernel. O terceiro erro foi relatado no debian Wheezy (DebianBugReport) mas que apareceu aqui no meu pc.
Por isso mandei um email para o controle de bugs do debian para ver se consigo formalizar um relatório.

pelo link que enviou

é só adicionar o opções
** loglevel=3 rd.systemd.show_status=auto rd.udev.log_priority=3**

nem precisa do vga=current

se não sabe o que significa, veja aqui
https://wiki.archlinux.org/index.php/Silent_boot

o loglevel=3, nada mais é que vc pode alterar o nível em que essas mensagens serão impressas

a mesma coisa rd.udev.log_priority=3

se você pode receber mensagens systemd durante a inicialização do initramfs. Você pode passar rd.systemd.show_status=false para desativá-las ou rd.systemd.show_status=auto

para saber o nivel de registro
https://www.linuxtopia.org/online_books/linux_kernel/kernel_configuration/re06.html
The kernel log levels are:

0 (KERN_EMERG)

The system is unusable.

1 (KERN_ALERT)

Actions that must be taken care of immediately.

2 (KERN_CRIT)

Critical conditions.

3 (KERN_ERR)

Non-critical error conditions.

4 (KERN_WARNING)

Warning conditions that should be taken care of.

5 (KERN_NOTICE)

Normal, but significant events.

6 (KERN_INFO)

Informational messages that require no action.

7 (KERN_DEBUG)

Kernel debugging messages, output by the kernel if the developer enabled debugging at compile time.
1 Curtida

Nossa cara, aprendi de mais com seu post, valeu mesmo! Mas infelizmente as mensagens continuam.
Primeiro eu tentei com loglevel=3 e rd.udev.log_priority=3. Atualizei o grub (update-grub), atualizei o arquivo 20-quiet-printk.conf (sudo bash -c “echo ‘kernel.printk = 3 3 3 3’ > /etc/sysctl.d/20-quiet-printk.conf’”), reiniciei o pc e nada…
Continuei a reduzir o nível de log do kernel até chegar no zero, repetindo o processo falado ali em cima e nada. Então tomei a atitude drástica de desativar as mensagens (rd.systemd.show_status=false) e as mensagens continuam!

Será que estou editando o arquivo do grub errado (/etc/default/grub)?
A linha editada na última tentativa ficou assim:

GRUB_CMDLINE_LINUX_DEFAULT="quiet loglevel=0 rd.systemd.show_status=false rd.udev.log_priority=0"

Mas de qualquer forma, depois dessa discussão, acho bom deixar no nível 3 ou até mesmo no 4. Afinal, se o kernel está mandando mensagem, acho bom dar uma conferida.

o local está aparentemente certo, mas vc depois deste processo está atualizando o grub?

vc usa o debian

acho que no debian update-grub

sudo update-grub

sim cara, eu atualizava com sudo update-grub

aqui funciona

aqui uso

GRUB_CMDLINE_LINUX_DEFAULT=“loglevel=3 quiet libahci.ignore_sss=1 video=VGA-1:d”

https://linuxconfig.org/introduction-to-the-linux-kernel-log-levels

Bom, como meu intuito original nesse tópico era solucionar os erros e não escondê-los
(diminuindo o nível do log do Kernel), vou parar por um tempo de focar nisso.
Só pra constar, outra pessoa também tentou suprimir mensagens do Kernel editando o loglevel=0 no arquivo do grub, e as mensagens ainda apareciam (link).
Mas agradeço de mais ai @swatquest pela disponibilidade de me ajudar!