Lenovo Ideapad L340 gamer 81tr0003br Qual distro? volto para o Windows?

Bom dia Galera!

Eu comprei um Lenovo L340, mas não me atentei as questões de limitações (por parte da Lenovo) com Linux. Veio com Windows 10 home num i5-9300hf 8gb de ram e 1 tb de hd, logo coloquei um ssd nvme.
Esse note no Windows dá pra ajustar brilho da tela, configurar bateria, e a wifi fica no máximo (433mb/s adap qualcomm), porém no Pop, Mint, Zorin, e ubuntu nada disso funciona corretamente > Não tem ajuste de brilho, a rede wifi fica com link de 6mb/s (apesar de teste via terminal e no site fast da netflix está ok sempre passa de 100mb/s doideira)…
O que faço? tem alguma distro que funcione com este note? ou pra usar tais recursos terei que ficar no windows?
Vou tentar hoje o Fedora worstation 33…
Ajuda ai brothers não queria sair do Linux

Estranho o brilho dele não estar funcionando. Minha suposição é que você não deve ter instalado os drivers de vídeo prorpietários, ou ao menos não fez o switch do Nouveau para o Closed Source. Instala a ISO com os drivers da nvidia do Pop!_OS 20.10 e, assim que terminar a criação de usuário e etc, rode no terminal: sudo prime-select nvidia e reinicie o pc. Quanto a velocidade do Wi-Fi, eu suponho que é a falta de um driver para o adaptador wireless da qualcomm, o que é uma M no mundo Linux, infelizmente.

Se você preferir usar o Mint, tenha certeza de marcar a opção “Codecs multimídia” e, com a distro já instalada, vá até a opção de drivers adicionais e mande instalar o driver da nvidia, por fim abra o terminal e digite sudo prime-select nvidia e reinicie seu laptop.

Link interessante: How To Set Up Linux Mint 20 For Gaming – Steam Proton, Wine, nVidia GPU, Lutris, Feral Gamemode - YouTube

2 curtidas

Eu uso o Pop!_OS 20.04 LTS no Lenovo S145, Intel Core i7-8565U, 12GB de RAM, SSD 240GB, SSD 512GB M.2 NVMe, NVIDIA GeForce MX110.

Eu não tive esse problema de notação com a Wifi, mas você disse que ela está funcionando com a velocidade normal, a questão é só a marcação da velocidade do link. Eu não sei como resolver isso.

image

O meu tem ajuste de brilho nativo no painel.

image

No seu PC não aparece essa opção?

Tem duas extensões do GNOME que podem te ajudar no controle do brilho:

https://extensions.gnome.org/extension/2808/brightness-panel-menu-indicator/

https://extensions.gnome.org/extension/1410/discrete-brightness/

Teste e veja a que melhor te atende.

Para o controle de bateria existe a seguinte opção:

Eu não uso, mas pode ser útil para você.

2 curtidas

O Pop!_OS foi o primeiro que instalei (Iso com drivers nvidia). tentei esse comando no ubuntu agora mais acho que deve ser logo após a instalação (como você mesmo disse)

Então até aparece esse controle de brilho, porém tanto faz se deixo ele em 0 ou 100% não muda nada…
a wifi deve ser falta de driver dessa qualcomm nfa435a…

Após a instalação da distro e a instalação dos drivers de video proprietários da Nvidia no Ubuntu e derivados

Vou ter que formatar mais uma vez então, pra ver se dá certo! Até publiquei na comunidade Lenovo a minha insatisfação, hoje ao meu ver todo hardware deveria ter suporte ao Linux ( as fabricantes deveriam vender com uma distribuição Linux e dá a opção de ter Windows… mas ainda preferem acordos com a Microsoft :rage:

Amigão, por mais que eu ame o pinguim, uso desde 2014, mas uma coisa é certa: Dinheiro fala mais alto.
Money can buy many things. Even power
-Vladimir Makarov

1 curtida

Infelizmente, acho que vou ter que usar Windows com este notebook!
Já cansei de formatar, é a 5ª tentativa… não dá pra ficar usando com a tela no brilho máximo…
Eu vacilei em não ter feito estes teste com Linux nos 7 dias, pq já teria devolvido esse notebook

Teste o xrandr ou o xbacklight para ver se funcionam.

Dê uma olhada nesse tópico que postaram no Reddit:

Tem um jeito de ajustar o brilho pelo terminal, com o comando
xrandr --output DP-0 --brightness 0.3
Esse DP-0 é a saída de vídeo. Verifique se é esse mesmo o nome que está aparecendo lá, com o comando xrandr sozinho. Aí você troca esse 0.3 pelo valor que vc quer. 1 é 100%. Veja aí se funciona. Eu sei que não é a solução ideal, mas você pode ir usando temporariamente até encontrar uma solução definitiva ou até resolverem o problema.

Ah, e você já testou alguma distro com outra interface, tipo o KDE Plasma, ou até mesmo o XFCE?

1 curtida

Blz! Vou fazer uns testes, acabei instalando o Windows 10 e realmente funciona tudo… a única coisa que o Linux tem de diferente é o driver do touchpad melhor… mas vou tentar outra interface (KDE, XFCE) pq Cinnamon, Mate não rolou…

1 curtida

Perguntei a Lenovo qual distro eles indicam e a resposta é:

"A versão garantimos a compatibilidade pois é mesma versão comercializada nesse modelo é o Satux.

Outras versões podem funcionar, mas apresentar algumas incompatibilidades que são resolvidas na maioria das vezes com a atualização do Kernel."

o Kernel eu atualizei em um dos teste para ultima versão estável no Ubuntu…
Esse Satux foi descontinuado certo? não achei nem site deles…

Estou com o mesmo problema. Antes de achar seu post cheguei a tentar diferentes versões do popOS e do Ubuntu, com diferentes drivers pra placa de vídeo.

Você conseguiu resolver o problema de alguma forma?

Então, eu acabei desistindo…
Tentei varias distros e nada, esse problema do brilho é muito chato e não tem como usar o note sempre com 100% de brilho. Hoje sigo no Windows 10 (por enquanto)…

Você usou quais distros. Talvez alguma que não fosse da base Ubuntu/Debian fosse uma boa opção…tentou usar Manjaro?

O site abaixo me ajudou a resolver esse problema.

https://wiki.archlinux.org/index.php/Backlight#Kernel_command-line_options

Eu uso o Pop!_OS 20.04 LTS. O meu notebook é um Lenovo Ideapad S145.

Eu inseri o parâmetro acpi_backlight=native no Kernel:

sudo kernelstub --add-options “acpi_backlight=native”

Essa opção foi a que funcionou para mim. Ela foi uma das alternativas especificadas no site que eu te indiquei.

Eu estou usando a extensão Brightness Panel Menu Indicator para facilitar a mudança do brilho da tela.

https://extensions.gnome.org/extension/2808/brightness-panel-menu-indicator/

Por favor, pesquise antes de qualquer alteração, principalmente ao adicionar parâmetros ao Kernel. Essa solução funcionou para mim, mas é prudente que você pesquise antes de realizar as mudanças.

Eu fiz algumas modificações no arquivo de configuração do Xorg também. Elas poderão ser estudas no site abaixo. Essas mudanças foram feitas para solucionar o problema que eu estava tendo com gráficos corrompidos.

https://wiki.archlinux.org/index.php/intel_graphics

Eu uso o sistema em modo híbrido (Intel + Nvidia).

1 curtida

Por favor, veja a minha resposta para o autor da postagem. Talvez a minha proposta de solução seja útil para você.

Usei Zorin, Pop, Ubuntu, Mint e Fedora, nenhuma funcionou… Vamos se o Manjaro resolve meu problema…

Vou pesquisar mais e ver se funciona no Ideapad L340…