League of Legends não rodando no Fedora 35 (para mim)

Eu venho tentando baixar o League of Legends no Fedora 35 de várias formas, mas todas elas ocorrem a mesma coisa.

O Riot Client abre tranquilamente, mas quando é vez do Client do League of Legends abrir, ele fecha. E fecha tudo, fecha o lutris tbm. Não sei mais o que fazer :frowning:

1 curtida

Bem vindo ao fórum @syna!

Vou te pedir para seguir o seguinte tópico, a ideia é nos passar mais informações sobre a sua máquina e sistema: Como fornecer boas informações.


Já adiantando, quando diz:

Uma boa dica é abrir pelo terminal, assim quando for fechar sozinho vai nos mostrar exatamente o que está causando a falha.

2 curtidas

ok, vou fazer

1 curtida

Tente instalar a versão Flatpak, caso continue dando erro, pq o Lutris tá ficando é uma bela de uma porcaria, parece q o suporte tá sumindo aos poucos. Tentei rodar Serious Sams aqui no Manjaro e tbm n consegui, tive q rodar por outros meios (bottles).

Lutris tem para flatpak ainda?

Você usou o Wine puro ou usou o Lutris?
O ideal é usar o script feito por eles para instalar o LOL e ler com calma, pois esse jogo é todo quebrado no Linux devido as últimas atualizações.

Eu li esse, e o League of Linux no reddit, fiz tudo, mas no Fedora não tem tanta informação assim, já tinha conseguido no Arch e tal, mas Fedora nem entrou no game

Oi, tudo bem, então, eu mencionei o pacote flatpak mesmo, procure na loja de sua distro (é que eu uso Manjaro e no Pamac tem de tudo, ainda mais q habilite suporte a Flatpak e Snap).
League of Legends no Linux via Flatpak - Veja como instalar League of Legends no Linux via Flatpak - Veja como instalar
Alias, o Blog do Edivaldo tem um conteúdo muito rico sobre Linux. Mas no momento está fora do ar (a página q passei n, fica sussa).

Eu estou tentando baixar o jogo pelo lutris e editei o runner options vou ver se entra, mas essa de league of legends no flatpak eu não sabia, obrigado night

1 curtida
MESA-INTEL: warning: Performance support disabled, consider sysctl dev.i915.perf_stream_paranoid=0

MESA-INTEL: warning: Performance support disabled, consider sysctl dev.i915.perf_stream_paranoid=0

MESA-INTEL: warning: Performance support disabled, consider sysctl dev.i915.perf_stream_paranoid=0

LeagueClientUx pid: 25762
Waiting for port 34673

vou tentar instalar pelo flatpak, o lutris realmente n roda league no meu Fedora

Não rolou, pede uma senha e tal, e o game fica atualizado em flatpak?

Faltou as informações do sistema que pedi linkando o tópico e peço que coloque toda saída do comando, desde o comando utilizado para exibir esse erro, como foi exemplificado no tópico que mencionei.

Essas informações são fundamentais para não ficar chutando uma solução.

1 curtida
System:
 Kernel: 5.16.11-200.fc35.x86_64 x86_64 bits: 64 Desktop: GNOME 41.4
   Distro: Fedora release 35 (Thirty Five)
Machine:
 Type: Laptop System: Dell product: Inspiron 15-3567 v: N/A
   serial: <superuser required>
 Mobo: Dell model: 01PXGP v: A00 serial: <superuser required> UEFI: Dell
   v: 2.10.0 date: 05/10/2019
Battery:
 ID-1: BAT0 charge: 18.4 Wh (58.4%) condition: 31.5/41.4 Wh (76.0%)
   volts: 15.1 min: 14.8
CPU:
 Info: dual core model: Intel Core i3-7020U bits: 64 type: MT MCP cache:
   L2: 512 KiB
 Speed (MHz): avg: 2281 min/max: 400/2300 cores: 1: 2277 2: 2300 3: 2248
   4: 2300
Graphics:
 Device-1: Intel driver: i915 v: kernel
 Device-2: Sunplus Innovation Integrated_Webcam_HD type: USB
   driver: uvcvideo
 Display: x11 server: X.Org 1.20.14 driver: loaded: modesetting
   unloaded: fbdev,vesa resolution: 1366x768~60Hz
 OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2F)
   v: 4.6 Mesa 21.3.6
Audio:
 Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
 Sound Server-1: ALSA v: k5.16.11-200.fc35.x86_64 running: yes
 Sound Server-2: PipeWire v: 0.3.47 running: yes
Network:
 Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
   driver: ath9k
 IF: wlp1s0 state: up mac: <filter>
 Device-2: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169
 IF: enp2s0 state: down mac: <filter>
Bluetooth:
 Device-1: Qualcomm Atheros type: USB driver: btusb
 Report: bt-adapter ID: hci0 rfk-id: 1 state: down bt-service: N/A
   rfk-block: hardware: no software: yes address: <filter>
Drives:
 Local Storage: total: 223.57 GiB used: 33.11 GiB (14.8%)
 ID-1: /dev/sda vendor: KingSpec model: P4-240 size: 223.57 GiB
Partition:
 ID-1: / size: 217.44 GiB used: 32.85 GiB (15.1%) fs: ext4 dev: /dev/sda3
 ID-2: /boot size: 973.4 MiB used: 249.3 MiB (25.6%) fs: ext4
   dev: /dev/sda2
 ID-3: /boot/efi size: 598.8 MiB used: 13.8 MiB (2.3%) fs: vfat
   dev: /dev/sda1
Swap:
 ID-1: swap-1 type: zram size: 3.57 GiB used: 1.6 GiB (44.8%)
   dev: /dev/zram0
Sensors:
 System Temperatures: cpu: 48.0 C pch: 47.0 C mobo: 47.0 C
 Fan Speeds (RPM): cpu: 2569
Info:
 Processes: 270 Uptime: 6h 3m Memory: 3.57 GiB used: 2.4 GiB (67.3%)
 Shell: Bash inxi: 3.3.12

É um empacotamento comunitário, assim como a versão em Snap. Portando, se o mantenedor não for rápido o suficiente, você pode ficar com o client desatualizado.

Realmente o game n quer funcionar :frowning:
Obrigado Riot, empresas como vc, quem precisa do diabo. Na verdade, até no Windows aqui n quer mais atualizar o Valorant, tá osso!

Talvez uma solução
How To Install and Play League of Legends Linux (2022) - DekiSoft

Isso não vai ser resolvido por você (pelo menos na teoria). Toda vez que sai um novo patch do League, os criadores do script do Lutris têm de atualizar o script. Então você terá que esperar alguns dias para poder jogar.