Layout de Teclado incorreto[Resolvido]

Oi, estou tendo problemas com layout de meu teclado, por exemplo [ <- era para ser um acento e isso < era para ser um contra-barra

Qual é o layout do seu teclado? Se for ABNT2 e estiver no Arch Linux como consta nas tags, pode-se tentar

loadkeys br-abnt2

(no Terminal)

Ja tentei, mas o terminal retorna o seguinte

Não foi possível obter um descritor de arquivo de referindo ao console.

Edite o arquivo de configuração de teclado (isso só funciona depois de configurar o Xorg, você já está no ambiente gráfico?)

 sudo nano /etc/X11/xorg.conf.d/10-evdev.conf 

Adicione estas linhas:

Section “InputClass”
Identifier “evdev keyboard catchall”
MatchIsKeyboard “on”
MatchDevicePath “/dev/input/event*”
Driver “evdev”
Option “XkbLayout” “br”
Option “XkbVariant” “abnt2"
EndSection

Depois, reinicie.

Ainda nao funcionou, e sim estou ja no ambiente grafico GNOME

setxkbmap -model abnt2 -layout br

Ainda nao :confused:

Se você já está no Gnome você precisa mudar o layout em Configurações -> Região & idioma. Mudar pelo Xorg só terá efeito no tty

1 curtida

No ambiente gráfico configure o teclado como “EUA intenacional com teclas mortas”.

Obrigado pela a ajuda de todas, mas a solução foi a do N1vBruno

Estou com o mesmo problema de teclas acentuadas tipo 'e no lugar de é Porem uso Xubuntu.

Uso o comando e fica normal “setxkbmap -model abnt2 -layout br”
Porem aonde eu coloco esta linha para ficar definitivo.