Kubuntu 18.04.3 bug para instalar novos tema de cursor

Estou com um bug muito chato no kubuntu 18.04.3 que não consegui resolve, quando instalo novos temas de cursores ele não funciona no sistema todo em algumas parte o sistema simplesmente ignora e volta pro cursor do sistema (breeze no caso aqui).
Já tentei vários outros cursores e continuo a mesma coisa, já tentei reinicia o computador pra vê se dava em algo e nada. Eu sempre gostei do DMZ como cursor to quase saindo do KDE por conta disso.

  • Também já tentei instala pelo terminal:
    sudo apt install dmz-cursor-theme
    De nada adianto também.

  • O link do tema que usei foi esse:
    [https://store.kde.org/p/1258818/] - (DMZ Cursors (Fixed for Plasma 5))

Link mostrando o que está acontecendo:
[YouTube] - (Cursor KDE 5 - Kubuntu 18.04.3 LTS)

Outra dúvida:
Aqui no dio plus tem como upa vídeo?
Não achei uma opção.

Me parece que isso tem a ver com o fato de que se programa X ou Y é feito em Qt ou GTK (verifique se é a versão 2 ou 3). Tente observar isso, se nos programas onde o cursor volta para o padrão são “coincidentemente” todos em GTK ou Qt.

Para ver se o programa é feito em Qt ou GTK 2/3, você pode se guiar pelo visual do programa. No caso de dúvida você abre o Synaptic ou Muon e olha as dependências do programa.


Isso o que eu postei não foi uma solução, mas se você ver que segue esse caminho, ao menos você saberá um pouco mais onde está o problema.

1 Curtida

Eu voltei pro xfce mesmo é mais fácil, não tava curtindo muito o KDE por conta desses probleminhas eu sou mais familiarizado com o xfce e assim posso faze o que eu quero com mais facilidade. Em 10 minutos deixei o xfce do jeito que eu queria:

Esse problema acontece porque além de trocar o tema do ambiente gráfico, você precisa setar esse cursor como global do sistema, você pode usar o programa galternatives pra fazer isso.

Porém, o tema que você quer usar, tem que estar na pasta /usr/share/icons, se estiver na pasta ~/.local/share/icons ou ~/.icons, ele não vai aparecer no galternatives.

1 Curtida

Vou tenta isso, vou instala de novo o kubuntu em uma VM e vê se isso funciona.

Após um bom tempo voltei pro KDE, consegui resolve o problema editando o seguinte arquivo:

~/.config/gtk-3.0/settings.ini

Editando:

sudo nano ~/.config/gtk-3.0/settings.ini

Depois apaguei essa linha:

gtk-cursor-theme-name=xxx

Após feito isso eu posso muda o tema do cursor e sair da sessão que ele vai funciona, mas ainda assim no KDE a maioria dos temas de cursor vem tudo bugado como esse tema do MacOS por exemplo:

image

Por algum motivo ele puxa parte do tema padrão mesmo baixando pelo gerenciador de tema do KDE ou baixado e instalando manualmente ‘-’ e mesmo após esse tempo todo que eu criei o post não teve nenhuma melhora pelo menos na versão do kde que estou usando. (KDE versão: 5.17.5 | SO: KDE Neon)