Kernel release 4.10.x.x roda no linuxmint 19.2 pergunta

Alguem saberia dizer se eh possivel roda a latest do linuxmint com um kernel mais antiga tipo 4.10.x.x etc???

A princípio não deve dar nenhum problema.

Porém alguns programas podem não funcionar conforme desejado, caso tenham sido projetados para usar algumas novas funcionalidades, principalmente na área de virtualização e redes.

No caso do desktop ou notebook, talvez o maior problema seja suporte ao hardware. Muitas placas recentes (de vídeo e wireless) podem não ser suportadas nessa versão do kernel.

Porém o maior problema é que esse kernel deixou de ser atualizado em 2017. Se você usá-lo estará com diversas falhas de segurança que não foram corrigidas! Se quiser fazer downgrade, escolha algum dos kernel que são LTS. Atualmente:

  • 4.19.76
  • 4.14.146
  • 4.9.194
  • 4.4.194
  • 3.16.74
    Esses sim est√£o recebendo atualiza√ß√Ķes.

Com sorte você encontrará algum repositório que dê suporte para esses kernel’s, senão terá que compilar e instalar por você mesmo.

Boa tarde amigo, eu desde já agradeço pela sua atenção e seu pronto retorno sobre essa minha questão…sabe o que ocorre vou te explicar se me permitir.
Eu tenho um notebook que comprei nos USA em 2008 veja bem √© uma raridade rsrsrsssrs, na verdade eu pouco usei ele pois usava notebooks que as empresas me disponibilizar√£o. Em resumo meu note HP 2710 bem antigo roda perfeitamente com o linuxmint 18.3 com kernel 4.10.xxx isso pq. esse notebook tem uma nvidia C67 GeForce 7150M / NForce 630M integrada o detalhe que quando eu atualizei o kernel opcionalmente para a release 4.15.xxx o drive da nvidia ficou zuado tipo duplicado display sem condi√ß√Ķes de usar a n√£o ser que eu de um boot com a op√ß√£o --nomodeset etc‚Ķ voc√™ deve entender o que estou dizendo‚Ķresumo da opera‚Ķeu n√£o queria deixar de usar este notebook pois ele est√° zerado mesmo com 11 anos de vida‚Ķser√° que eu consigo aprimorar o kernel 4.15 ou superior para que eu possa deixar meu lmint bem atualizado e com essa release do kernel sem ter que abrir m√£o do meu velho notebook. Obrigado novamente por sua aten√ß√£o.

O correto é instalar o software atualizado e daí solucionar os problemas que surgirem. Teoricamente a compatibilidade deveria continuar. Veja também que o problema pode não ser o kernel, mas sim do módulo da placa nvidia (tbm conhecido como driver). Aliás é muitas vezes maior a chance do problema ser do módulo que foi atualizado.

Se for esse o caso, veja se consegue instalar o módulo antigo na nova instalação. Não tenho nenhuma placa nvidia para poder ajudar mais.

Tente atualizar o driver da Nvidia baixando o instalador do site Líder Mundial de Computação de AI pegue o mais atual.
https://plus.diolinux.com.br/t/instale-o-driver-proprietario-nvidia-baixado-do-site-oficial-em-qualquer-distribuicao/10162
Sim você pode usar um kernel mais antigo eu estou usando a que o Kernel versão: 4.4.0-165-generic
Prefira os de LTS como o meu você pode baixar o código fonte em kernel.org e depois compilar.
Você não vai ter problema com os kernel antigo por causa do hardware já que o seu notebook é muito antigo.

1 curtida