KDE Plasma trava ao abrir uma determinada pasta no Dolphin (wrestool)

Vim deixar registrado um bug que estava ocorrendo comigo para que outras pessoas que tenham o mesmo problema saibam como resolver. O problema era o seguinte: Eu iniciava o sistema, navegava na internet, jogava e fazia tudo mais e o sistema se comportava normalmente até que, ao abrir o Dolphin e acessar a pasta de downloads o sistema simplesmente travava totalmente. Eu nunca soube como resolver isso e temia sempre tentar abrir aquela pasta mas hoje fiz algo diferente e sugiro que, para qualquer bug do tipo, façam a mesma coisa para identificar o causador de um problema de travamento.

Monitorando o Sistema

Eu abri o KSysGuard (O monitor do sistema do KDE) e deixei aberto para monitorar o que acontece. Abri o Dolphin e entrei em algumas pastas e nada de anormal estava acontecendo, até que abri o diretório de downloads e começou novamente… No KSysGuard um programa que eu não conhecia era executado, chamado de “wrestool” e ele começou a consumir recursos do processador e memória RAM de uma forma exponencial até começar a travar. Eu fechei o programa com a famosa caveira (CTRL+ALT+ESC) e pesquisei sobre ele e achei em um determinado site a seguinte descrição sobre:

" Wrestool reads 16 or 32-bit Microsoft Windows ® binaries and lists or extracts the resources they contain. Some resources require processing before they can be written to files; wrestool is able to do this with icon and cursor resources."

Ele executava um programa para ler e exibir recursos de arquivos .exe do windows - e realmente, eu tinha bastante ali para testes - isso fazia de alguma forma consumir muitos recursos da máquina pois o Dolphin estava configurado para mostrar os ícones.

Solução
Identificado o problema:

  • Abri as configurações do Dolphin > Geral > Visualizações
  • Desmarquei “Executáveis do Microsoft Windows” e “Imagens do Microsoft Windows”.
  • Cliquei em “Aplicar”

Pronto. Problema resolvido! :smile:
Espero que esse artigo ajude quem estiver enfrentando o mesmo problema.

Configurações
Ubuntu 20.04.1 LTS x86_64 (Kubuntu)
KDE Plasma 5.18.5
RAM: 4GB
Processador Intel Pentim Dual Core E6500

5 Curtidas

Cara, vê se dá para reportar isso!

2 Curtidas

Opa, eu até tinha esquecido disso, muito obrigado.
Reportei lá também! :smile:

1 Curtida

Obrigado por compartilhar seus conhecimentos.