Jogo via Steam Play não abre

Já acontece com o segundo jogo que eu baixo, primeiro uma versão trial de the division, depois castlevania lords of shadow, o jogo na steam diz que esta rodando, mais não abre, contatei a steam ela disse pra avisar o pessoal no github, ja tentei mudar o proton mais ele continua com o mesmo problema, nao encontro uma saida.

Antes de baixa um jogo eu recomendo você a da uma conferida no ProtonDB para sabe como que o jogo está rodando
Basicamente o site mostra relatos de experiência de outros usuários rodando o game e junto com esses relatos você pode conferi a versão do proton usada, hardware usado e geralmente os usuário postam possíveis modificações que eles tiveram que faze para conserta um bug. Você pode da uma conferida nesse links pra ter mais detalhes e entende melhor como funciona o ProtonDB:


Você pode conferi os jogos que você cito por esses links:
The Division:
https://www.protondb.com/app/365590
Castlevania: Lords of Shadow:
https://www.protondb.com/app/234080

Vou rouba uma frase que vi o @Jedi_Fonseca usando em outro tópico.
“Em geral, o Windows ainda é muito mais completo que qualquer distro Linux no quesito jogos, mas dependendo de o que tu quer jogar, a experiência pode ser bem semelhante.”

Dito tudo isso, vale também avaliar se o Linux é o sistema ideal para o seu uso.

2 Curtidas

Qual distro você está usando ? Sua placa de vídeo ? Dependendo é preciso ver se está com o driver de vídeo atualizado e se tem as bibliotecas corretas instaladas.

Uma vez aconteceu comigo no DmC, mas era configuração mal feita.

gostei desse site, vou ficar de olho agora, mais a pelo pouco que eu vi os cara tão rodando normal, obrigado pela resposta.

to usando o linux mint (tricia), eu tenho uma rx580 de 8gb, eum i5 9400f, eu nao consegui olhar qual a mesa que eu to usando, mais o kernel ta o ultimo 5.3.0-46, tentei instalar o driver da placa mae e ele fica com a tela branca, mais acredito que ta atualizado por que no gerenciador de driver nao aparece nada.

configuração da steam? ja coloquei a steam em beta, e ja tentei alterar as versão do proton, mais não adiantou

Só os jogos via steam play não abrem ?
Os nativos estão abrindo normalmente ?

eu baixei o cs go, funcionou normal, ja o castlevania e o the division a steam mostra que ele abriu mais ele não abre nada, se eu executar muito ele fala que ta aberto, mais naaaada aperece, kk
e nao acho gente com esse problema, to achando que vai ser por causa do linux que to usando o tricia

Antes de rodar o jogo, vai em propriedades e opções e depois tem o botão para adicionar o comando antes de lançar, ative o log,

PROTON_LOG=1 antes de %command%

O arquivo log vai está na pasta do steam… Vai está " o código do jogo ".log

E verifica se está rodando os drive amdgpu

Ainda se não me engano vc tem que instalar alguns pacotes do vulkan,

E talvez seja interessante usar o proton customizado GE

Você está instalando os jogos numa partição NTFS ?

ta sim, no meu ssd .

O fato dos jogos estarem instalados numa partição NTFS é o que pode está causando o problema.

Você já tentou especificar o UID e o GID do seu usuário na linha referente a sua partição NTFS lá no /etc/fstab ?

As bibliotecas vulkan estão instaladas ?

sudo apt install mesa-vulkan-drivers mesa-vulkan-drivers:i386

O fato dos jogos estarem numa partição NTFS também pode ser um problema.

o meu driver ta sendo o amdgpu, quanto eu instalo o pro a tela fica branca com a seta, ai tenho que da unistall, eu coloquei o proton_log=1 na inicialização do jogo, mais nao deu

deu certo, dei esse comando pra instalar o driver vulkan reiniciei e funcionou, muito obrigado, achei que pelo fato do driver ja estar atualizado por causa do kernel, ja estaria tudo ok com a placa de video.

Infelizmente pra quem usa Intel ou AMD essas bibliotecas não vem junto com o driver, para Nvidia sim. Mas no Ubuntu 20.04 e provavelmente o Linux Mint 20, elas já vão vir instaladas no sistema por padrão.

que bom que deu certo,

Em relação ao drive eu utilizo o amdgpu (o drive opensource), mas tive que instalar os pacotes do vulkan também !!! a propósito também utilizo uma RX 580 da XFX com o Ryzen 5 3600 porém estou com o fedora workstation 31.

no caso do comando para criar o arquivo .log, não esqueça que tem que esta em maiúsculo, como uso steam flatpak, o arquivo log fica no diretório:

/home/tiago/.var/app/com.valvesoftware.Steam

e geralmente fica um número ID do jogo, por exemplo Resident Evil 2 re gera o arquivo steam-883710.log
quando tive problema os dados de erro no arquivo .log sempre ajuda a descobrir o que esta acontecendo.

mas bom jogatina por ai :smile:

Ó a minha é xfx tambem, to gostando muito, eu comecei agora com o linux, to apanhando ainda,kkk
mais valeu pela dica!

É engraçado isso, eles não disponibilizarem os driver, passei um aperto com meu mouse também, não achei driver em lugar nenhum, mais configurei ele no windows da minha mãe e ele salvou a config, kkk
mais cada vez mais a galera ta parando de usar o windows, muita coisa não vale a pena nele.