Já tentei de tudo e não resolvi esse erro 7 GPG


Tentei de tudo, vários tutorias no youtube, site da linux, esse site aqui tb e não resolveu nada, sou iniciante e nem sei mexer muito, estou ficando doido, faz 2 dias que comprei ele e nem instalei a steam. alguém aqui pfv sabe resolver?

@Robson2 seja bem-vindo ao Fórum.

“já tentei de tudo”

Compreendo que você é “iniciante” – eu também já fui, e todos os nossos colegas aqui também já foram. – Estamos todos prontos para nos esforçarmos para entender as dificuldades de um iniciante (temos até saudades dessa fase de nossas vidas!).

Mas, não temos bola de cristal, para adivinhar qual o seu hardware, sua distro, seu grau (maior ou menor) de conhecimento, ou quais quais “tutoriais do youtube” você assistiu.

Acho que os colegas, aqui no Fórum, precisam de mais informações, para poderem lhe ajudar.

isso é um problema no servidor do Repositório (mirror) da sua distro, por algum motivo não esta disponibilizando a chave pública ou ela esta com certificado vencido.

Mude o servidor do Repositório onde faz as atualizações, tente colocar a fonte de outro pais.

/etc/apt/sources.list


ou instale outra distro mais recente.

Achei o problema: vc comprou uma máquina com um sistema feito para reduzir o preço de venda, mas ser substituído pelo Windows pirata.

O melhor a fazer é trocar o que está instalado, por um sistema de qualidade.
Dá uma conferida nesse aqui: http://tigeros.com.br

1 curtida

temos dois “problemas” aqui, facilmente resolvíveis. são tão antigos quanto a origem do linux. nada demais. o primeiro é do pubkey, que vc resolve assim:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 2F7F…489

sudo apt update

tem também o erro do “key is stored in legacy trusted…” mas este só posso mostrar como faz quando eu chegar em casa, porque não me lembro de cabeça.

os linux mais novos somente o pubkey não resolve.

PS1: to vendo aqui vc tem lista de repositório de 32 e 64 bits. s vc n usa de 32, pode desabilitá-lo no /etc/apt/sources.list assim:

ANTES

deb http://etc…etc…etc…

DEPOIS

deb [arch=amd64] http://etc…etc…etc

agora rode:

$ sudo apt update

altere todas as linhas de repositórios para carregar somente os de 64 bits. vc desabilita os repositorios 32 bits que não usa e deve resolver o erro na foto. lembre-se de que o repositorio do virtualbox não é oficial, assim não tem a chave de autenticação no ubuntu, debian etc. tem de carregar na mão.