Instalação do Sped Fiscal

Boa noite, sou novo aqui!
No meu trabalho estou usando Linux Ubuntu no meu computador pessoal fiz a instalação a menos de uma semana, mas estou tendo um pequeno problema, faço Sped Fiscal da empresa, mas no em tando não conseguir instalar o programa Sped Fiscal, já olhei alguns videos no youtube mas nenhum deu certo.
Se alguém pode me ajudar ficarei grato.

Olá @weliton

Seria interessante mais informações sobre o erro que você está tendo, contudo vamos começar instalando e configurando o Java 8, mais especificamente o OpenJDK 8.

A versão do OpenJDK 8 que está no seu repositório pode (ou não) ser suficiente, contudo o OpenJDK fornece um PPA.

OBS: Testado no KDE Neon (18.04).

Adicionando o PPA:

sudo add-apt-repository ppa:openjdk-r/ppa

Atualizando a lista de repositórios (isso se o comando a cima não realizar esse procedimento de forma automática):

sudo apt update

Instalando o OpenJDK 8:

sudo apt install openjdk-8-jdk

Definindo que o OpenJDK 8 é o padrão para o sistema:

sudo update-alternatives --config java

No terminal irão aparecer as opções de java que você a disposição, selecione o numero referente ao OpenJDK 8:

Após selecionar você pode verificar a versão com o comando:

java -version

Agora vá até o arquivo que você baixou do site da Receita Federal. Estou supondo que por Sped Fiscal, você está se referindo ao Escrituração Contábil Fiscal (ECF) e clique com o botão direito e vá em propriedades.

Em propriedades procure pela aba de permissões e de permissão de execução ao arquivo (É executável):

Após dar permissão basta dar 2 cliques sobre o arquivo baixado:

Caso não seja este o seu problema tente executar o arquivo pelo terminal utilizando ./NomeDoArquivo para ver se o log exibe alguma informação do erro que você está tendo.

7 Curtidas

Eu já vi muitas pessoas com dúvida sobre isso e esse tutorial vai ajudar bastante gente :wink:

2 Curtidas

Olha seigue o passo a passo ate a parte de Definindo que o OpenJDK 8 é o padrão para o sistema.

apos isso não deu a opção de fazer a alteração.

1 Curtida

Seu sistema está apenas com o OpenJDK 8, neste caso não serão exibidas opções, uma vez que o OpenJDK 8 será o padrão de qualquer forma.

Teoricamente é só você dar permissão de execução e clicar 2 vezes sobre o arquivos que foi baixado.

1 Curtida

sim ja tentei fazer isso mas não da certo também, por que fica carregando mas o programa não e executado.

Vamos tentar executar pelo terminal para ver se ele retorna algum erro, em algumas distribuições basta executar o comando: ./NomeDoArquivo.

Escolha o comando de acordo com a arquitetura da a sua distribuição:

./SpedEcf_linux_x64-5.0.9.jar

ou

./SpedEcf_linux_x86-5.0.9.jar

Agora estou no Fedora 30 e o comando ./NomeDoArquivo não funcionou legal, então executei da seguinte forma:

java -jar SpedEcf_linux_x64-5.0.9.jar

Como resultado não houveram erros no terminal e abriu normal.

No Fedora eu instalei o OpenJDK 8 com o comando:

sudo dnf install java-1.8.0
3 Curtidas

Esta com esse erro.

Dê os seguintes comandos
$ pwd

e depois
$ cd ~/Downloads

e tente novamente

1 Curtida

Seu terminal não está na pasta Downloads, tente abrir o terminal na pasta Downloads ou como exemplificou o @Keviny tente navegar até a pasta com os comandos que ele demonstrou, sendo:

  • pwd: Vai exibir o seu diretório atual
  • cd: Lhe permite navegar entre os diretórios.
  • ~: É um atalho que leva sempre para a sua pasta home.

Caso haja necessidade você pode utilizar cd .. para retornar (voltar) um diretório.

1 Curtida

Pessoal muito o brigado amo vocês SRsrsR…
Agradeço a ajuda de vocês muito o brigado mesmo.
E desculpa por ser tão chato :pensive: as vezes, e por que sou novo no mundo linux.
Mas agradeço de coração @natorsc e @Keviny

3 Curtidas

Que nada todos nós somos usuários Linux, e mesmo sabendo algumas coisas ainda todos nós ainda estamos aprendendo :slight_smile: , acho que conhecimento em Linux é algo infinito :thinking:

3 Curtidas

Olá pessoal!

Até pouco tempo atrás eu utilizei essas dias para a instalação do Validador EFD ICMS-IPI, o que sempre funcionou. Porém agora ao iniciar apresenta o Erro de Conectar ao banco de dados. Alguém mais está tendo esse problema?
Já vi em alguns lugares que pode ser a porta do validador, porém já fiz a alteração e não funcionou.
Atualmente utilizo o Mint 20 Cinnamon.

@Alexsander_Rocha conseguiu resolver o seu problema? Também estou no mint (porém 19) e com erro no ICMS IPI versão de 64 bits, já abre com erro e não atualiza tabelas.

Dei chmod 777 na pasta Fiscal2, mas mesmo assim não resolveu meu problema.

Na stacktrace do PVA fala: “Houve um erro ao ler a configuração do sistema”
Mas nada que me ajude.

@mattvasc ainda não, estou tendo que utilizar no windows. Já procurei em vários locais na internet mas nenhum resolveu.

Complicado né cara? Tentei entrar em contato com a receita hoje através de um formulário no site da fazenda, mas quando vai enviar, da erro 500.

Estou usando o Windows também atualmente, mas adoraria migrar para o Linux para redução de custo.

Vamos usar essa thread caso alguém descubra alguma novidade.

1 Curtida

@Alexsander_Rocha @weliton @rxtheodoro tentei vários procedimentos em utilizar as versões nativa do Linux, mas não deu certo, porém obtive êxito usando o Wine.

Vou detalhar o procedimento que realizei no meu pc com Mint 20:

  • Instalei o Wine e o WineTricks
  • Instalei o Java para Windows (tive que usar compatibilidade com WIndows XP e fornecer o parametro “/S” para instalar silenciosamente devido a um erro do java)
  • Instalei o EFD Contribuições 4.0.1, EFD ICMS IPI 2.6.8 e o Receita NET
  • Abri o WineTricks para instalar a fonte Arial no workspace, para os programas funcionarem corretamente.

Após feito os passos acima, tanto o icms quanto contribuições estão funcionando normalmente, porém notei um desempenho inferior para a validação.

1 Curtida