/home não monta no Ubuntu 20.04

Bom dia,

Usava o Ubuntu 19.10 e fiz a instalação limpa do Ubuntu 20.04. Mantive /home sem formatação, mas agora não consigo acessar.

Tirei o print do Gparted, Disco e Terminal comando sudo fdisk-l:

imagem

manda a saída dos comandos:

sudo mount | grep home

cat /etc/fstab

sudo blkid

Se for problema de permissões, manda a saída desses comandos:

ls -la /home

id

imagem

O /home está montado corretamente.

Me parece que na instalação antiga seu usuário era anderson e nessa nova instalação é anderson-acer

Seus arquivos antigos devem estar todos na pasta /home/anderson juntamente com todas as configurações do desktop. O UID do usuário é o mesmo, então vc pode navegar a vontade em ambos os diretórios.

Pra voltar com a instalação antiga, o jeito fácil é simplesmente renomear as pastas para montar corretamente.

Tente executar no terminal. Se não der certo vc vai precisar fechar o ambiente gráfico e fazer pelo terminal virtual (Ctrl+Shift+F2).

  1. Mover a pasta nova para um nome diferente.
    cd /home
    sudo mv anderson-acer anderson-acer.old
  2. Mover a pasta antiga para o local esperado pelo sistema:
    sudo mv anderson anderson-acer

Daí encerre imediatamente a sessão (caso esteja nela) e inicie de novo. Tudo deve voltar a ser como antes.

Caso alguma coisa tenha saído errado, não vai entrar na sua sessão do desktop. Daí vc precisa ver se renomeou corretamente a pasta, executando os comandos mv no terminal virtual. Na pior das hipóteses vc vai ter que voltar com a pasta .old pro nome original e voltar a carregar o ambiente gráfico nesse usuário novo. Diga aqui se deu certo!

Outro jeito, sem recuperar as informações dos aplicativos, é simplesmente mover seus arquivos da pasta /home/anderson para /home/anderson-acer pelo seu aplicativo de gerenciador de arquivos.

Fiz e deu certo. Agora quando abro o terminal aparece como se sempre abrisse com uma pasta selecionada imagem

O nome da home é anderson. Se eu reinstalar o Ubuntu e manter o nome anderson, vai resolver o problema anterior?

Deu certo como? Apareceram os arquivos que vc tinha antes da instalação?

Encerrou a sessão? Reiniciou o computador?

O que aparece quando vc dá ls -la /home

imagem

Reiniciei e parece que deu tudo certo

1 Curtida