HD externo de 4 TB mais lento

Bom dia, amigos. Comprei um HD externo de 4 TB da Seagate. Desde o início, tive a impressão que ele era mais lento que os outros que tenho (1 de 1 TB e outro de 2 TB, todos do mesmo fabricante - Seagate). Essa performance pior acontece tanto no Windows quanto no Linux (Mint e Zorin).

Cheguei a formatá-lo 2 vezes (uma delas no Windows, inclusive com exclusão da partição e criação da nova, com formatação). Formatei sempre para NTFS.

Hoje, eu resolvi fazer a Avaliação de Desempenho no “Discos” no meu Ubuntu para comparar com o HD de 2 TB. Os dois testes foram feitos na mesma porta USB 3.0 e os resultados foram os seguintes:

HD 4 TB:

  • tamanho da amostra: 10,0 MiB
  • taxa média de leitura: 31,9 MB/s (100 amostras)
  • taxa média de gravação: 19,8 MB/s (100 amostras)
  • tempo médio de acesso: 19,8 milissegundos (1.000 amostras)

HD de 2 TB:

  • tamanho da amostra: 10,0 MiB
  • taxa média de leitura: 98,5 MB/s (100 amostras)
  • taxa média de gravação: 53,5 MB/s (100 amostras)
  • tempo médio de acesso: 18.05 milissegundos (1.000 amostras)

Ou seja, confirmou minha impressão: o HD de 4 TB é cerca de 3 vezes mais lento que o de 2 TB nas taxas de leitura e gravação.

Há alguma explicação para isso? Há algo que eu possa fazer para corrigir isto ou HDs de 4 TB são mesmo mais lentos?

Antecipadamente, agradeço as respostas.

Sim, cada HD tem o seu RPM (Medida em rotações por minuto), os mais conhecidos se limitam entre 5400RPM e 7200RPM, com isso esse seu pode ser de 5400. Normalmente essa informação está na etiqueta do HD, seria interessante dar uma conferida:

Tenho um HD de 1tb que infelizmente é bem mais lento do que esse da foto acima, mas é porque não me atentei para esse detalhe na época.

Segue matéria abordando esse assunto: Quanto maior a ‘RPM’ mais rápido será o seu HD

2 Curtidas

Olá, thespation, obrigado pela resposta. Mas os 2 HDs a que me refiro são externos. Procurei nas etiquetas e nas caixas dos 2 e nenhum deles tem esta informação. Acredito que ambos sejam 5400, que é a velocidade mais comum.

1 Curtida

Uma boa forma de tirar a prova real seria ver o modelo dele e buscar no site do fabricante, certamente há essa informação. Caso seja realmente 5400, infelizmente é a limitação do dispositivo.

1 Curtida

Olá!

Complementando a reposta do @thespation, é preciso ficar atento com as especificações dos equipamentos porque existem uma variedade quase infinita de soluções, só para citar alguns pontos que podem impactar na performance:

  • Portas compatíveis com USB 3.0 (mas que não são realmente 3.0);
  • Velocidade dos discos: existem muitos discos de 5400 RPM que usam uma tecnologia chamada “green” que são focados em economia de energia o que acaba tornando-os muito mais lentos.
  • Controladoras de storage: muitos storages externos mais simples não dispõe de cache na controladora ou nem mesmo possuem uma controladora em si, contando apenas com chips simples para disponibilizar a conectividade.

Ferramentas como o Gnome Discos ou o Gparted devem conseguir exibir os modelos dos discos mesmo que eles estejam conectados via USB, no Gparted por exemplo, clique em “Ver > Informações do dispositivo” que serão exibidos diversos detalhes do drive.

:vulcan_salute:

2 Curtidas

Além do já - e muito bem - mencionado pelos colegas é comum um HD mecânico aparentar certa lentidão quanto maior seu tamanho. Exatamente por isso o recomendado é que a SWAP fique no início do disco, para reduzir o tempo de acesso. Também por isso é comum HD’s que não são muito utilizados acabarem apresentando problemas mecânicos.

Recomendo: YouTube

O vídeo é sobre partições mas para tanto é detalhada essas questões quanto aos HD’s.

1 Curtida

Agradeço todas as respostas dos colegas.

No entanto, como eu disse no título do post e em minha 1ª mensagem, é um HD externo (Seagate BUP Portable). Também sempre o usei nas portas USB 3.0.

Já fiz várias tentativas (inclusive dividir o HD em 2 partições de 2 TB cada e também formatá-lo para EXT4) mas a lentidão continua. Acho, então, que é problema do HD mesmo.

Obrigado e um abraço a todos.

Não é um “problema” e sim uma limitação de hardware. Acredito que você não entendeu o que tentamos te dizer, pode dar uma olhada na matéria que linquei, vai esclarecer.

1 Curtida

Olá, thespation, acho que me expressei mal.

Eu frisei que o HD era externo porque o usuário Windows_User fez algumas recomendações que incluíam a área de SWAP e este não é o caso para um HD externo.

Quanto às outras questões (inclusive de velocidade do HD e particionamento), embora eu não seja um técnico mas apenas um usuário “especializado” :wink: , entendi as explicações de vocês (sei que há HDs de 7.200 e de 5.400 (tantos os HDs externos como os HDs mecânicos dos meus notes são todos de 5.400) e também já havia visto o vídeo sobre partições há algum tempo pois sigo o canal do Diolinux).

E, quando eu disse que o problema provavelmente é do HD mesmo é porque ele não é um pouco mais lento por causa do tamanho maior mas muito mais lento.

Exemplo: tirei um backup de umas pastas que totalizam 27.9 GB em outro HD externo de 2 TB, mesmo fabricante, mesmo modelo (só que de 2 ao invés de 4 TB), com mesmo cabo, na mesma porta e no mesmo notebook (e os 2 HDs externos formatados em NTFS).

No HD de 2 TB, a cópia demorou 24min30seg. No HD de 4 TB, a cópia começou bem (na faixa entre 30 e 40 MB/seg que foi mais ou menos a performance no de 2 TB durante toda a cópia). No entanto, depois de um tempo, a performance foi caindo, caindo e chegou à faixa de KB/seg. Resultado: com 90 minutos, ainda não havia copiado sequer 50% dos 27.9 GB e acabei desistindo.

E detalhe: o HD de 2 TB está 65% ocupado e o de 4 TB estava zerado, sem nenhum outro arquivo nele.

Foi por isso que cheguei à conclusão que há algum problema com este HD de 4 TB. Tentei até particioná-lo, com 2 partições de +ou- 2 TB cada para ver se gravando em uma área ou em outra afetaria a performance mas o mesmo problema se repete nas 2 partições: começa bem, depois a performance vai caindo até quase parar, levando uma eternidade para copiar alguns GBytes.

Um abraço e obrigado pela atenção.

1 Curtida

Acho que não compreendeu. Dei um exemplo sobre o desempenho de um HD. Um HD de 4gb é naturalmente mais lento do que um igual de 2gb. A questão do SWAP no início foi pra lembrar que o tamanho do disco importa no desempenho - por isso há a recomendação - colocar no início pro tamanho do HD não influenciar no tempo de acesso.

O vídeo sugerido sanaria suas dúvidas.

Em todo o caso pode haver um defeito sim. O vídeo também indica como testar efetivamente o desempenho e eficiência de um disco - o que resolve sua dúvida.

Windows_User, assisti o vídeo e, de fato, é excelente (e foi um bom aprendizado para minhas próximas instalações de Linux). Não cheguei a testar o HD com o HD Tunes como ele sugere mas testei com o Gnome Discos. Como havia feito antes, fiz o teste com 100 amostras de 10 MB e parecia estar razoável, com índices similares aos outros HD externos que tenho. Aí, tentei com amostras maiores (200 amostras, com 20 MB) e, como acontece quando estou fazendo uma cópia para este HD, começou bem mas, a certa altura, a performance foi lá para baixo. Tanto é que fui jantar, deixei o teste rodando e, quando voltei mais de meia hora depois, ainda estava na amostra 153 e o gráfico ia lá para cima e voltava a cair quase a zero.
Ou seja, confirmou o que eu já imaginava: há um problema com o HD (apesar de novo, com 6 meses de pouco uso).
Obrigado e um abraço.

Olhe no site ou rode uma aplicação de velocidade para estabelecer um parâmetro.