Gnome Keyring não iniciando com o sistema

Utilizo o gnome-keyring para logar automaticamente no minecraft launcher. Percebo que o launcher não tem iniciado corretamente, pois o deamon do gnome-keyring não está iniciando com o sistema.

Se instalo o gnome-keyring, ele funciona. Mas, ao dar reboot, ele não inicia. Utilizando o comando gnome-keyring-daemon --replace --foreground --components=secrets,ssh,pcks11 ele funciona, mas é exaustivo dar esse comando toda vez que der reboot.

Utilizo arch linux com dwm e inicio a sessão pelo startx (.xinitrc)

Tente o seguinte…

Criar um arquivo .desktop para o gnome-keyring-daemon:

Crie um arquivo .desktop que irá iniciar o gnome-keyring-daemon quando você iniciar a sessão. Você pode fazer isso criando um arquivo gnome-keyring-daemon.desktop em ~/.config/autostart. Use um editor de texto, como o nano, para criar o arquivo:

vim ~/.config/autostart/gnome-keyring-daemon.desktop

Dentro deste arquivo, coloque o seguinte conteúdo:

[Desktop Entry]
Type=Application
Exec=gnome-keyring-daemon --start --components=secrets,ssh,pkcs11
Hidden=false
NoDisplay=false
X-GNOME-Autostart-enabled=true
Name[en_US]=GNOME Keyring Daemon
Name=GNOME Keyring Daemon
Comment[en_US]=Starts the GNOME Keyring Daemon
Comment=Starts the GNOME Keyring Daemon

Feito isso, salve o arquivo e saia do editor. Conceda permissão de execução:

chmod +x ~/.config/autostart/gnome-keyring-daemon.desktop

Verifique a configuração em .xinitrc:

Verifique se a inicialização do startx no seu arquivo .xinitrc não está substituindo as configurações do GNOME Keyring. Certifique-se de que o arquivo .xinitrc não esteja iniciando um gerenciador de sessão que substitua as configurações do GNOME Keyring.

Reinicie o sistema e verifique:
Após seguir essas etapas, reinicie o sistema ou inicie uma nova sessão com startx. O gnome-keyring-daemon deve ser iniciado automaticamente agora.

Espero que isso ajude.

2 curtidas

Fiz isso e não funcionou, aqui está meu .xinitrc:

#!/bin/sh

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/etc/X11/xinit/.Xresources
sysmodmap=/etc/X11/xinit/.Xmodmap

# merge in defaults and keymaps

if [ -f $sysresources ]; then







    xrdb -merge $sysresources

fi

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap
fi

if [ -f "$userresources" ]; then







    xrdb -merge "$userresources"

fi

if [ -f "$usermodmap" ]; then
    xmodmap "$usermodmap"
fi

# start some nice programs

if [ -d /etc/X11/xinit/xinitrc.d ] ; then
 for f in /etc/X11/xinit/xinitrc.d/?*.sh ; do
  [ -x "$f" ] && . "$f"
 done
 unset f
fi

nvidia-settings --load-config-only &
pipewire &
wal -R &
xsetroot -cursor_name left_ptr &
#exec dbus-run-session bspwm
exec dbus-launch --exit-with-session dwm

Porque você não coloca o gnome-keyring para iniciar no .xinitrc como os outros aplicativos?

Todos estes acima estão sendo iniciados. A dica que o @leoberbert passou geralmente é usado em DE, no seu caso você esta usando WM, que geralmente tem uma solução própria para configurar o inicio de aplicativos junto com o sistema.

Aqui no qtile eu uso assim:
gnome-keyring-daemon --start &
Através de um hook de autostart, este é o modo do Qtile, no dwm não sei como que é.

2 curtidas

Já tentei, nada aconteceu.

Isso aí. Como está usando o dwm:

Acredito que a forma plausível seja dentro do .xinitrc mesmo, por exemplo:

# ... outras configurações ...

# Iniciar o gnome-keyring-daemon
eval $(gnome-keyring-daemon --replace --foreground --components=secrets,ssh,pcks11)

# Iniciar o dwm
exec dwm

Vi a dica desse site: shell script - Unlock Gnome Keyring Daemon from command line - Unix & Linux Stack Exchange.


Acredito que o @Tuxraldo vai poder somar com dicas também.

Rodando via terminal recebi isso:

Colando o código, ao invés de foto, fica melhor para ler e comentar.

@thespation @b_Andrade quando comecei a usar o dwm e, depois de fazer uns testes, achei bem, bem mais fácil, iniciar os serviços que uso (sxhkd, feh, polkit etc.) tudo através desse patch. Por um motivo muito simples, fica mais organizado. O patch lê o arquivo autostart.sh dentro do diretório .dwm na sua home. Obviamente, após adicionar o patch, você tem que criar o diretório e o script autostart.sh.

Meu dwm é iniciado através do gerenciador de login (lxdm ou tbsm). Como tenho 5 ambientes instalados, é bem mais fácil de gerenciador todos. E, como disse, eu acho mais fácil ter um script próprio para os serviços que quero iniciar, do que colocar tudo no .xinitrc.

Um pedaço do meu autostart.sh para exemplificar:

#!/usr/bin/env bash

# System Monitor
psensor &

# Wallpaper
feh --bg-fill $HOME/Imagens/everforest/ghost.jpg &

# Statusbar
$HOME/.dwm/status-bar.sh &

# Notification Daemon
/usr/lib/x86_64-linux-gnu/xfce4/notifyd/xfce4-notifyd &

# Gnome polkit
/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1 &

# Compositor
picom --config ~/.dwm/picom-dwm.conf &

# Hotkey daemon
sxhkd -c ~/.dwm/sxhkdrc &

# Power Manager
xfce4-power-manager &
2 curtidas

Pela imagem, parece que a maioria dos erros acontece porque você já tinha inicializado o gnome-keyring, então quando você tenta inicializar ele vai aparecer estes erros em que já esta registrado.

DICA: para copiar o texto do terminal, basta selecionar o que quer e ao invés de utilizar o CTRL+C como de costume, utilize o CTRL+SHIFT+C, o mesmo vale para colar no terminal, CTRL+SHIFT+V.

1 curtida

Já uso esse patch e já tentei por o gnome-keyring pra iniciar através dele. Sem diferença, se não inicia pelo .xinitrc, não vai iniciar através dele também.

1 curtida

Nunca usei o gnome-keyring. Se as soluções aqui não resolveram, e eu não faço ideia do que pode estar acontecendo aí, eu recorreria ao r/suckless. Lá o pessoal ajuda de boa qualquer pergunta que a galera faz. É um canal oficial do projeto suckless.