Gimp sobre apoio ao flatpak

gimp
#1

Dev do gimp explica das limitações do gimp via flatpak(aparentemente são as mesmas com snap/appimage) e pq apoiam este formato, interessante o ponto que citaram “o Linux era um cidadão de segunda classe usando a versão antiga do gimp nos sistemas LTS…” ou algo assim…e sobre como é mais fácil usar a infraestrutura do flathub para distribuir o gimp desde a v2.10…

Aparentemente eles tem uma visão construtiva da tecnologia(não é pq não funciona algo agora que vamos descartar) e também prática por facilitar a distribuição do gimp upstream para todos usuários Linux

5 Likes

#2

Uma visão bem coesa em minha opinião. É evidente que o Gimp em Flatpak tem alguns aspectos a melhorarem, como o suporte a plugins por exemplo. Entretanto, a facilidade de utilizar a aplicação nos últimos lançamentos em distros como o Ubuntu, sem o risco de conflitos com bibliotecas, ou ficar “preso a versão do repositório” é uma vantagem monstruosa. Utilizo o 2.10, e depois que migrei do 2.8 para ele, só me apaixonei mais ainda por esse software.

(Como já até disse em live contigo no FastOS, se fosse para escolher um programa como o favorito, o GIMP seria o primeiro de minha lista… rsrsrs).

3 Likes

#3

Tem um motivo pra isso, o flatpak roda seus aplicativos em sandboxing por design e o ostree é somente leitura, em outras palavras o gimp via flatpak nunca vai rodar plugins do sistema a não ser que eles sejam instalados na sua home via AppImage e Snap isso pode ser contornado mas no Flatpak não

1 Like

#4

Em fim, você pode instalar os seus plugins em /.gimp-<versão do gimp>/plugins, a versão appimage segue o FreeDesktop e a pasta de configurações é visível e se encontra na pasta .config

0 Likes

#5

Então, existe um “erro” nessa sua afirmação. Pois plugins funcionam no Gimp Flatpak, ao contrário do que você escreveu. O que ocorre que nem todos funcionam. A maioria não. No entanto existe a possibilidade, tanto que os desenvolvedores do Gimp estão correndo atrás desta compatibilidade. O link disponibilizado com a opinião do dev do Gimp é um bom exemplo.

No momento existe esse problema, mas funcionar funciona…

0 Likes

#6

Na verdade eu disse plugins do sistema, os instalados globalmente em /usr/share esses nunca vão funcionar no entanto como eu disse:

A versão local “por usuário” funciona perfeitamente

0 Likes