Gforce Now no navegador com delay absurdo do mouse e teclado

Olá pessoal recentemente eu vendi minha GPU e precisei usar o serviço de streaming de jogos da NVIDIA o Gforce Now, entretanto eu tive uma experiência bem ruim com um delay de mais de 5s, melhorou um pouco depois de eu ter mudado o DNS, mas não fez milagre. Minha irmã ela tem um laptop com Windows e ela passou o final do mês passado aqui e jogou algumas vezes usando o Gforce Now pelo app e ela me disse que não tinha delay no mouse ou teclado estava normal e usando minha conexão a internet.
Fnf. adicionais: aceleração de hardware do navegador está ativada.
Caso for necessário:

image

1 curtida

Teria como você colocar um print da tela do navegador no link chrome://gpu

a dois dias atrás eu usava uma GPU RX550 2gb agora estou com a intel graphics do chipset i945
Aqui:



Com o software para Windows sei que rodará perfeito. Eu cheguei a testar a versão do Gforce Now do Flatpak, deu a mesma coisa.

Você está sem aceleração de hardware praticamente, vamos tentar ativar e ver se ajuda. Em chrome://flags você vai ter de ativar os seguintes items:

se ainda assim não ajudar, você pode tentar executar via terminal com essas flags.

google-chrome --use-cmd-decoder=passthrough --use-gl=desktop

depois podemos ver como editar o executável do Chrome se isso ajudar.

2 curtidas

Eu já tive essa GPU integrada no chipset da MOBO, é muito ruim ela.

Concordo, mas a do note da minha irmã é a mesma só que de laptop e ela consegue jogar sem problemas no Gforce Now com o app oficial, o que é intrigante, pode ser drivers mesmo, talvez o driver free mesa não oferece mais suporte a essa GPU integrada antiga.

Senti uma melhora talvez de 4s para 3s de resposta, eu vou instalar o Windows em um HD que tenho só para ver se não fica a mesma coisa.
No terminal me parece que o chrome insiste em tentar carregar uma biblioteca do Vulkan:

google-chrome --use-cmd-decoder=passthrough --use-gl=desktop
[110279:110279:1006/232422.476677:ERROR:gpu_init.cc(453)] Passthrough is not supported, GL is swiftshader, ANGLE is 
[110237:110264:1006/232425.130546:ERROR:chrome_browser_main_extra_parts_metrics.cc(228)] crbug.com/1216328: Checking Bluetooth availability started. Please report if there is no report that this ends.
[110237:110264:1006/232425.130579:ERROR:chrome_browser_main_extra_parts_metrics.cc(231)] crbug.com/1216328: Checking Bluetooth availability ended.
[110237:110264:1006/232425.130592:ERROR:chrome_browser_main_extra_parts_metrics.cc(234)] crbug.com/1216328: Checking default browser status started. Please report if there is no report that this ends.
[110237:110264:1006/232425.175993:ERROR:chrome_browser_main_extra_parts_metrics.cc(238)] crbug.com/1216328: Checking default browser status ended.
Warning: Couldn't open libvulkan.so.1
Info: Couldn't load Vulkan
[110338:18:1006/232509.302851:ERROR:webrtc_video_engine.cc(3470)] Absent receive stream; ignoring clearing encoded frame sink for ssrc 0
[110338:17:1006/232549.245744:ERROR:stun_port.cc(96)] Binding request timed out from 172.17.0.x:34560 (docker0)
[110338:17:1006/232549.246458:ERROR:stun_port.cc(96)] Binding request timed out from 192.168.0.x:41803 (ens33)
[110338:17:1006/232549.246588:ERROR:stun_port.cc(96)] Binding request timed out from 25.9.124.x:35496 (ham0)
[110338:17:1006/232549.246723:ERROR:stun_port.cc(96)] Binding request timed out from 10.124.154.x:40338 (tun0)

você está com o vulkan ativado no chrome://flags? Da uma procurada, eu recomendo desativar, como você pode ver ainda não está ok, em algumas GPUs ajuda, em outras nem executa ou até piora a performance.

Uma outra possibilidade é que o componente chave seja aceleração de vídeo (video decode na página chrome://gpu), não de hardware. Nesse caso o problema se complica mais, principalmente no Chrome.

Outra coisa, só verifique também se os ajustes que fizemos mudaram algo em chrome://gpu, o conteúdo do terminal durante a execução do jogo pode também nos dar algum feedback se o navegador está engasgando em algo.

1 curtida

Não quero me alongar muito lendo os outros comentário então vou dizer de forma direta:
Vc não tem decodificação de vídeo (não confundir com aceleração de composição) no Chrome no Linux, por isso deve estar executando o serviço (Gforce Now) de forma ruim e com delay. É isso!

1 curtida

Pensei nisso ao ver o a saída no terminal, ERROR:webrtc_video_engine.cc(3470)] Absent receive stream; ignoring clearing encoded frame sink for ssrc 0 Consegui reduzir o delay para uns 0,60s o que já ajuda muito, eu setei a resolução do jogo para 800x600

É um tiro no escuro, mas talvez isso funcione:

google-chrome --use-gl=desktop --enable-features=VaapiVideoDecoder

Aceleração de vídeo no chrome é algo meio delicado… Mas como o seu Chrome é 91+ podemos tentar algumas coisas mais. Você pode também nos dar a saída deste comando?

vainfo

Desativei ai o error até sumiu do terminal, sim alguns já estavam ativados por padrão, mas é isso mesmo que o colega ai de cima falou @u_lts sem decodificação via hardware, ai da ruim mesmo.

Vou tenta o que disse acima.

Testei aqui mesma coisa testei com a resolução padrão 1980x1080 e 800x600 só baixando a resolução mesmo que o inputlag fica menos que 1s, Parece que essa decodificação é muito importante, meu hardware é bem antigo, mas ainda sim agora fiquei com mais vontade de testar no Windows e ver o que rola, hoje de tarde eu posto o que eu concluí.

Sobre o comando vainfo meu terminal não sabe o que fazer diz comando não encontrado creio que faça parte de algum pacote que eu não tenho instalado.

Muito obrigado a todos eu não fazia ideia que ia aparecer alguém para tentar me ajudar.

No caso você precisa instalar o vainfo, estou achando que você não está com o libva (VAAPI) instalado. Esse comando vai instalar o vainfo:

sudo apt-get install vainfo

Pode ser que apesar do hardware antigo ainda consigamos colocar o VAAPI para funcionar junto ao Chrome, mas realmente o hardware é antigo.

Saída do comando vainfo

vainfo                                      
libva info: VA-API version 1.13.0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i915_drv_video.so
libva info: va_openDriver() returns -1
vaInitialize failed with error code -1 (unknown libva error),exit

É, Infelizmente sua GPU integrada não vai suportar VAAPI, se não me engano o driver i915_drv_video é o único responsável pelas Intel graphics antigas (anteriores a geração 7 ou 6 acho). Você pode tentar resolver com RX550, mas para essa sua integrada, no Linux, não tem solução acredito.

1 curtida

Pelo visto a sua GPU não tem suporte ao VAAPI.
https://ubuntuforums.org/showthread.php?t=2226917

1 curtida

Valeu por tentar ajudar, eu descobriq ue só o i965 segundo este tópico no forum do Manjaro: VA-API driver broken - #4 by koshikas - Graphics & Display - Manjaro Linux Forum

Pessoal vcs podem tentar usar o Chromium com Vaapi habilitado. É uma ideia e pode ser q funcione bem.

@u_lts essa minha VGA onboard ela não suporta o vaapi, infelizmente, eu ainda vou testar no Windows no app nativo para ver como fica, certamente fica do mesmo jeito mas não custa tentar.