Fedora 30: Como alterar idioma e resolução/fullscreen no VirtualBox?

Por favor, sou iniciante linux instalei fedora 30 no virtualbox, mas esta ingles tem alguma forma de passar para portugues, e como deixar ele tela cheia virtualbox, obrigado

Sim! Instale o utitário de idioma com o comando: sudo dnf install system-config-language -y
Depois execute o comando: sudo system-config-language e selecione na tela que aparecer o idioma Português Brasil. Aguarde a janela aplicar e fechar. Reinicie o sistema para concluir.

Está usando o Fedora com Gnome? Se for, não posso ajudar porque não entendo nada do Gnome. No menu deve existir alguma entrada como “language support”, se tiver, é só clicar e procurar por português brasileiro (pt-br). Enquanto escrevia o @kalebesouza já deu a dica do idioma. :slight_smile:

Para mudar para fullscreen é só usar as teclas host (que é o ctrl do lado esquerdo) + f, se ainda assim não preencher a tela toda, vá no menu e procure por monitor ou vídeo e altere a resolução por lá.

Se for GNOME não precisa complicar, settings-> language and region, ou vice versa, adicione o idioma e reinicie a sessão.
Resolução também na central de controle, quanto a virtualbox fico devendo, pois utilizo o gnome-boxes para virtualização.

1 Curtida

Isso da tela cheia no virtualbox eu tive o mesmo problema que você. Geralmente basta instalar os adicionais de convidado (guest additions) que resolve, mas com o Fedora eu não consegui nem a pau kkk, não consegui nem mudar a resolução, pesquisando na internet vi que tem umas coisas a mais que você precisa fazer.
Acabou que eu nem tentei não, preferi testar pelo vmware e funcionou tudo de boa.

Caso queira tentar, dá uma olhada nisso aqui: VirtualBox Guest Additions on Fedora 30/29, CentOS/RHEL 7.6/6.10/5.11 – If Not True Then False

Opa. Não compliquei. É q por alguma razão no Fedora não tem essa opção de language nas configurações sendo necessário executar os passos q listei. Mesmo que vc instale selecionando o idioma português, a tradução não fica completa, o que pode ser corrigido executando os passos que informei.

Tela cheia no VirtualBox é fácil é só instalar os seguinte pacotes:

virtualbox-guest-utils

1 Curtida

Viji, só isso e dá certo? Eu tava tentando instalar pela ISO do virtualbox e não ia, bom saber que tem um pacote.

1 Curtida

Sim mas vou ver aqui direitinho o nome do pacote no Fedora :wink:

No Fedora só precisei rodar esse comando para instalar o adicional de convidado no VirtualBox

sudo dnf install virtualbox-guest-addition-ogl virtualbox-guest-addition

E depois reiniciar e deu tudo certo :slight_smile:

? Como mencionei GNOME, ou talvez estejamos utilizando Fedoras diferentes, em qualquer GNOME funciona da mesma forma, depois você pode adicionar o suporte a pt_BR na GNOME Software que está em complementos, no Fedora e em qualquer distro que traga um GNOME “padrão” vai funcionar tranquilamente.
Settings
Screenshot%20from%202019-05-26%2000-25-28
Region and Language


Clique sobre o idioma vai aparecer o menu suspenso para selecionar clicando no menu hamburquer “tres faixas” ou pontos dependendo do tema que esteja utilizando, Digite “Bra” ou qualquer coisa que lembre “Brasil” ou “Portuguese” e reinice a “Sessão”, nada de reiniciar o computador, não precisamos disto para alterações simples.

Screenshot%20from%202019-05-26%2000-27-53



O resultado seria este

1 Curtida

Outro detalhe que esqueci de mencionar, mesmo que o amigo tenha esquecido de instalar o idioma, no GNOME do Fedora, que é o padrão, será lançado o GNOME inicial setup, que é a tela de configuração e boas vindas do próprio GNOME que em tese deveria ser uma introdução a interface e que eu me lembre somente o Fedora e o ALT Linux oferecem esta experiência que o projeto gostaria que os usuários tivessem, aí pode escolher idioma, criar usuário, configurar contas online, início automático de sessão etc, que são as mesmas configurações da central de controle, apesar deste vídeo ser antigo o primeiro encontro com o gnome-shell seria mais ou menos assim.

1 Curtida