Falha ao ativar conexão de Rede

Beleza, boa noite ai :wave:

1 curtida

Boa noite para nós :wave:t2:
Eu aparecendo aqui no Diolinux amanhã, já te mando uma mensagem. :vulcan_salute:t2:

2 curtidas

:wave:t2: Estamos ae, quando estiver preparado para tentarmos solucionar o problema, é só mandar mensagem. :vulcan_salute:t2:

1 curtida

estou aqui, hoje dei dual boot no pop os e o wifi estava funcionando depois que eu apertei fn + 12 porém quando eu iniciei a steam e joguei por alguns minutos aquela notificação apareceu e o wifi desconectou de novo.
tem como instalar o ath10k no pop os será?

1 curtida

Então eu começo a suspeitar que pode não ser driver e sim entre o computador e o moden.
Para tirarmos esta dúvida, no Windows o WiFi funciona normalmente?

Podemos tentar instalar o driver ath10k para ver ser resolveria.

1 curtida

sim, no Windows o Wifi funciona de boa, não cai nem nada, o pop os tem o ath9k e o meu windows tem o ath10k que é bem estável e esse ath9k eu tinha no windows e caía muito o wifi.

1 curtida

Excelente news. Irei fazer umas pesquisas aqui para instalarmos o ath10k no Pop OS.

1 curtida

talvez isso não ajude muito mas, tenho esse link sobre meu hardware.
HW probe of Samsung 370E4K #a296e36d75 (linux-hardware.org)

1 curtida

Pelas pesquisas que fiz, precisariamos atualizar o Linux Firmware e então o ath10k será instalado.
Mas antes disto precisaremos saber qual Firmware atual o Pop OS estaria usando.
Tenta usar o comando abaixo para ver se conseguiremos obter estas informações:

apt list | grep linux-firmware

1 curtida

Resultado:
linux-firmware-xilinx-vcu/hirsute,hirsute 2020.2-0ubuntu1 all
linux-firmware/hirsute,hirsute,now 1.201+system76~1634227151~21.04~7ce58ad all [instalado]

1 curtida

Estas informações ajudam sim porque precisamos de dados para tentar resolver o problema. Mas tem de ter um certo cuidado com informações antigas, antigas ao hardware ou “novas demais”, ou até mesmo informações falsas ou errôneas. Mas é sempre bom coletarmos bastante dados para facilitar na resolução dos problemas.

Bom o POP OS tem uma ferramenta, out of the box, que atualiza o firmware com cliques. Para isso iremos em
Configurações > na parte lateral esquerda Firmware > e clicamos no botão verde acredito que deva estar Atualizar (no Inglês está update).

Mas lembrando que é bom realizar este procedimento com o laptop ligado na energia elétrica e não desligar ele e evitar mexer nele até o procedimento completar.

1 curtida

Aí mano depois que eu coloquei esse código e reiniciei pra voltar pro Windows o Wi-Fi não funciona no windows mais apenas no pop os…Que coisa não?xD

1 curtida

:grimacing: Então eu suspeito que pode entre os roteadores e o laptop. Aquele comando apenas lista informações, ele não altera nada. Ae já é algo mais complexo porque tem vários detalhes:

  • Pode ser confilto de ips.
  • Pode ser conflito de pacotes pois canais podem estar próximos uns dos outros.
  • Pode ser problema/falta de QOS e alguém ou algum dispositivo está consumindo muita banda ae.
  • Pode ser o ISP.
  • Pode ser vários outros detalhes.

Os roteadores vem configurados de fábrica para funcionar 100% automático, comprar, instalar e usar. Isso quando somente 1 roteador irá exercer esta função. Quando instalamos um segundo roteador, ou mais, daí a coisa começa a complicar para este modo automático, por causa dos “pode ser” que citei e tem vários outros detalhes. Porque os roteadores não sabem que iremos colocar mais roteadores em “modo automático”. Outro detalhe que fica mais complexo ainda é não usar uma rede estruturada, ou seja, usar roteadores de diferentes marcas.

Então nestes casos de mútiplos roteadores é necessário fazer as configurações corretas entre eles para não termos dor de cabeça. Tem de posiciona-los estratégicamente bem entre os ambientes.

Neste caso teriamos de fazer uma série de diagnosticos, acessando os aparelhos roteadores, no qual iremos precisar usar as senhas para acessa-los.

Ao primeiro momento eu posso sugerir que, desligue todos os aparelhos, para desergeniza-los, pois eles acumulam dados e uma hora estes dados se conflitam. Outros detalhes são que conforme eles ficam ligados, eles geram campos eletromagnéticos entre si, causando interferência. Tem vários detalhes.

Diagnosticando primeiros passos: Desliga todos os roteadores e equipamentos que usam internet, televisores, celulares, computadores por alguns minutos. Liga o roteador do ISP e espera ele ficar 100% operante. Não liga os outros até que ele fique 100%. Depois testa a internet do roteador do ISP, com algum aparelho que esteja conectado direto a ele. Funcionando legal, iremos ligar um roteador WiFi e conectaremos o laptop nele. Não liga os outros roteadores. Outro detalhe testa apenas com o laptop ligado no WIFi, mantenha desligado os outros equipamentos que usem o WiFi, como celulares, televisores e outros computadores, etc.

Assim estariamos começando a diagnosticar de onde pode ser o problema no WiFi entre o laptop e os roteadores.

É meio complexo isso :joy: mas, em palavras mais simples, os “roteadores são como Semáforos de Transito e os dados que vem e vão pela internet são os carros”, oque pode estar acontecendo ae é que os Semáforos estão abrindo ao mesmo tempo e causando acidentes entre os carros (dados).

Essa parte de rede é complexa, por isso quando ligamos nas operadoras, os atendentes pedem para nós desligarmos os roteadores por algum tempo e depois ligar. Senão der certo eles imediatamente agendam a visita técnica, porque é complexo explicar isso por telefone e fica mais caro para a empresa, melhor enviar os técnicos no local.

Bom isso é oque eu posso fazer :sweat_smile:, se o pessoal tiver mais idéias para tentarmos resolver, mas eu acredito que não seja no laptop o problema, já que pegou o Windows também e você tem múltiplos roteadores operando no “modo automatico”.

2 curtidas

Digitei tanto que esqueci de um detalhe :joy:

Conforme você for executando so passos a passos, podemos ir fazendo isso juntos.

Oque você acha?

1 curtida

deixa pra lá, voltou.
foi mal por perder seu tempo :sweat_smile:

1 curtida

:grinning_face_with_smiling_eyes: Que isso, não perdemos tempo.

Aprendemos com este tópico então não foi uma perda de tempo e sim ganho de conhecimento :pray:t2:

Eu sempre gosto de resolver nossos problemas, pois eu penso que o problema das pessoas, indiretamente também é um problema meu. Claro que por eu ser somente uma pessoa não consigo abraçar e ajudar o mundo mas, tento fazer meu melhor para que todos ao meu redor sejam os melhores também.

“Uma pessoa feliz e satisfeita não irá causar danos as outras pessoas, pode ser até que esta pessoa ajude mais ainda as outras.” :grinning_face_with_smiling_eyes:
Já imaginou por que que tem o bandido? As vezes eu penso, que a questão não é prender o bandido, já estamos decadas de cansados de ver que isso não resolve… Eu penso que tem de ver porque que aquela pessoa virou um bandido, tem de curar pela raiz, eu penso.

Sobre a sua rede de internet, tenta ver se você consegue perceber padrões quando caí. Ao cair, olha se alguma pessoa chegou na sua casa e acessou a rede, dá uma olhada na rua se tem carros com aparência de motorista de aplicativos. Eu conheci pessoas que usavam “roubar” WiFis dos outros usando aplicativos específicos para isso, afim de evitar usar o 4g(créditos) do celular.

Irei resumir uma experiência profissional minha aqui. No meu antigo serviço, existia um problema que não conseguiamos detectar, Kernel Panic no antigo servidor da loja. Executamos vários procedimentos e nada. Então eu comecei a tentar enxergar padrões na hora que o Kernel Panic acontecia, anotando coisas repetitivas, tentando aliás. Eu ia nas janelas do andar superior e ficava olhando toda a loja, se algum caixa travava, coisas do tipo. Eu ia nos setores administrativos, nos de piso de loja, depósitos, para ver qual software, sites e etc eles estavam usando. Eu analisava roteadores, terminais e balanças. Enfim eu ia anotando. Um belo dia eu percebi um padrão, o diretor da empresa entrava na loja e Kernel Panic… Anotei aquele comportamento. Tempos depois, quando dava Kernel Panic eu corria na janela e adivinha, aquele diretor estava lá nos corredores da loja. Outro dia avisaram " O diretor está para vir na loja." Eu já me adiantei e fiquei experto, quando eu vi o diretor entrando na loja, corri nos servidores e… Bingo Kernel Panic.
Com todo cuidado e respeito eu me aproximei do diretor perguntando se eu podia fazer uma analise técnica no smartphone e Ipad dele e voilà. Por algum motivo o tipo de senha e/ou o canal configurado (automático para variar) naquele Ipad causava Kernel Panic nos servidores. Foi só alterar a senha e reconfigurar o canal do Ipad e pronto. Nunca mais deu problemas. Anos depois aquele servidor foi substituido pelo pfSense.

E mais outra experiência, bem resumida. O hipermercado novo travou todos os caixas na inauguração, lotado de clientes, os diretores desesperados, nós do TI sem saber oque fazer e me veio na mente o fato do Kernel Panic. Daí eu contei este fato e os diretores mandaram “Desliga todas as antenas WiFis”. Seata-Ceatía :mage:t2: os PDVs voltaram a funcionar. Foi o dia mais feliz da minha vida no meu ex serviço.

Uma detalhe que eu aprendi com o professor de Ciência da Computação de Harvard, David J. Malan: “Tem vezes que estamos tão avançados e especialistas em tal profissão, que quando acontece algo básico, como um simples enxergar o ambiente resolveria, ficamos todos perdidos dentro de nossas próprias mentes.” Ou seja, ficamos tentando resolver de modo avançado, mas o problema é algo básico.

Bom quaisquer coisas estamos aqui para tentarmos nos ajudar!

:vulcan_salute:t2:

5 curtidas

Belas palavras e história mano, por mais pessoas como você.
No meu antigo ath9k, wifi desligava quando eu usava algo que puxava muito ele, tipo abrindo a steam ele desligava e ligava novamente (no Windows).
Já nesse ath10k não acontece nada no Windows, porém no Pop OS ele desligou quando eu estava jogando, o que deveria estar exigindo muito dele e o Pop OS tem o ath9k que comprova meu ponto.

2 curtidas

Entendo.

Você chegou a tentar atualizar o firmware pelas configurações do Pop OS?
Pelas pesquisas que eu fiz, ao atualizar o firmware o driver ath10k instalava.

1 curtida

Desculpa a demora.
Gerenciamento de firmware indisponível
Não foram detectados dispositivos com suporte para atualização automática de firmware.
E também o backports-iwlwifi-dkms é importante? Notei que não tenho ele instalado.

1 curtida

:wave:t2: Sem problemas!

:thinking:Eu não tenho certeza sobre este, eu preciso pesquisar sobre.
Pelo nome ele tem relação com WiFi mas, é melhor confirmar. Irei pesquisar para ver se eu consigo algo.

1 curtida