Estou com um problema depois de instalar algo

Eu estou usando o Pop_OS! 20.10 e tentei instalar um Desktop Enviroment chamada “Ubuntu DDE”, mas ele tá dando um certo problema no meu PC. Por causa dele eu não consigo instalar nenhum app se quer, e quando eu tento ele me retorna esse erro.

Quando eu retorno o “sudo apt --fix-broken install” ele me retorna esse erro.

Quando eu tento dar um "sudo dpkg --configure -a ele me retorna esse erro.

Só queria instalar meu app. Poderiam me ajudar?

O ambiente que você está tentando instalar tem pacotes que conflitam com pelo menos um que você já tem instalado aí no sistema, aparentemente, algo do KWin, o gerenciador de janelas do KDE Plasma. É isso o que o apt está lhe dizendo. Cuidado para não quebrar seu sistema. Eu removeria os pacotes do DDE (são aqueles três citados no primeiro erro) e repensaria a decisão de experimentar o ambiente (talvez brincar numa VM antes).

sobre esse bagulho dá VM, vou tentar mesmo meu PC tendo 4GB de RAM :sweat_smile:

Quando tento remover os pacotes UbuntuDDE eles me retornam um erro.

Precisa remover o dde-daemon e o startdde também.

Ele diz que os pacotes não existem.

Diz que não existe. E quando eu tento instalar o tal do dde-kwin me retorna esse erro.

Olá @Guztaver tudo beleza?

Os primeiros dias após migrar de um sistema operacional para outro sempre é de descobertas, algumas vezes, meio dolorosas. :slight_smile:

Possivelmente, a forma mais eficiente de corrigir o problema seria reinstalar o Pop!OS formatando apenas o “/” - a partição principal onde o sistema operacional é instalado. Usando muito “dpkg” acredito que seria possível corrigir também, mas vai levar um tempo, considerando a quebradeira que tentar instalar o DDE gerou.

Via de regra, você pode instalar qualquer ambiente gráfico no Pop, mas ele é “pensado” para o Gnome, então, se você realmente deseja usar o DDE recomendo testar o Ubuntu DDE Remix ou o próprio Deepin em si.


Se quiser seguir tentando corrigir o problema na unha, recomendo usar os seguintes comandos:

apt info (nome do pacote)

Que irá mostrar todas as dependências e pacotes relacionados, aí você executa um:

apt purge --autoremove (nome dos pacotes que você identificou)

Isso provavelmente irá remover os pacotes indicados e todas as dependências que não forem mais necessárias no sistema.

:vulcan_salute:

2 Curtidas

Bom, então vou formatar por completo.

Agora, pelo que eu ví, o Deepin tá se voltando para o mercado chinês, isso poderia me acarretar em algum problema futuro?

Se der, vou pro Mint, se não der, vou pro Deepin

Então, eu acho que é muito importante procurar distribuições com comunidades fortes no Ocidente, pois facilita muito na hora de buscar informações e resolver possíveis problemas. Observe que qualquer distribuição com apt pode sofrer do mesmo problema. É por isso que é preciso ter muito cuidado na hora de adicionar repositórios de terceiros nessas distros.

1 Curtida

Então eu vou de Linux Mint mesmo.