Estou com problemas quando vejo videos no ubuntu 19.04

quando eu vejo algum video no youtube ou quando vou assistir um dilme, sempre que acontece um movimento vertical fica meio q cortando a imagem, tipo alguns jogos quando vc n usa o v-sync, o q eu posso fazer para consertar isso? (pelo q eu estou notando só acontece em tela cheia)

Qual seu ambiente gráfico? Acho que mexendo nas configurações do compositor vai resolver.

1 Curtida

meu ambiente gráfico é o GNOME

Opa!
Belesma?
Se estiver usando o Google Chrome, pesquise nas configurações por aceleração.
Desative a opção de Usar aceleração de hardware quando disponível.

Feche o navegador e abra o novamente.

Se o problema persistir, leia e execute as dicas numeros 4, 6, e 8 desse artigo que o @henriquead7 escreveu:

Se seus drivers forem Intel, leia e execute a dica número 7.
Se tiver vídeo da NVidia, leia e execute a dica número 9.

2 Curtidas

Somente em vídeos? Se sim pode ser relacionado ao navegador se não, talvez tenha que criar um arquivo de configuração do xorg, para remover o Screen Tearing:
Tem um tutorial pelo terminal mas é possível pela interface gráfica:

CASO USE INTEL/AMD

  1. Abra o gerenciador de arquivos da sua interface gráfica :slight_smile:

  2. Procure no seu gerenciador de arquivos para reabrir o gerenciador de arquivos como ROOT e digite a sua senha (no meu caso eu uso o Thunar):

  3. Agora abra um editor de arquivos na pasta /etc/X11/xorg.conf.d/ (Se a pasta não existir é só criar :wink:)

Agora vem a parte mais importante :smile:

Se usa alguma placa de vídeo da AMD nomeie o arquivo como 20-amd.conf:

Agora abra o arquivo e cole isso depois salve o arquivo e reinicie a máquina:

Section “Device”
Identifier “Radeon”
Driver “radeon”
Option “TearFree” “on”
Option “DRI” “3”
EndSection

Se usa placa de vídeo onboard Intel nomeie o arquivo como 20-Intel.conf:

Agora abra o arquivo e cole isso depois salve o arquivo e reinicie a máquina:

Section “Device”
Identifier “Intel Graphics”
Driver “intel”
Option “AccelMethod” “sna”
Option “TearFree” “true”
Option “DRI” “3”
EndSection

CASO USE NVIDIA

Se usa placa de vídeo Nvidia com o próprio utilitário nvidia-settings é possível resolver, na aba XServer Display Configuration procure por Advanced:

E selecione a opção Force Full Compositor Pipeline, e salve o arquivo de configuração do Xorg no botão Save to X Configuration File

Caso não tenha a opção Force Full Compositor Pipeline no seu nvidia-settings (como meu caso), adicione na sua Sessão e Inicialização da sua interface gráfica esse comando:

nvidia-settings --assign CurrentMetaMode=“nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }”

Fontes ou caso queira fazer pelo terminal :smile: (caso use placas de vídeo AMD/Intel)

2 Curtidas

Eu acredito que consigo lhe dar a solução se vc me fornecer as seguintes informações : 1- Qual o seu processador? 2- Os vídeos estão com esse problema em algum player ou navegador?

1 Curtida

Veja se resolve:
http://ubuntuhandbook.org/index.php/2018/07/fix-screen-tearing-ubuntu-18-04-optimus-laptops/

1 Curtida